jEdit Community - Resources for users of the jEdit Text Editor
Macro for removing '\0' possible?
Submitted by labidus on Friday, 9 March, 2012 - 01:20
i got a problem by using reload with encoding from UTF-16 to UTF-8, finally I reloaded with US-ASCII

My ASCI file now have a lot of wrong character, 1/2 of the character are useless, basically I need to find the bad character
and replace them with a "" empty char, to restore the file.

I say character '\0' need to be removed but its maybe another number, but the character is lower then space, so in the editor
it seam ok but you need to move the cursor 2 times to actually change to the next character.

Anyway, what i am trying to use is that right now


But the character \\0 generate a javascript error

thank you, btw I really like this editor, i am using it on my mac for a game project!
Mouse Speed Halved?
Submitted by stretch6555 on Tuesday, 13 March, 2012 - 06:02

I have this strange but really annoying problem with JEdit 4.5. Everytime a JEdit dialog box of any kind appears (for example, the Find/Replace dialog), the speed of my mouse is halved. Every time this happens, I have to go to my Windows 7 Control Panel and set the mouse speed back to its original speed (the maximum, which is what I prefer). Why is this happening? Is this a bug?
Copy on select
Submitted by rovf on Tuesday, 13 March, 2012 - 12:41
Is there a plugin which would automatically copy a selected text to the clipboard (i.e. without hitting Control-C), and insert the text using middle click of the mouse? Ideally this should work on Windows7 and MacOSX.
Whitespace plug-in in v4.5
Submitted by CJreige on Tuesday, 13 March, 2012 - 15:41
Hi everybody.

I've upgraded to version 4.5 and I've only encountered a single issue. My Whitespace plug-in does not work and I've had to uninstall it. Now it does not even install. Has anyone else come across a similar problem? Any thoughts on a possible solution?

How to get a function list of a JavaScript file with jEdit's Sidekick on a Mac?
Submitted by Ton on Wednesday, 14 March, 2012 - 13:57
I have a Mac with jEdit 4.5 installed on it, including the Sidekick and the JavaScript plugin from [1]. Now when I open the Sidekick window, I can choose from two JavaScript parsers (skrul-xml-javascript and skrul-javascript).

However, none of them parses my JavaScript file (the window only shows the document name with "Not parsed" underneath it). When I open a PHP file and choose my PHPParser, it does parse the file and shows clickable PHP function names.

Does anybody know what might cause this and/or how it can be solved?

Buffer options - syntax highligting not preserved on reload
Submitted by Cheruvim on Thursday, 15 March, 2012 - 15:14
Hey all,

I'm not sure if this is a bug or not, so I will open up a discussion here to point it out.

It seems that if you change the buffer option, specifically, syntax highlighting and then an external program (like say svn or git) changes the physical file on the file system, jedit will ask you if you want to reload the file. When you do, the highlighting reverts back to whatever the global settings are. Shouldn't it preserve what the buffer settings are if they are meant to override the global?

To reproduce this.

1) open a file type that uses a specific syntax highlighting (like C++ or PHP)
2) change the buffer options to use a different highlighting (Java or Perl)
3) change the file outside of Jedit
4) Bring Jedit back into focus and either agree to have it reload the file (I have it set to prompt) or watch it reload (if you set it up to do so automatically [haven't tried this]) and you should see the highlighting revert back to the global options.

No graphic display (window) when starting jedit - java process hangs
Submitted by rdehmel on Thursday, 15 March, 2012 - 15:57
I have just installed jre 1.6 on my very very old Linux box. Suse LinuxEnterprise 1.0 (SLES Cool

de/jedit> java -version
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b04)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)
de/jedit> uname -a
Linux atgws-rdl 2.4.19-64GB-SMP #1 SMP Mon Oct 21 18:48:05 UTC 2002 i686 unknown

When I try to install jedet the graphic window does not popup. One of the java processes uses 100% CPU time.

Trying text mode -> Installation of jedet is OK!

Trying to start jedit same as above: No window and one of the java processes uses 100% CPU time.

All other graphic stuff is fine on the linux box.

Any idea?

PS: I love jedit, because I use it already on windows.

recover the path file
Submitted by maximeD on Sunday, 18 March, 2012 - 22:42
Good evening all,

I test currently to developpe a small plugin, and I'm stuck on one small point:

I would like to recover the current file path , how could I achieve that?

thank for your help
Voxspell for other language ?
Submitted by jojaba67 on Thursday, 22 March, 2012 - 19:34

I installed Voxspell (a very old plugin but still working). Unfortunately, only english language is checked. I looked for infos on the Web but didn't find anything about that. I just saw that the dictionnary that is used is called en.spl.
My question : can I replace the en dictionnary by a french one without changing anything of the rest of the plugin (I'm not a java coder) ?
If yes, where can I find this fr dictionnary ?

Thanks in advance.
Zend framework tool command wrapper ( v0.1 by Tom Power)
Submitted by tp21 on Sunday, 25 March, 2012 - 10:20
Macros to wrap the zftool commands if you don't feel like typing them
jEdit 4.5.1 is out!
Submitted by Vampire on Tuesday, 27 March, 2012 - 15:51
Hi all,

I proudly present jEdit 4.5.1, the latest stable release of the 4.5 series of jEdit.

Detailed changes can as always be found in the Change Log at
This release is a bugfix release.

Volunteers are always welcome to contribute to the future of jEdit:

That being said, here is the download link:

FYI, merge requests for the 4.5 series (fix done, but waiting for a review) can be found at:

Have fun with the new release.
newbie problem-Help! fonts don't work
Submitted by cristyla on Thursday, 29 March, 2012 - 13:46
Hello, I am new in using Jedit, and for some reason my Jedit doesn't like any foreign fonts-more specifically french accents, and greek. They are not displayed as they should be. Can anyone guide me on how to fix this? thanks!
Right Gutter/Column That Shows Selection Locations - Looking for it
Submitted by hurricanedavid on Thursday, 29 March, 2012 - 17:09
How do you activate the thin column that is on the right of the editing space, next to the scroll bar, that will indicate all other occurrences of the selected word? I find that invaluable.

I stumbled upon it by accident before, but my settings folder got erased and I have to start over. I don't know what it's called, or if it is a plug-in or what.
additing multiple background colours
Submitted by milindvel on Monday, 2 April, 2012 - 12:20
I am using Jedit & found it very helpful in writing c progs.
I request to add one facility.
At present Background colour of the "c" file is user changable but it is same for entire file.
I wish to have different colours (user settable) so as to identify different functions, calls,subroutines.
This is necessory especially for long length c files.

I hope it will be useful to many other programmers/developers.

-Milind Velankar
Submitted by Skeeve on Saturday, 14 April, 2012 - 11:36

I'm using jEdit for ages now die about almost everything.

Recently I got the task to configure syslog-ng but I could not find anything for jEdit which would help me. Does anybody here know of any stuff which could be usefull? Edit modes? Macros?

Many thanks in advance.
jEdit hangs on Win7 32bit
Submitted by Dominicus on Tuesday, 17 April, 2012 - 05:37
I updated jEdit from 4.4.2 to 4.5.1 on Win 7 32-bit PC, and now my environment is toast.
Upon opening, gave me an I/O error related to "Sidekick". I uninstalled 4.5, and installed 4.4.2 back.
No luck.
I can open a file with code and move the cursor around, but as soon as I update anything (i.e. add or delete a single character), jEdit hangs.
I have to kill the process from Task Manager.
Tried uninstalling either of the two version and now both installations behave exactly same...hung after first interaction.
After uninstalling a version, I reboot to install another, and the install wizard tells me it needs to close an existing version of jEdit that's can this be, after I've uninstalled and rebooted?
I suspect there's a component or accessory to jEdit that both corrupted and persists even after uninstall.
any clue how I can fix my environment to successfully reinstall and start from scratch?
Default jEdit keyboard shortcuts conflict with OS X?
Submitted by patricksurry on Wednesday, 18 April, 2012 - 16:28
Sorry, this feels like a stupid question, but can't find an obvious answer anywhere.

I've recently moved from Windows to Mac and brought jEdit with me, and been confused about why the 'go to recent buffer' key wasn't working (command-`). Eventually discovered it was because OS X already uses that binding for 'show-next-application-window'.

Is there any standard set of OS X keybindings for jEdit that avoid these kinds of conflicts, or do I need to roll my own? Seems like something lots of OS X users would run into?

Disabling FTP/SFTP welcome message dialog
Submitted by rubio.terra on Thursday, 19 April, 2012 - 13:03
Is there a way to disable the FTP/SFTP welcome message dialog that pops out when connecting to a VFS using the FTP plugin? The problem is that every time a remote buffer is saved (Ctrl+S), the same nagging welcome message from the server appears.
JEdit Autodesk Maya Integration
Submitted by filmico on Friday, 20 April, 2012 - 14:33
Hello Guys,

My Name is Gerardo Sebastian Verrone; I am a TD specialized in rigging.

I have recorder and uploaded to youtube 10 videos Tutorials covering how you can install and configure JEdit to integrate it as an external code editor to work with Autodesk Maya.

This tutorials are up to date to be usefull for Maya 2011/2012/2013 or until Adesk change things drastically.

Trust me, you are not going to find videos out there explaining all this steps.

The tutorials are located here:

I'd like to thanks to the developer and maintainers of JEdit as it is a great application with many posibilities to expand it.


Gerardo Verrone
Issue running jEdit on Mac OS X 10.5.8 (Using OpenJDK7 bsd-port compiled against platform)
Submitted by jlove on Sunday, 22 April, 2012 - 09:11

I love jEdit and use it all the time on my standard Linux desktop however I've recently purchased a PowerMac G4 and have managed to compile OpenJDK7 against the platform. Great... now I can upgrade to the latest version of jEdit!! I downloaded the source and compiled against my platform but due to complications I have to explicitly set Djava.awt.false=false as an option when running jEdit.

Everything loads correctly and I can browse through the menu items, install plugins etc however the one thing which doesn't work is keyboard input into buffers. When I try to type into a buffer no text appears and instead the output is directed to the console.

Could somebody please help me understand what is happening and perhaps suggest any way of avoiding this issue? I'm not afraid to get my hands dirty in the code if it comes to that but I'd appreciate a starting point!

Kind Regards,

User login
Browse archives
« March 2012 »
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51172
Context Free Art (*.cfdg)   0.31   41265
JBuilder scheme   .001   17059
BBEdit scheme   1.0   16663
ColdFusion scheme   1.0   16640
R Edit Mode - extensive version   0.1   14942
Advanced HTML edit mode   1.0   14097
Matlab Edit Mode   1.0   14043
jEdit XP icons   1.0   13469
XP icons for jEdit   1.1   12492