jEdit Community - Resources for users of the jEdit Text Editor
Voxspell for other language ?
Submitted by jojaba67 on Thursday, 22 March, 2012 - 19:34

I installed Voxspell (a very old plugin but still working). Unfortunately, only english language is checked. I looked for infos on the Web but didn't find anything about that. I just saw that the dictionnary that is used is called en.spl.
My question : can I replace the en dictionnary by a french one without changing anything of the rest of the plugin (I'm not a java coder) ?
If yes, where can I find this fr dictionnary ?

Thanks in advance.
Zend framework tool command wrapper ( v0.1 by Tom Power)
Submitted by tp21 on Sunday, 25 March, 2012 - 10:20
Macros to wrap the zftool commands if you don't feel like typing them
jEdit 4.5.1 is out!
Submitted by Vampire on Tuesday, 27 March, 2012 - 15:51
Hi all,

I proudly present jEdit 4.5.1, the latest stable release of the 4.5 series of jEdit.

Detailed changes can as always be found in the Change Log at
This release is a bugfix release.

Volunteers are always welcome to contribute to the future of jEdit:

That being said, here is the download link:

FYI, merge requests for the 4.5 series (fix done, but waiting for a review) can be found at:

Have fun with the new release.
newbie problem-Help! fonts don't work
Submitted by cristyla on Thursday, 29 March, 2012 - 13:46
Hello, I am new in using Jedit, and for some reason my Jedit doesn't like any foreign fonts-more specifically french accents, and greek. They are not displayed as they should be. Can anyone guide me on how to fix this? thanks!
Right Gutter/Column That Shows Selection Locations - Looking for it
Submitted by hurricanedavid on Thursday, 29 March, 2012 - 17:09
How do you activate the thin column that is on the right of the editing space, next to the scroll bar, that will indicate all other occurrences of the selected word? I find that invaluable.

I stumbled upon it by accident before, but my settings folder got erased and I have to start over. I don't know what it's called, or if it is a plug-in or what.
additing multiple background colours
Submitted by milindvel on Monday, 2 April, 2012 - 12:20
I am using Jedit & found it very helpful in writing c progs.
I request to add one facility.
At present Background colour of the "c" file is user changable but it is same for entire file.
I wish to have different colours (user settable) so as to identify different functions, calls,subroutines.
This is necessory especially for long length c files.

I hope it will be useful to many other programmers/developers.

-Milind Velankar
Submitted by Skeeve on Saturday, 14 April, 2012 - 11:36

I'm using jEdit for ages now die about almost everything.

Recently I got the task to configure syslog-ng but I could not find anything for jEdit which would help me. Does anybody here know of any stuff which could be usefull? Edit modes? Macros?

Many thanks in advance.
jEdit hangs on Win7 32bit
Submitted by Dominicus on Tuesday, 17 April, 2012 - 05:37
I updated jEdit from 4.4.2 to 4.5.1 on Win 7 32-bit PC, and now my environment is toast.
Upon opening, gave me an I/O error related to "Sidekick". I uninstalled 4.5, and installed 4.4.2 back.
No luck.
I can open a file with code and move the cursor around, but as soon as I update anything (i.e. add or delete a single character), jEdit hangs.
I have to kill the process from Task Manager.
Tried uninstalling either of the two version and now both installations behave exactly same...hung after first interaction.
After uninstalling a version, I reboot to install another, and the install wizard tells me it needs to close an existing version of jEdit that's can this be, after I've uninstalled and rebooted?
I suspect there's a component or accessory to jEdit that both corrupted and persists even after uninstall.
any clue how I can fix my environment to successfully reinstall and start from scratch?
Default jEdit keyboard shortcuts conflict with OS X?
Submitted by patricksurry on Wednesday, 18 April, 2012 - 16:28
Sorry, this feels like a stupid question, but can't find an obvious answer anywhere.

I've recently moved from Windows to Mac and brought jEdit with me, and been confused about why the 'go to recent buffer' key wasn't working (command-`). Eventually discovered it was because OS X already uses that binding for 'show-next-application-window'.

Is there any standard set of OS X keybindings for jEdit that avoid these kinds of conflicts, or do I need to roll my own? Seems like something lots of OS X users would run into?

Disabling FTP/SFTP welcome message dialog
Submitted by rubio.terra on Thursday, 19 April, 2012 - 13:03
Is there a way to disable the FTP/SFTP welcome message dialog that pops out when connecting to a VFS using the FTP plugin? The problem is that every time a remote buffer is saved (Ctrl+S), the same nagging welcome message from the server appears.
JEdit Autodesk Maya Integration
Submitted by filmico on Friday, 20 April, 2012 - 14:33
Hello Guys,

My Name is Gerardo Sebastian Verrone; I am a TD specialized in rigging.

I have recorder and uploaded to youtube 10 videos Tutorials covering how you can install and configure JEdit to integrate it as an external code editor to work with Autodesk Maya.

This tutorials are up to date to be usefull for Maya 2011/2012/2013 or until Adesk change things drastically.

Trust me, you are not going to find videos out there explaining all this steps.

The tutorials are located here:

I'd like to thanks to the developer and maintainers of JEdit as it is a great application with many posibilities to expand it.


Gerardo Verrone
Issue running jEdit on Mac OS X 10.5.8 (Using OpenJDK7 bsd-port compiled against platform)
Submitted by jlove on Sunday, 22 April, 2012 - 09:11

I love jEdit and use it all the time on my standard Linux desktop however I've recently purchased a PowerMac G4 and have managed to compile OpenJDK7 against the platform. Great... now I can upgrade to the latest version of jEdit!! I downloaded the source and compiled against my platform but due to complications I have to explicitly set Djava.awt.false=false as an option when running jEdit.

Everything loads correctly and I can browse through the menu items, install plugins etc however the one thing which doesn't work is keyboard input into buffers. When I try to type into a buffer no text appears and instead the output is directed to the console.

Could somebody please help me understand what is happening and perhaps suggest any way of avoiding this issue? I'm not afraid to get my hands dirty in the code if it comes to that but I'd appreciate a starting point!

Kind Regards,

Search in directory encoding exception
Submitted by yohann.martineau on Thursday, 26 April, 2012 - 16:00
I try to use jedit to make recursive text search in all files in a directory.

When I perform a search, jedit complains about cp1252 encoding not applicable on pdf files. Yes, I'm on windows xp...

The file could not be loaded correctly (some data might be lost) with
the encoding "Cp1252".
(java.nio.charset.UnmappableCharacterException: Input length = 1)
Try selecting a different encoding.
It can be selected with the menu File->Reload with Encoding.
If you want it to be done automatically, add the candidates into
"List of fallback encodings" in Encodings pane of Global Options.

I don't understand why jedit tries to search in pdf files as pdf files are binary files. Does it try to extract text from pdf files and then apply an encoding to find text?

It seems that jedit can skip binary files, it seems to be an interesting feature, but I don't know how jedit considers files as binary. If I uncheck "skip binary files", the same exception pops out but for bin files, obj files, etc. I've been looking at the documentation, but cannot find anything about binary files association. I think this behavior is expected, but not very user friendly.

Is it possible to use jedit to search in all binary files as well?

Does it just try to decode the file using its default encoding (cp1252, I'm on windows xp) and considers the file as binary if it fails? (I guess it's not that simple)


How to submit an edit mode
Submitted by Skeeve on Sunday, 29 April, 2012 - 16:26

I just finished my LQL edit mode (for mk-livestatus). How can I submit it?
jEdit, Mac, Java 1.7+
Submitted by alopecoid on Monday, 30 April, 2012 - 15:10

Java 1.7 has been officially released by Oracle for OS X 64-Bit:

I have been attempting to get jEdit (4.5.1) running with this JVM without any success. When I modify JVMVersion from 1.6+ to 1.7+ in /Applications/, I get an error "No compatible version of Java 1.7+ is available.". I have also tried setting this to the exact version number.

You will see here that I have Java 1.7 installed correctly:

/usr/libexec/java_home --verbose

Matching Java Virtual Machines (5):
1.7.0_04, x86_64: "Java SE 7" /Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home
1.6.0_31-b04-413, x86_64: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0_31-b04-413.jdk/Contents/Home
1.6.0_31-b04-413, i386: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0_31-b04-413.jdk/Contents/Home
1.6.0_31-b04-413, x86_64: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
1.6.0_31-b04-413, i386: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home



echo ${JAVA_HOME}


Also, Java 1.7 is even set as the default:

java -version

java version "1.7.0_04"
Java(TM) SE Runtime Environment (build 1.7.0_04-b21)
Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)

I have been running jEdit on Linux (Ubuntu) and Java 1.7 for quite some time without any major issues.

Any ideas?

Thank you.
add a line to every line in a file?
Submitted by jbrave on Tuesday, 8 May, 2012 - 03:14
I want to take a text file which is a program source, and insert a print statement after each line, for example if line 1 is:


then insert
print "line 1: x=5"

so that when a program crashes hard (as in, the system reboots before I can see what happened) at least I can see the last line that executed.

Is there some kind of macro or plugin that I can use to do things like that?


- Joel
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:19
When large input data are entered in a new file, the heap gets out space and displays an beanshellerror message which is not user friendly message. Also in the the beanshellerror message the text is typable.

Expected Results:
Appropriate user friendly error message should be appeared and in the error message text should not be typable.

Test Enviroment: OS: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:32
When a file is printed, the filename also appears at the top of the page.

Expected Result: Application should be able to send the print command which should print only the contents of a file

Test Enviroment: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 15:08
If multiple files with different files format is opened then an error message appears that does not fit to screen.

Expected Results: The list of error message should be able to fit on screen so that user can click on OK button.

Test Enviroment: OS: Windows 7, 64-bit
font size of tags plugin dialog
Submitted by wkevils on Thursday, 10 May, 2012 - 18:04
I used to have and use quite and old release of JEdit (4.2.0)
I am trying now latest 4.5.3.
I am not satisfied with the font size of tags plugin dialog - it is to much large
in my feeling. In the previous JEdit I used (4.2) It was ok.
Is there a way to make this font smaller ?
User login
Browse archives
« March 2012 »
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51053
Context Free Art (*.cfdg)   0.31   41260
JBuilder scheme   .001   17052
BBEdit scheme   1.0   16658
ColdFusion scheme   1.0   16636
R Edit Mode - extensive version   0.1   14919
Advanced HTML edit mode   1.0   14092
Matlab Edit Mode   1.0   14037
jEdit XP icons   1.0   13463
XP icons for jEdit   1.1   12487