jEdit Community - Resources for users of the jEdit Text Editor
Hypersearch results analysis ( v1.0 by Thiemo Kellner)
Submitted by Robert Schwenn on Thursday, 13 April, 2017 - 21:04
Two neat macros to analyse hypersearch results:

- hypersearch_results_distinct_hits.bsh: extracts the distinct lines in the results
- hypersearch_results_files.bsh: extracts all the files results were found in

! Note that these macros depend on:
- other macro "Misc/HyperSearch_Results_to_Buffer.bsh"
- TextTools Plugin

Also, see original post:
jEdit Server on OSX
Submitted by RobertX on Friday, 21 April, 2017 - 00:26
When I run jEdit on Windows, I create a shortcut and put it in the Startup folder that runs the jEdit server in the background. I have zero idea on how to do this on MacOS. Any help?
jEdit hangs when using multiple screens
Submitted by rursus on Friday, 21 April, 2017 - 12:17
Hi! Jedit version tested: 5.4.0 (compiled from source) Java version: java-1.8.0-openjdk-amd64 (Debian) I have tried to find any relevant info by googling, but I couldn't find any: * Whenever I run jedit on a single screen, there are no problems, and life is happy and the sun shining. * Whenever I run jedit on a computer using multiple screens, jedit cannot be started, or if it is already started before, and the second screen is attached afterwards, jedit refuses to open any new windows. When refusing to open any window, jedit says: 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: Exception in thread "AWT-EventQueue-1" 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.image.ReplicateScaleFilter.( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at sun.awt.X11.XToolkit.createCustomCursor( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.textarea.TextAreaPainter.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Container.addNotify( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at javax.swing.JComponent.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.textarea.TextArea.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Container.addNotify( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Window.pack( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.jEdit.newView( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.PerspectiveManager$PerspectiveHandler.endElement( Which obviously means that when jEdit makes a newView, it obviously triggers a TextArea.addNotify which triggers a TextAreaPainter.addNotify, which somehow delivers a window with a size of 0,0. I'm inclined to hack this in my personal copy of jEdit, if possible. Anyone have an idea why this occurs?
Write current date/time to a file as it is saved
Submitted by jhaefner on Sunday, 23 April, 2017 - 01:00
I am writing html and would like to write "Updated: ...the date of last modification.." on to the html file in a particular place. So, after testing that the file has been modified, I would like to write the current day and time to the file immediately after I tell Jedit to save the file, but before it is actually saved. Possibly, the solution would be to point my usual "save file" shortcut to a macro that writes the date/time info where I want it and then does the jedit save file command. Has anyone done this? If not, can any one point me in a direction to get me started? I have done simple ".bsh" macros, but nothing more complex. I am aware of Robert Schwenn's 2008 "insert_simple_date.bsh".

Thanks in advance. Jim
ReadOnlyBuffer (Macro) not working with jEdit 5.4
Submitted by Hans_Bauer on Friday, 19 May, 2017 - 11:30
Using the MacroManager i downloaded the "ReadOnly Buffer"-Macro and associated a Toolbar-Icon with it.

The Macro does not seem to do anything in jEdit 5.4.

Possibly there is a code change in jEdit, because my own-written macro "ToggleReadOnlyBuffer" also stopped working after the update from jEdit 5.3 to 5.4.

Any idea to update the macro "ReadOnly Buffer"?

Thanks Hans
(Windows) unable to release Ctrl+Alt+J hotkey for usage
Submitted by 1234ru on Wednesday, 24 May, 2017 - 19:21
Ctrl+Alt+J is bound to start jEdit when it is installed (which was pretty surprise by itself and was discovered accidentally). I need this combination for another program, so I went to "Start jEdit" shortcut's properties and reset the "Shortcut key" property to a blank value.
However, the hotkey still remains bound to starting jEdit (which happens when I press the keys), although the property of a shortcut is displayed as a blank value.

How can I get rid of it?
Windows 7 Install problem: The installer will now try to quit a running instance of jEdit, when there is no running instance..
Submitted by JimParinisi on Tuesday, 4 July, 2017 - 23:04
I have been running jEdit 5.3 for about a 1.5 years with no significant problem. On 2017-07-03 I used it and it worked fine. On 2017-07-04, It would not start. jedit and javaw exe's were created, but jEdit window would not display. I uninstalled version 5.3 and tried to install version 5.4 and got this error:
The installer will now try to quit a running instance of jEdit.
Please save your work and exit jEdit for the installation to continue.
The installer hangs up at this point.
I did not have a running instance, but the installer thought that I had one. I am guessing that something went wrong with jEdit when I shutdown on the 3rd. Does anyone know how to tell windows 7 to get rid of this phantom instance of jEdit. I am using a backup version of jEdit 4.5.2 for the time being. So, I can continue with my work. I am guessing that this phantom instance also caused the jEdit 5.3 startup problem that I had before the uninstall.
When will jEdit be cleared to use Java 9?
Submitted by jrs40 on Thursday, 18 January, 2018 - 15:06
I cannot use jEdit with Java 9. I am running a Windows 10 x64-x86 box. When I click on any shortcuts that start the jEdit.exe program I get a message stating that i need a Java 1.8.x JRE and then am sent to a java Website to download the appropriate JRE. How do I inform the jEdit.exe program tjat java 9 is a valid java installation? Failing that, when can I expect to see a version of jEdit compatible with Java 9? Remember, Java 8 is officially unsupported as of October 2018. I do not look forward to creating form my own use some sort of script to run on a Windows 10 box to emulate the jEdit.exe program.
Highlight Plugin: What does the "Highlight overview" setting do?
Submitted by rovf on Friday, 18 May, 2018 - 10:27
The option settings for the "Highlight Plugin" named "Highlight Overview". What exactly is controlled with these settings?
Jedit 5.4.0 - hi CPU usage when text is selected and windows put to back
Submitted by edinburger on Thursday, 24 May, 2018 - 12:10
I'm facing a strange behavior with Jedit 5.4.0

If I select some text in jedit, put another App in front of jedit then bring jedit back to the front by clicking on the jedit taskbar icon then Jedit (java process) starts consuming lots of CPU (up to 40% on a 2 core i5 system)
CPU utilization will only go down if I either click into the Jedit window or any of the Menu items.

disabling all Plugins did not help

I'm running Jedit under Win 10, java version "1.8.0_171"
User login
Browse archives
« April 2017 »
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51173
Context Free Art (*.cfdg)   0.31   41266
JBuilder scheme   .001   17059
BBEdit scheme   1.0   16663
ColdFusion scheme   1.0   16640
R Edit Mode - extensive version   0.1   14942
Advanced HTML edit mode   1.0   14098
Matlab Edit Mode   1.0   14044
jEdit XP icons   1.0   13469
XP icons for jEdit   1.1   12493