jEdit Community - Resources for users of the jEdit Text Editor
Trouble building jEdit in Eclipse
Submitted by kenmcfa on Saturday, 10 October, 2009 - 23:32
Hi, I'm trying to built the latest trunk of jEdit in Eclipse. I checked it out from the sourceforge SVN, and then imported it as a new project from the ant buildfile. However doing so gives me loads of problems. A lot of them are complaining that various imports cannot be resolved. I *can* fix these by importing the appropriate .jar files on the build path. This fixes those errors, but I also get package related errors such as "The declared package "macosx" does not match the expected package "jars.MacOSX.macosx"" I could fix these by replacing the package declarations, but surely this isn't necessary? Is it possible that I've set something up wrong?

Any help would be much appreciated.
User login
Browse archives
« January 2018  
MoTuWeThFrSaSu
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   50945
Context Free Art (*.cfdg)   0.31   41166
JBuilder scheme   .001   16997
BBEdit scheme   1.0   16596
ColdFusion scheme   1.0   16582
R Edit Mode - extensive version   0.1   14862
Advanced HTML edit mode   1.0   14043
Matlab Edit Mode   1.0   13979
jEdit XP icons   1.0   13412
XP icons for jEdit   1.1   12435