jEdit Community - Resources for users of the jEdit Text Editor
jedit debian packages are not installable on debian testing
Submitted by Archimedes on Monday, 10 May, 2010 - 16:28
The debian packages of jedit (4.3.2) cant be installed with dpkg (im at debian testing and dpkg 1.15.7.1). The error is:

...
parse error in file '...' near line 7 package 'jedit'
duplicate value for 'Architecture' fiels
...

My last "install" time was the 4.3(.0) version, so i tried that deb, which results in the same error. For completness i checked the 4.3.1 version also, same result.
It seems that a change in dpkg causes this new more strict behaviuor.

The fix is quite simple:

I extracted the deb file and the "rules" stuff
mkdir jedit
dpkg -x jedit_4.3.2_all.dep jedit
mkdir jedit/DEBIAN
dpkg -e jedit_4.3.2_all.dep jedit/DEBIAN

remove the second "Architecture" line in the jedit/DEBIAN/control file and build a new one:

dpkg -c jedit

The resulting jedit.deb is installable without the error.
Replicating installations
Submitted by alsdias on Wednesday, 28 April, 2010 - 14:06
Suppose that you already have an installation containing your plugins and configurations.
If you desire to replicate this installation to another machine, for instance a virtual machine, without having to do everything again, there is an alternative that works well if the new installation has the same path of the old. If not, some path adjustments may be necessary according to your environment.

1. Install jEdit as usually.
2. Copy the jEdit's user configurations under .jEdit folder overwriting the content of the respective .jEdit folder of the new installation.
For instance, on Vista you find .jEdit folder configuration under C:\Users\User_Login\.jedit, and on XP under C:\Documents and Settings.
3. Copy the full content under the INSTALL_DIR/jEdit, overwriting the full content of the respective INSTALL_DIR/JEdit of the new installation.

It's ready to run.
I use this procedure to replicate my jEdit's intallations on virtual machines.
Re-installing jEdit 4.2 with appropriate plugins
Submitted by Kuba on Monday, 29 March, 2010 - 23:34
Hi,

I'm looking to re-install jEdit 4.2 with a working Jython Interpreter and am running into problems. The reason I'd like to do this is because the current Jython Interpreter seems to have problems with jEdit 4.3.1 -- http://community.jedit.org/?q=node/view/4354.

On an old computer I have jEdit 4.2final which still works with the Jython Interpreter I installed with it a few years ago. When I copy the jEdit 4.2 folder to my new computer, all the plugins are gone. Where can I find the plugin files on my old computer (Mac powerbook, OS 10.4.11)? Spotlight search for "jython" yields nothing.

Alternatively, I still have the jEdit 4.2 DMG installation file and can re-install. But the plugin manager for 4.2 has a very limited list of plugins available for installation, and I'm having trouble installing Jython Interpreter manually. I've downloaded it from the current Plugins page, copied the .jar files into the jars folder, but I get a string of install messages that lead me to install ErrorList and then Sidekick, which, finally, does not seem compatible with my program.

So, does anyone out there know how to run Python macros in jEdit using Jython Interpreter either in jEdit 4.3.1 or 4.2?

Many thanks in advance for your suggestions!
Kuba
Possible Installation/Permissions Problem?
Submitted by Stuart on Monday, 15 March, 2010 - 00:04
Hi,

I just upgraded to a new Intel Core i7 machine running Windows7 64 bit and reinstalled jEdit.

However, although jEdit starts and runs, I find that if I open a file to edit and then make changes
I am unable to save the file, getting instead a

Cannot save: java.io.IOException Rename failed error.

Since there seems to nothing magical about the file itself (generated text from a Matlab program that can be opened in other text editors and the same behavior occurs when attempting to edit other
txt files), I am inclined to believe that I may have some time of permission error or User Account error going on here that may resulted from settings during my installation in the windows 7 environment.

Curiously, the file name when given is surrounded by # signs rather than the simple string in the error message.

ie:

C:\...\Morphometrics\Ves_iso.nts:
leads to
Cannot save: java.io.IOException: Rename failed: C:\...\Morphometrics\#Ves_iso.nts#save#

Not sure if this is a clue as to what might be failing, but it does suggest something odd that I don't understand that may be related to the problem.

Has anyone else experienced a similar problem and might someone be able to offer and explanation as to the possible nature of this problem and suggestions for a fix?

Thank you.

Stuart
Getting past installation
Submitted by okfqcnpe on Thursday, 4 March, 2010 - 17:29
I like the idea of jEdit and it really appeals to me, especially the portability. Is there any way for me to make it a simple executable jar file that i can run on any java-compatible platform? I want to be able to place it in my external hard drive so if i ever need to borrow a laptop, i can simply plug my hard drive in and start coding. I scanned the Install.java file and saw that every installation checks the current OS and installs based on that. Is there anyway to skip the install part and just compile an executable jar?
Portable version of jEdit for Windows
Submitted by wpp-dev on Friday, 15 January, 2010 - 22:34
Hello,

I'm a winPenPack.com developer.
winPenPack ( http://www.winpenpack.com and http://sourceforge.net/projects/winpenpack ) is a collection of open source portable programs for Windows, optimized for use with a USB pen drive or any portable device and also directly from Hard Disk.

I'd like to signal you that we have developed a portable version of jEdit for Windows, called X-jEdit, in winPenPack.com Format: http://www.winpenpack.com/main/download.php?view.840 . You have just to download the .zip archive, uncompress it and double-click on X-jEdit.exe

Obviously, any suggestion or feedback will be welcome! Smiling


______________________________________

TECHNICAL DETAILS:


1 - at X-jEdit first run, the Java Runtime Environment (JRE) is automatically downloaded and extracted in X-jEdit\Lib\Java\ folder (but only if JRE is not present in this directory). In this way anyone can use jEdit even if Java is not installed in the host pc;

2 - the "-Duser.home" parameter has been set: all settings are stored in \User\jEdit directory instead of %USERPROFILE%\.jEdit folder;

3 - all paths of recent files (if the files are saved in \Bin\, \User\, \Lib, \Documents, \Downloads or \Backups directories) are normalized when the drive letter or the software position changes;

4 - all paths included in "history", "properties", "recent.xml" and "perspective.xml" are normalized when the drive letter or the software position changes;

5 - the "backup.directory" has been set.
jedit update from 4.2 to 4.3
Submitted by SchusterHannes on Sunday, 10 January, 2010 - 20:27
Hello,

I have just installed jedit and am thrilled with the software and appreciate this very much. Now I have installed 4.2 on Suse yet, because the management was included in the package.

How can I jedit update from 4.2 to 4.3??

Or do I install 4.3 from scratch??
How can I install the software from the Sorce code in Suse??

Gruß Ralf
Beginner's problems in setting up localhost preview
Submitted by d_l on Sunday, 3 January, 2010 - 17:43
Beginner's problems:-

I have installed JEdit to experiment as a cross-platform editor for both *.php and *.lzx (XML format with *.dtd validation).

My OS is Windows Vista.

I guess that I need to setup several projects to test code on different localhost servers:

apache httpd on port 8080
apache tomcat on port 8090
caucho resin on port 8100

Installed plugins ..

PHP Parser
Project Viewer
SQL
XML


But I cannot get started with even the basics of setting JEdit to launch phpinfo.php in localhost mode. http://localhost:8080/test/phpinfo.php (this URL runs o.k. when manually pasted into any browser. I can also preview this same simple test file in editors other than Jedit.


The phpinfo.php test file is located in:

C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\test\phpinfo.php



I created a simple test project "phpinfo" and in Project options I have

Project name: phpinfo

Root Directory: C:\Program Files\Apache Software Foundation\Apache2.2\htdocs (note: excluded the \test\ folder)

Web root URL: http://localhost:8080/



But I cannot preview this phpinfo.php from Jedit to browser !

When I right click phpinfo.php in project phpinfo in Project Viewer and select "Preview in browser" I get a popup error message:-

Cannot run program "mozilla": CreateProcess error=2, The system cannot find the file specified. Please fix your external app configuration.

I have no external application associated with extension *.php.

Options: Plugins: Info Viewer: Choose Browser

external browser radio button selected.

but the command below reads ..

netscape -remote openURL($u) -raise


How do I set up an association with preview browser firefox.exe?

and how do I setup to switch preview between several different browsers?


firefox
Internet Explorer
Opera
etc.


Options: Plugins: Project Viewer: External Applications

what application(s) should I associate here with *.php (and other extensions)?

php.exe or php-win.exe or php-cgi.exe or firefox.exe .. or others?

If I associate *.php with another text editor that launches from Project Viewer.



Finally .. unrelated glitch. If I force shut down of JEdit using the [X] close top right toolbar button (which I should not use, I know) I see a very long (not wrapped) indecipherable error message in Jedit popup window ..

with separate Windows popup error message reading ..

"The color scheme has been changed to Windows Vista basic. A running program isn't compatible with certain visual elements of Windows".

This apparent incompatibility with Vista does not occur if I use the correct shutdown JEdit procedure of File > Exit. Not serious .. just annoying.
Windows 7 64bit, Java 1.6.0_16 64bit Server VM - jedit4.3pre17install.exe unable to locate VM
Submitted by jakbal on Wednesday, 28 October, 2009 - 17:17
Hello All -

First let me start off by stating that jEdit is fantastic tool, and that I use it religiously every day. I recently upgraded (installed rather, dunno if its an upgrade yet) to Windows 7 on my DELL XPS laptop and I'm having problems installing jEdit.

Java Version:

C:\Users\alex>java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

JAVA_HOME Definition:

C:\Users\alex>set JAVA_HOME
JAVA_HOME=C:\java\jdk1.6.0_16

JRE_HOME Definition:

C:\Users\alex>set JRE_HOME
JRE_HOME=C:\java\jdk1.6.0_16\jre

PATH Definition:

C:\Users\alex>set PATH
Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\java\jdk1.6.0_16\bin;

When I run the jedit4.3pre17install.exe I first get the Windows 7 box asking me if I want to allow this .exe to modify my system, and I say yes. I then get the jEdit language selector for the installer, and this also works fine (I can select languages, etc). Then I choose to continue and I get this error message:

"Setup was unable to find an installed Java Runtime Environment or Java Development Kit of version 1.4 or higher.
You must have installed at least the JDK or JRE 1.4 to continue setup.
Please install one from http://java.sun.com and restart setup."

Advice?
after installing red dots and blue line in editore
Submitted by Dshah on Saturday, 10 October, 2009 - 17:19
Hi i am new to jedit and just installed jedit version 4.3 on windows 7. now i have three problems.

1. there are red dots on every line
2. there is one blue horizontal line on middle of the page.
3. i installed the FTP plugin but its not connecting to my server host.

Thanks for any help
Best Wishes
cannot download jEdit
Submitted by Pollyanna on Thursday, 24 September, 2009 - 15:32
When I try to download jEdit, I always get a message saying, "The "jedit-devel/4.3pre17/Packages.bz2" file could not be found or is not available. Please select another file."

I get this message regardless of what I try to download.

What am I doing wrong?
4.3pre17 crashes with Snow Leopard
Submitted by phemets on Monday, 14 September, 2009 - 08:42
Hi everyone! I recently switched to Mac after having used jEdit on Windows for years. Everything worked fine with 4.2, but using the touchpad for scrolling on Mac was a real show stopper. This should be solved with 4.3pre17, so I tried to install it. The first time I tried to start the Mac app the splash screen froze. Every subsequent time it stopped one second after starting. This happens both with the Mac OS App and jedit.jar from the Java-based installer. If I try 4.3pre16 everything works fine. Deleting the configuration directory doesn't help. Any ideas? Paul Error messages when trying to start jedit.jar: Error messages:10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.View.setSplitConfig(View.java:911) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.View.(View.java:1356) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.jEdit.newView(jEdit.java:2403) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.PerspectiveManager$PerspectiveHandler.endElement(PerspectiveManager.java:341) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endElement(AbstractSAXParser.java:601) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.dtd.XMLNSDTDValidator.endNamespaceScope(XMLNSDTDValidator.java:263) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.handleEndElement(XMLDTDValidator.java:2028) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.dtd.XMLDTDValidator.endElement(XMLDTDValidator.java:901) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEndElement(XMLDocumentFragmentScannerImpl.java:1774) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2930) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.util.XMLUtilities.parseXML(XMLUtilities.java:139) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.SettingsXML.load(SettingsXML.java:155) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.PerspectiveManager.loadPerspective(PerspectiveManager.java:104) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.jEdit$6.run(jEdit.java:3833) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.dispatchEvent(EventQueue.java:633) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188) 10:33:05 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.run(EventDispatchThread.java:122) Output of "java -version": java version "1.6.0_15" Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219) Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)
Getting jEdit started under Vista Home Premium
Submitted by Abbeyman on Friday, 11 September, 2009 - 09:57
Hi,

I want to operate jEdit on a Windows Vista Home Premium OS, installed latest JAVA environment and the latest jEdit. At double-klick the program does not start (even with administrator rights and simulating an WIN XP SP2 environment). Another post said you need to delete perspecitves.xml in the folder "Settings". Problem is, there is not such a folder, nor the xml-file. Does anyone has experience with operating jEdit under WIN VISTA Home Premium? It would be very sad to miss jEdit as it looks very promising.

Thanks in advance for any help & best regards from germany

Jan
Invalid initial heap size: -XmsM
Submitted by Claribob on Saturday, 5 September, 2009 - 14:10
Hi ! My OS is Fedora 10. I'd like to get Jedit up and running so I can use the Lilypond plugin. So, I followed instructions at the Lilypondtool web site: http://lilypondtool.organum.hu/86.html It told me to install Java Runtime 5.0 and gave instructions which I followed. Then to get Jedit 4.3pre16 or later. I downloaded 4.3pre17 It took me hours to finally get Java installed, I think. When I give this command in terminal: update-alternatives --config java I get a listing which shows three java files. The Plus (+) symbol is on jre1.6.0_16 and when I give this command in terminal: java -version it also lists jre1.6.0_16 This is what's it's supposed to be for Lilypondtool. Then I installed Jedit4.3pre17install.

But, when I try to run Jedit from terminal, I get the following: Invalid initial heap size: -XmsM Could not create the Java virtual machine. Anyone using Jedit in Fedora who can help me with this ?

RL
jEdit on Snow Leopard
Submitted by rrm74001 on Friday, 28 August, 2009 - 04:25
I plan on installing Mac OS X Snow leopard tomorrow. Does any one know how jEdit is going to react? I know jEdit is sensitive to Java updates, so I was just wondering if I should expect any problems updating the OS. I am going to school working toward a Computer Science major, so I NEED jEdit to work Laughing out loud.
After upgrading to jedit 4.3pre17 I have got font display problems
Submitted by tomasio on Tuesday, 11 August, 2009 - 14:38
After upgrading to jedit 4.3pre17 my preferred programming font ("Profont 12") displays wrongly in the editing window. It is antialiased although I defined not to use this feature in the JEdit Text Settings I found under Global Options. For a Screenshot click the link below:
Jedit Text Settings

The line numbers in the gutter left to the editing area display correctly, although using the same font, as seen in the next screenshot:
JEdit Editor Window

All this worked untill the last version (4.3pre16). I am running MacOS 10.5.8 on a MacBookPro, maybe this has something to do with my OS? Any advice would be very appreciated.
4.3pre17 forgets window position and size
Submitted by gsawyer9 on Wednesday, 5 August, 2009 - 17:41
I just updated my Windows XP jEdit from 4.3pre16 to 4.3pre17, and the new version doesn't remember its window size or position. I deleted my settings directory and let jEdit re-create it, but the problem persists. I assume that I've doing something wrong, but what?

Thanks,
Gary.
installed 4.3.17 and doesn't start up
Submitted by merrill77 on Friday, 31 July, 2009 - 15:47
I've been using jEdit for many years with no problems. I was using 4.3.15, I think, and wanted a plugin that required 4.3.17, so I installed the new version. When it starts, the splash screen gets up to the "run startup scripts" and then stops. I've installed in a new folder with the same result. I don't see any log files in the installation folder - is there anywhere else I can look to find out what is going wrong?

I have XP/sp3, Sun JDK6 default and other Sun JDKs (1.5, etc) installed.

Chris
ProjectViewer Plugin not available
Submitted by devashanti_om3 on Wednesday, 15 July, 2009 - 16:49
I just installed jEdit v 4.2 Final on a new machine. I have used jEdit for many years and I always install the ProjectViewer plugin, but it is not available in Plugin Manager for this version when I download the Plugins. I located it on a separate website and downloaded it but am not sure how to install it as I always used the jEdit Plugin manager in the past. I installed other plugins through jEdit's Plugin Manager and the option to have them installed to the jEdit settings directory was selected, but I cannot find the jEdit settings directory in the C:\Program Files\jEdit main directory anywhere. Can someone help me understand how to install ProjectViewer and why it is no longer included in the Plugin available through jEdit's Plugin Manager?
jEdit launcher, Mac OS/X, Java 1.5.0_19
Submitted by k.kelln on Monday, 22 June, 2009 - 19:29
I just upgraded my Macbook (OS/X 10.5.7) to Java 1.5.0_19 and my jEdit launcher stopped working. This happens everytime I update Java or Mac OS/X versions. I can fire off the jar version, but the normal launcher crashes and burns. Of course, with the jar version I lose the Mac specific interface. Ideas?
User login
Browse archives
« August 2014  
MoTuWeThFrSaSu
 
1
2
3
4
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   46310
Context Free Art (*.cfdg)   0.31   36834
R Edit Mode - extensive version   0.1   11048
JBuilder scheme   .001   10882
Advanced HTML edit mode   1.0   10500
BBEdit scheme   1.0   10446
ColdFusion scheme   1.0   10434
Matlab Edit Mode   1.0   10369
jEdit XP icons   1.0   9823
XP icons for jEdit   1.1   9750