jEdit Community - Resources for users of the jEdit Text Editor
Archives
How do I remove period (or dot) at every line?
Submitted by Ethien on Saturday, 17 May, 2008 - 10:40
How do I remove period (or dot) at every line?

jEdit is a good program that I would like to use in my future projects except for one feature that really bothers me a great deal. That is period or dot shown at every line. I could not find a way to disable that. I have checked every option there is. I am pretty sure I am missing an option somewhere to turn that off.

I would like very much to continue using the jEdit without having to see period/dot at end of line.

Thanks in advance!

~Ethien
An error at Jedit startup
Submitted by squier on Saturday, 17 May, 2008 - 13:46
I have installed Jedit v4.3 in my openSuSE v10.3 KDE system. Jedit does start, and immediately shows this error message:

------------------------
The following I/O operation could not be completed
home/user/Desktop/icon32.png
Cannot load with the encoding "UTF-8"
(java.nio.charset. MalformedInputException (Input length = 1)
.
.
.
-------------------------

If someone can tell me how to clear this error, I will be very grateful.

"icon32.png" is the filename of an icon that I tried (and failed) to associate with the script that calls Jedit.

If someone can also tell me why I am unable to substitute that, or any other icon for the generic one that the script now has, I would be even more so. When I open the Properties screens of the script, and try to drop an icon on the existing generic icon, the cursor changes to its "forbidden" form.
Usage of GUIUtilities.loadIcon
Submitted by Hamza on Saturday, 17 May, 2008 - 14:13
Hi folks,

I am trying to modify the QuickNotepad sources to add an extra button to the tool panel (QuickNotepadToolPanel.java) but whatever I do I can't seem to load a PNG file as the button icon.

I've added the following bit to QuickNotepadToolPanel.java to add the actual button:

add(makeCustomButton("msp430.foo", new ActionListener() {
public void actionPerformed(ActionEvent evt) {
QuickNotepadToolPanel.this.pad.foo();
}
}));

..and I have specified the icon files in the props file as:

QuickNotepad.foo.icon=foo.png
QuickNotepad.foo.label=Foo

the icon foo.png resides in the same folder as the java sources and the code compiles just fine but the icon is not loaded when I load the plugin and the button is just the size of a tiny dot.

If I specify an absolute path the code compiles but jEdit chokes on startup and I have to kill it.

Do I need to somehow specify the icon location in the build.xml file? Can I manually add the files to the jar itself?


Quite an easy question I guess but it has been driving me crazy so any comments/help much appreciated.


Cheers,
Hamza.
Need help with macro to toggle tab size
Submitted by ernest on Tuesday, 20 May, 2008 - 04:58
How would I create a macro to toggle the tab size between 4 and 8? I tried to start one by recording a macro while I changed the tab size using the buffer options dialog, but the resulting macro only showed this: new BufferOptions(view,buffer) - which just brings up the buffer options dialog. I'm not sure now how to proceed. I want to learn how to write good macros, and eventually plugins, so I'm hoping for advice rather than a complete solution. But any help at all will be appreciated.

Thanks,

Ernest
XPath tool is confused with namespaces
Submitted by eiku on Tuesday, 20 May, 2008 - 07:04
Hi

Is there a trivial solution for the XPath tool to recoginze and operate correctly with namespaces? For example, I have a XML document(WSDL file, I omit all the namespace declarations for better reading):

<?xml version="1.0" encoding="UTF-8"?>
  <wsdl:definitions ... >
    <wsdl:types>
      <xsd:schema ... > ... </xsd:schema>
    <wsdl:types>
  </wsdl:definitions>
If I try to execute XPath expression //types or //wsdl:types then an empty resutl is returned? As much as I know of XPath (and also experience from othe XML editors) there should be a single node as result. Is it just the the plugin is not usable or am I missing some other plugins or some knowhow (how to use jEdit).

Thanks for input,
Heiko

Embedding Java app inside dockable window
Submitted by donTomaso on Tuesday, 20 May, 2008 - 19:28
Hi!

How about making a plugin that can embed any jar-based java application inside a dockable window?
Maybe even using jdic? Or just something very basic configurable to use any application set by the user.

Isn't this something that could easily be achieved?

Regards,

Tomas
GUIUtilities.setIconPath doesn't work with pre14
Submitted by MichaelSchreiner on Thursday, 22 May, 2008 - 02:30
After updating from pre13 to pre14 my startup script containing:
GUIUtilities.setIconPath("jeditresource:iconfile.jar!/org/gjt/sp/jedit/icons/");
doesn't work any more, the icons are missing after jEdit startup.
The activity log shows no problems.
Move to text area from console
Submitted by ernest on Friday, 23 May, 2008 - 01:16
I have a macro that I use to save my current document to disk and then to the server on which I am required to launch builds. This all works fine. But when I do a save, the macro runs (running ssh) and the cursor ends up in the Console. How can I have the cursor jump back into the text area where I am working?

Also, the act of saving causes any errors in the Error List to be cleared. I can understand this given that Console does the error parsing, but is there some way I can tell Console not to clear the Error List?

Thanks!

Ernest
jEdit4AutoIt (jEdit4AutoIt.zip v3.4 by Thorsten Willert)
Submitted by Thorsten Willert on Sunday, 25 May, 2008 - 09:29
A collection of:
  • edit-mode
  • macros
  • console-commando-files
  • startup-scripts
  • XInsert-library
  • ...
to create AutoItScript-programms.
More information you can find on the jEdit4AutoIt homepage.
Included in the archiv:
  • Ctags
Required plugins and software:
  • Console-plugin
  • Clipper-plugin
  • XInsert-plugin
  • Sidekick-plugin
  • CtagsSideKick-plugin
  • An installation of AutoIt3 and all the other tools you want e.g. Tidy ...
Should I build a Python/Django plugin?
Submitted by Ristretto on Monday, 26 May, 2008 - 00:15
I'm moving from Java to Python, and Seam to Django. I'm also ditching Eclipse. I used to use Jedit for Java dev. I'm back. I would like to have a few features available that would make learning and using Python and Django a bit easier. I'm guessing the features are already there, and I just need find them or download plugins.

I've read in the forums that using 'spaces' for tabs, and setting 'deep indent' is wise, so I've done that.
I notice that there is a django edit mode, and then I set the django type in SideKick to parsed by 'xml', so now the XML plugin show the structure of the template, and the edit mode bolds the django template language keywords. This is so totally cool as a start. Big thank yous!! to the people who put this support together.

For Python, I would love these three things. Is this available somehow? Perhaps an existing plugin can be configured do it?
- code completion for imports and methods.
- method param lookups which typing
- documentation lookups (doc strings)

If nothing exists to do this, perhaps that for good reason: It isn't needed. I've heard that Python is so well designed that a programmer can keep most of the key bits of knowledge in his/her head. I'm not there yet, and I really do like handy look ups to get info and save time.

If nothing like this exists, and you think it would be valuable, would anyone want to give me tips and pointers to writing a plugin or set of macros, or ??. I would be happy to implement a solution and commit back to the project. (At this point, I know more Java than Python.)

cheers
BeanShell in classpath
Submitted by jossoj on Monday, 26 May, 2008 - 16:22
I've seen some suggestions about this error:

[error] BeanShell: You have BeanShell version 2.0-0.b1.6jpp in your CLASSPATH.
[error] BeanShell: Please remove it from the CLASSPATH since jEdit can only run with the bundled BeanShell version 2.0b1.1-jedit-1

when starting jedit, but the replies ans solutions seem to be specific for MacOS.
Could anyone tell me how to resolve this issue in linux (fedora 6, installation of jedit by rpm) ?

$ jedit -version
jEdit 4.2final

More specific: should I change something in the jedit startup script, in my environment variables, or do I have to remove the conflicting beanshell version ?

Thanks, Jos
UnsatisfiedLinkError on Mac OS X with Apple's Java 1.6
Submitted by vocaro on Tuesday, 27 May, 2008 - 09:30

I'm running Mac OS X 10.5.2 and have installed the new 1.6.0_05 release of Apple's Java distribution. The new Java seems to be causing problems, however, because jEdit 4.3pre14 will not run with it installed. I get:

java.lang.UnsatisfiedLinkError: /usr/lib/java/libObjCJava.A.dylib:  
 at java.lang.ClassLoader$NativeLibrary.load(Native Method) 
 at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1822) 
 at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1702) 
 at java.lang.Runtime.load0(Runtime.java:770) 
 at java.lang.System.load(System.java:1005) 
 at com.apple.cocoa.foundation.NSRuntime.loadLibrary(NSRuntime.java:127) 
 at com.apple.cocoa.foundation.NSRuntime.(NSRuntime.java:35) 
 at com.apple.cocoa.foundation.NSObject.(NSObject.java:27) 
 at macos.MacOSPlugin.start(Unknown Source) 
 at org.gjt.sp.jedit.PluginJAR.startPlugin(PluginJAR.java:1360)
 ...

There has been talk of this bug in other places, namely here:

http://lists.apple.com/archives/java-dev/2008/Apr/msg00280.html

and here:

http://lists.bluej.org/pipermail/bluej-discuss/2007-October/006482.html

My guess is that the problem can be worked around by preventing jEdit's Mac OS plugin from launching, but I haven't confirmed this.

Any other thoughts?

set jEdit as default edito
Submitted by martinsarsini on Tuesday, 27 May, 2008 - 13:07
Hi, I am actually using jEdit on Windows Vista
is there any way how to set it us default editor, so I can just double click on a php file and it opens in jEdit?
at the moment I have to drag the files inside the editor window, or right click on them and select Open with jEdit
Using jedit on Solaris 9 with Gnome desktop
Submitted by rlanier on Tuesday, 27 May, 2008 - 18:45
Hi,

I've installed the latest release of jedit in my home directory, and can get jedit to come up fine. But when it does, I get TWO instances of jedit, both with the same text file. I've also tried to print to a color printer, but all I get is grayscale.

Does anyone have a clue why I'm seeing this?

Thanks,
Tony
BBCode edit mode (bbcode.xml v1.0 by matejkaf)
Submitted by matejkaf on Thursday, 29 May, 2008 - 11:34
Edit mode for BBCode (Bulletin Board Code). Please add the following line to modes/catalog file: <MODE NAME="bbcode" FILE="bbcode.xml" FILE_NAME_GLOB="*.bbcode" /> The file extension "bbcode" is something I just choose, don't know whether it is in use.
JEdit produces ever increasing number of windows for every jedit start through a VPN connection
Submitted by Xoman08 on Friday, 30 May, 2008 - 11:03
I am using JEdit (4.2 Stable) on an old Linux CentOS (uname -r = 2.4.21) at work and on Fedora 8 at home. On both I use KDE environment. Recently I got VPN connection to work. Then I connect through a ssh -X -C -q -l username machine_name. The connection works well and it feels like working at the office. However JEdit shows some worrying phenomena. If I logout from work when I login into my session through VPN and then I can start JEdit and it will appear at my machine at Home. Everything is fine and well. However If I forget to logout at work, jedit will refuse to appear at my machine at home ... Unlike many other applicatios which do appear at the screen at home. When I get to the office I will see extra windows at the office for each time I started jedit. Also, and this is the most worrying phenomena. For every time I start jedit on a remote connection, even if it doesn't appear on my screen (it appears at the screen at work) a new window appears. So far I have 5 JEdit windows. And that number has increased for every jedit start I have executed through VPN. The fact is that when I get back to the office even after closing JEdit or rebooting the Linux machine, still when starting JEdit I get 5 windows. I am worried that if this keeps going Jedit is going to become unusable. I have been looking at /.jedit folder settings also at /tmp ... Also I have tried to start Jedit from the command line with different versions but still the phenomena persists. Nothing I can find nothing that may indicated something like a "replication of sessions - windows". If anyone can give me a hint of where to look, which files to delete in order to correct this behaviour, I will be very grateful. Does anyone know if there is "professional support" (i.e. read "paid support") for JEdit? This issue is quite urgent, if I don't get it sorted I will be forced to use another editor when working remotely. And even at the office too will be forced to stop using JEdit until this issue is solved. Could this be a bug in Jedit? Probably not, I figure is some issue in this bloody old CentOS that I have to use at work. Thanks for reading.
Locking/Unlocking the Scroll between side by side "Split" Viewing Panes
Submitted by rahnen on Friday, 30 May, 2008 - 15:47
I am trying to uses jEdit to View to Split Pane Buffers side by side and would love to be able to lock and unlock the scrolling. I've looked thru the menus but don't see anything that will allow me to do this. Can anyone help me out?
jEdit won't start...after hibernate?
Submitted by jimmygyuma on Saturday, 31 May, 2008 - 18:42
All my problems started when I upgraded my memory from 1G to 2G. I ran into the 'Not enough system resources...' bug. Tracked down and installed the hotfix for that. jEdit would not run. It was working fine before. Uninstalled it downloaded and installed the new version (jEdit 4.3pre14 using Java 1.6.0_05); still won't run. Maybe a restart is required. Did a restart. jEdit started right up, with the pretty colored icons and all my plugins, macros, etc. Okay, I'm set I think. I almost never shut my computer down, it takes so long to start up, plus it doesn't connect to my always on internet (or didn't, installing the hotfix seems to have jarred something loose in that department.) I started and stopped jEdit two or three times this morning with no problems, but on the third or fourth go, it wouldn't start. Double click on the icon, the hourglass appears for about a second and disappears and nothing further happens. I tried starting it from a command prompt and got 'Unable to access C:\Program Files\jEdit\jedit.jar.' I cogitate on it and try another restart; jEdit starts up fine after.

So it seems I have two choices: 1. Keep jEdit running all the time, or 2. Restart my computer before firing up jEdit.

Could someone help me please?

Jim
Insert simple Date (Insert_simple_Date.bsh v1.0 by Robert Schwenn)
Submitted by Robert Schwenn on Sunday, 1 June, 2008 - 20:37
Inserts current date in simple format "01.06.2008" at caret position.
com.mysql.jdbc.Driver not found
Submitted by Cheo on Monday, 2 June, 2008 - 10:40
Hi all

I've got a Netbeans web project working perfectly in my Debian box. I'm using the MVC pattern and would like to give jEdit a go for unit testing my Model.

I'm using a MySQL server, but cannot make my Model work because the com.mysql.jdbc.Driver is not found during run time. It compiles fine.

In my Project Viewer plugin, I right-clicked in my project->Properties->SQL Server Configuration and added my MySQL server.
I'm using the SQL pluggin and have set up the Driver's classpath by doing Plugins->Plugin Options->SQL->JDBS and adding the file mysql-connector-java-5.1.6-bin.jar. I can run queries in the SQL plugin with no problem and see the results in the SQL Result Set.
I have even added the mysql-connector-java-5.1.6-bin.jar file manually into ~/.jedit/jars as well.

So, I don't really know what is the problem. Any help will be appreciated.

Best regards,

Sergio
User login
Browse archives
« May 2008 »
MoTuWeThFrSaSu
 
3
9
11
16
17
18
19
21
24
28
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   46307
Context Free Art (*.cfdg)   0.31   36834
R Edit Mode - extensive version   0.1   11048
JBuilder scheme   .001   10882
Advanced HTML edit mode   1.0   10500
BBEdit scheme   1.0   10446
ColdFusion scheme   1.0   10434
Matlab Edit Mode   1.0   10369
jEdit XP icons   1.0   9823
XP icons for jEdit   1.1   9750