jEdit Community - Resources for users of the jEdit Text Editor
Archives
Syntax highlighting alias
Submitted by John Gallant on Monday, 16 July, 2012 - 17:08
I would like to assign new filename extensions to extensions already supported. Is there a way to do this?
Specifically, I am editing Objective C files with .mm extensions which does not seem to be supported. I would like to assign this extension to .m which is supported.
Another use I find handy is to name files with a .cx extension and alias that extension to .c. This allows me to view highlighted files I do not want searched.
jediut.exe over jedit java
Submitted by DocDJ on Wednesday, 18 July, 2012 - 13:32
I installed the java version of jedit some time ago and had a lot of files in the history list. I recently installed java.exe (Windows) and now, neither of these programs can find my history list. How can I recover it (and I think I would prefer to be able to use it in the java.exe version, to become independent of changes to the java installation.
How to disable the localization in jEdit 5.0?
Submitted by sinarf on Thursday, 19 July, 2012 - 08:50
Hello,

Just installed the last version of jEdit (5.0pre1) and everything is in French, probably because my professional computer is under a French version of Windows. I can see that it can be seen as a good idea, but it is not.

I won't be a problem if I find a way to disable it forever, but I couldn't find anything on the subject in help.
How can I go back to the real jEdit? Please.

In my humble opinion, translating a developer tool doesn't make any sense.

Thanks in advance.
Trouble adding Markdown syntax highlighting mode for the jEdit 5.0
Submitted by avamk on Saturday, 21 July, 2012 - 01:25
Hello, I am just starting to explore jEdit 5.0 on Mac OS X 10.6.8, and so far I find it all to be very exciting! Thanks for creating such a great piece of software. I downloaded the markdown.xml Markdown syntax highlighting mode from here: https://github.com/peterlynch/jEdit-modes And I tried to add it to jEdit by placing markdown.xml in the same folder as ~/Library/jEdit/modes/catalog Then I added the following to the catalog and saved it: However, even after restarting jEdit, the markdown mode still does not appear when I try to change modes in the Buffer Options dialog. How should I troubleshoot this, did I skip any steps? Thanks!
Plugin Column Ruler bugs?
Submitted by linuxerwang on Sunday, 22 July, 2012 - 16:27
Hi, all

I am using Column Ruler and love its functionality but it seems has a few issues (latest version of Column Ruler and jedit 4.5 pre1):

1. Add Marker/Guide through the "Plugins Options" dialog doesn't work most of time. After input the marker the list doesn't have that marker. Sometimes works though.

2. The guide line created through column ruler doesn't show up when jEdit starts. I have to always click on the ruler at the column number and the guide line is shown. It's tedious to do it every time.

Thanks.
Sentence recognition is text mode?
Submitted by avamk on Tuesday, 24 July, 2012 - 15:52
Hello,

I realise that jEdit has shortcut keys for moving to the beginning and end of lines. Is there a similar way to move the caret to the beginning and end of a *sentence* in text mode? Is jEdit, or perhaps a plugin, capable of recognising sentences?

Thanks!
Can't use Alt key in jEdit 5 under Mac OS X
Submitted by avamk on Sunday, 29 July, 2012 - 23:35
Hello,

I am trying to get my Alt key to work in Mac OS X. Whenever I try to use it as part of a shortcut, it instead writes a symbol (which symbol depends on what character I hit on the keyboard) into my buffer.

I searched for previous posts, and one suggested modifying my startup.bsh. I tried but still couldn't get my Alt key to function. Can someone tell me what I am doing wrong? Below is the section in my startup.bsh:

/*{{{ Remapping modifier keys part I */

/* The below is the default, swap the items around to
* change meaning of C+, A+, M+, S+.
*/
//KeyEventTranslator.setModifierMapping(InputEvent.CTRL_MASK,
// InputEvent.ALT_MASK, InputEvent.META_MASK,
// InputEvent.SHIFT_MASK);

/* ... and this the MacOS default: */
KeyEventTranslator.setModifierMapping(InputEvent.META_MASK, /* == C+ */
InputEvent.CTRL_MASK, /* == A+ */
InputEvent.ALT_MASK, /* == M+ */
InputEvent.SHIFT_MASK /* == S+ */);

/*}}}*/

/*{{{ Remapping modifier keys part II */

/* Note if you chose to make use of the M+ (option key) prefix on MacOS, you
* will need to disable a little piece of code: */
Debug.ALT_KEY_PRESSED_DISABLED = false;
/* Otherwise M+ will be ignored for the purposes of keyboard shortcuts. */

/* But if you enable this, you might find that Option+8 for example invokes your
* macro but also inserts a bulletpoint, as per standard Macintosh keyboard
* behavior. To disable the Option key for inserting special high ASCII
* characters, uncomment this. Note that it has wider implications, notably
* DROVAK keyboard shortcuts will be mapped as if the keyboard was QWERTY. */
Debug.ALTERNATIVE_DISPATCHER = false;

/*}}}*/
java.lang.OutOfMemoryError: unable to create new native thread
Submitted by imgod2u on Friday, 3 August, 2012 - 20:42
Something has happened with our company linux cluster recently. I think they've limited the number of user threads or at the very least, have significantly reduced it. In either case, resizing the jedit window will consistently cause:

1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: Exception in thread "AWT-EventQueue-0"
1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: java.lang.OutOfMemoryError: unable to create new native thread
1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.lang.Thread.start0(Native Method)
1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.lang.Thread.start(Unknown Source)
1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.initDispatchThread(Unknown Source)
1:32:20 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.run(Unknown Source)

Unfortunately, I do not have admin access nor do I think IT will change their policy just so I can use jedit. So my question would be, is there a way to find out what the maximum thread/nproc limit is for my user account and is there a way to limit how many threads jedit spawns?
Java Noob
Submitted by Arionyx on Monday, 6 August, 2012 - 18:26
I'm almost a complete noob when it comes to Java. The bulk of my expereience has come from working with beanshell to write macros for jEdit. On that note, I've decided to try to dive a little deeper, and write a plugin. I've got most of my programming sources ready to go, all I have left is to set up the dev environment. I'm currently using NetBeans IDE so I was wondering if anyone could help me set it up for writing plugins. I've managed to compile jEdit but when I try to work on, even the 'QuickNotepad' plugin from the tutorial, it says packages from jEdit are missing.
How to apply a plugin patch
Submitted by nils3142 on Thursday, 9 August, 2012 - 18:34
I posted this question earlier today, but for some reason it was deleted.
I try again:

I have downloaded the patch BufferList-collapse-on-save-fix.patch for the BufferList plugin. How do I apply this patch to the plugin? I use jEdit on a computer with Windows 7.
Matching characters other than brackets
Submitted by Kevin Moore on Friday, 10 August, 2012 - 22:05
I am a new user and I am wondering if JEDIT supports matching on characters other than brackets? I've searched previous posts, and I have found requests for this type of operation, but no mention of it's support.

I would like to be able to jump between the beginning/end of old style c comments:

/**********
lots of lines of comments....
lots of lines of comments....
**********/


Thanks, Kevin Moore
jEdit changes the string 'and ' to a character that looks like an open square.
Submitted by JimParinisi on Monday, 13 August, 2012 - 20:34
The java.io.CharConversionException sites character '^'(U+2227) with encoding "Cp1252" on a save. I am guessing that i caused the error by hitting some key combination shortly before. It occurred first in a .py file, but also occurs in a .txt file. How do i get rid of this behavior?
PopupMenu in StandaloneTextArea class jEdit
Submitted by Paula17 on Thursday, 16 August, 2012 - 17:15
Hi,

I'm using textArea's jEdit into my own application with StandaloneTextArea class.
This class has its own pop-up-menu but I'd like to create my own pop-up-menu. How can I disable that pop-up-menu?

Thanks in advance!!

Paula
How to correct syntax highlighting for comment: @throws in php edit mode
Submitted by Denouncer on Sunday, 19 August, 2012 - 12:08
Hi all,

I'm hoping someone can help. I've noticed that in the latest version of jEdit that if I use "@throws" in a function comment (PHPDoc style) the syntax highlighting seems to go out of whack. Basically, if it sees @throws... inside a comment block, it highlights the line correctly, but then all proceeding lines seem to be highlighted as comments as well. For example:

/**
* Test
* @throws Exception
*/
public function test() {

}

Basically, instead of it seeing "*/" as the end of the comments, it continues to highlight "public function" as a comment as well. This didn't happen in earlier versions, from what I can tell, only newer versions.

Anyone know how I can fix this?

Thanks
Rectangular selection detect
Submitted by kemptenkid on Wednesday, 22 August, 2012 - 04:26
I'm going to modify my paste command to detect if jedit is in rectangular mode, if so then I will issue a vertical paste.
How do i detect jedit in is rectangular mode from the bash macro ?
d'oh! Need help recovering macros and settings after re-installing 4.5.2
Submitted by tnlibrarian on Monday, 27 August, 2012 - 04:11
Help!

I have lost macros and settings following a rash and ill-considered update from 4.5.3 to 5.0 pre and a subsequent re-installation of 4.5.2 (which is when the macro and other C:\User\[...]\.jedit files were overwritten with a clean install) (nb: this is a Windows 7 installation).

Anybody got a favorite free (or cheap) recovery solution? (Windows recovery/shadow solutions ain't an option... nor is going back in time and being not-stupid about making an adequate backup.) eSupport Undelete Plus finds the files in the "C:\Deleted 1200\" directory, but insists on payment to recover the .bsh files (which I am willing to do, but not if I can get them back for free...)

Thanks for the help in my panicking times!
jedit and netrexxJe - no longer supported?
Submitted by kklein on Thursday, 30 August, 2012 - 19:29
I can't get netrexxJe to work anymore after upgrading to the latest jedit 4.5.2. I also can't use the plugin manager to get plugins, but that could be a proxy issue on this network.
Running jEdit Mac OSX 10.8 - “jEdit” is damaged and can’t be opened. You should move it to the Trash.
Submitted by Matt Fleming on Wednesday, 5 September, 2012 - 18:19
I just downloaded the latest OSX bundles (stable and dev branch). When I attempt to open the application I get this message:
“jEdit” is damaged and can’t be opened. You should move it to the Trash.

Any ideas?
I can't add new toolbar icons for Navigator "forward" and "back"
Submitted by mlefevre on Monday, 10 September, 2012 - 19:25
I'm using jEdit 4.5.1 on Linux (Centos 6.3) and I have loaded the Navigator plugin (version 2.4). When I try to edit the toolbar and add buttons (icons) for The Navigator "forward" and "back" actions, they show up in the Global Options dialog as I create them, but when I "apply" or "exit", they don't show up on the tool bar. I can create toolbar buttons for other Navigator actions and for actions from other plugins. I just can't add the forward and back actions.

Does anyone know of a problem that leads to this behavior? I'm coming back to jEdit after a year with slickEdit and I'm trying to restore a configuration I know I had before.

Marc
Problem with jEdit 4.5.2 on OpenJDK 1.7.0_07 - uneditable text area
Submitted by Phitherek_ on Thursday, 13 September, 2012 - 10:44
Hello,

I' ve got a following problem with jEdit 4.5.2 after last OpenJDK update to version 1.7.0_07. I use Arch Linux with LXDE as a desktop environment and Compiz Fusion as a window manager. Before the update everything worked as expected. However, after the update if the jEdit window loses focus, its text area becomes uneditable and the program is not responding to keyboard hotkeys. However, the buttons and menus still work perfectly. I can temporalily solve the problem by minimizing jEdit to taskbar and then restoring it, but it happens again with the next loss of focus, which is really frequent with autocompletion plugins. It is really annoying and makes my work harder. Please help me if someone knows the solution.
User login
Browse archives
« July 2012 »
MoTuWeThFrSaSu
 
1
2
3
5
6
7
9
10
12
13
14
15
17
20
23
25
26
27
28
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   47181
Context Free Art (*.cfdg)   0.31   37190
JBuilder scheme   .001   11542
R Edit Mode - extensive version   0.1   11382
BBEdit scheme   1.0   11107
ColdFusion scheme   1.0   11096
Advanced HTML edit mode   1.0   10834
Matlab Edit Mode   1.0   10699
jEdit XP icons   1.0   10159
XP icons for jEdit   1.1   9957