jEdit Community - Resources for users of the jEdit Text Editor
JEdit Autodesk Maya Integration
Submitted by filmico on Friday, 20 April, 2012 - 14:33
Hello Guys,

My Name is Gerardo Sebastian Verrone; I am a TD specialized in rigging.

I have recorder and uploaded to youtube 10 videos Tutorials covering how you can install and configure JEdit to integrate it as an external code editor to work with Autodesk Maya.

This tutorials are up to date to be usefull for Maya 2011/2012/2013 or until Adesk change things drastically.

Trust me, you are not going to find videos out there explaining all this steps.

The tutorials are located here:

I'd like to thanks to the developer and maintainers of JEdit as it is a great application with many posibilities to expand it.


Gerardo Verrone
Issue running jEdit on Mac OS X 10.5.8 (Using OpenJDK7 bsd-port compiled against platform)
Submitted by jlove on Sunday, 22 April, 2012 - 09:11

I love jEdit and use it all the time on my standard Linux desktop however I've recently purchased a PowerMac G4 and have managed to compile OpenJDK7 against the platform. Great... now I can upgrade to the latest version of jEdit!! I downloaded the source and compiled against my platform but due to complications I have to explicitly set Djava.awt.false=false as an option when running jEdit.

Everything loads correctly and I can browse through the menu items, install plugins etc however the one thing which doesn't work is keyboard input into buffers. When I try to type into a buffer no text appears and instead the output is directed to the console.

Could somebody please help me understand what is happening and perhaps suggest any way of avoiding this issue? I'm not afraid to get my hands dirty in the code if it comes to that but I'd appreciate a starting point!

Kind Regards,

Search in directory encoding exception
Submitted by yohann.martineau on Thursday, 26 April, 2012 - 16:00
I try to use jedit to make recursive text search in all files in a directory.

When I perform a search, jedit complains about cp1252 encoding not applicable on pdf files. Yes, I'm on windows xp...

The file could not be loaded correctly (some data might be lost) with
the encoding "Cp1252".
(java.nio.charset.UnmappableCharacterException: Input length = 1)
Try selecting a different encoding.
It can be selected with the menu File->Reload with Encoding.
If you want it to be done automatically, add the candidates into
"List of fallback encodings" in Encodings pane of Global Options.

I don't understand why jedit tries to search in pdf files as pdf files are binary files. Does it try to extract text from pdf files and then apply an encoding to find text?

It seems that jedit can skip binary files, it seems to be an interesting feature, but I don't know how jedit considers files as binary. If I uncheck "skip binary files", the same exception pops out but for bin files, obj files, etc. I've been looking at the documentation, but cannot find anything about binary files association. I think this behavior is expected, but not very user friendly.

Is it possible to use jedit to search in all binary files as well?

Does it just try to decode the file using its default encoding (cp1252, I'm on windows xp) and considers the file as binary if it fails? (I guess it's not that simple)


How to submit an edit mode
Submitted by Skeeve on Sunday, 29 April, 2012 - 16:26

I just finished my LQL edit mode (for mk-livestatus). How can I submit it?
jEdit, Mac, Java 1.7+
Submitted by alopecoid on Monday, 30 April, 2012 - 15:10

Java 1.7 has been officially released by Oracle for OS X 64-Bit:

I have been attempting to get jEdit (4.5.1) running with this JVM without any success. When I modify JVMVersion from 1.6+ to 1.7+ in /Applications/, I get an error "No compatible version of Java 1.7+ is available.". I have also tried setting this to the exact version number.

You will see here that I have Java 1.7 installed correctly:

/usr/libexec/java_home --verbose

Matching Java Virtual Machines (5):
1.7.0_04, x86_64: "Java SE 7" /Library/Java/JavaVirtualMachines/1.7.0.jdk/Contents/Home
1.6.0_31-b04-413, x86_64: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0_31-b04-413.jdk/Contents/Home
1.6.0_31-b04-413, i386: "Java SE 6" /Library/Java/JavaVirtualMachines/1.6.0_31-b04-413.jdk/Contents/Home
1.6.0_31-b04-413, x86_64: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
1.6.0_31-b04-413, i386: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home



echo ${JAVA_HOME}


Also, Java 1.7 is even set as the default:

java -version

java version "1.7.0_04"
Java(TM) SE Runtime Environment (build 1.7.0_04-b21)
Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)

I have been running jEdit on Linux (Ubuntu) and Java 1.7 for quite some time without any major issues.

Any ideas?

Thank you.
add a line to every line in a file?
Submitted by jbrave on Tuesday, 8 May, 2012 - 03:14
I want to take a text file which is a program source, and insert a print statement after each line, for example if line 1 is:


then insert
print "line 1: x=5"

so that when a program crashes hard (as in, the system reboots before I can see what happened) at least I can see the last line that executed.

Is there some kind of macro or plugin that I can use to do things like that?


- Joel
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:19
When large input data are entered in a new file, the heap gets out space and displays an beanshellerror message which is not user friendly message. Also in the the beanshellerror message the text is typable.

Expected Results:
Appropriate user friendly error message should be appeared and in the error message text should not be typable.

Test Enviroment: OS: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:32
When a file is printed, the filename also appears at the top of the page.

Expected Result: Application should be able to send the print command which should print only the contents of a file

Test Enviroment: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 15:08
If multiple files with different files format is opened then an error message appears that does not fit to screen.

Expected Results: The list of error message should be able to fit on screen so that user can click on OK button.

Test Enviroment: OS: Windows 7, 64-bit
font size of tags plugin dialog
Submitted by wkevils on Thursday, 10 May, 2012 - 18:04
I used to have and use quite and old release of JEdit (4.2.0)
I am trying now latest 4.5.3.
I am not satisfied with the font size of tags plugin dialog - it is to much large
in my feeling. In the previous JEdit I used (4.2) It was ok.
Is there a way to make this font smaller ?
Using java2d.noddraw on Windows
Submitted by exxa on Friday, 11 May, 2012 - 16:29
Using jEdit causes my GPU to leave its idle state. This eventually causes it to heat up, which causes the fan to increase in speed. Really not something that's necessary when doing editing. I saw a way to disable 2d acceleration, which in the past has cured this. However, I notice this version of jEdit no longer launches from the .bat file, but has a "jEdit.exe." How do I pass -Dsun.java2d.noddraw=true when jEdit starts?
how to Clear the clipboard ??
Submitted by DoctorSea on Monday, 14 May, 2012 - 02:29
I am trying to write a macro that clears the clipboard. This is most important to me.
I tried

a = "";

and a variety of other textArea methods(viewable online) but nothing I can find helps. What am I missing ?
How does one clear the clipboard ? Any ideas anyone? Please?
how to Clear the clipboard ??
Submitted by DoctorSea on Monday, 14 May, 2012 - 11:36
I am trying to write a macro that clears the clipboard. This is most important to me.
I tried

a = "";

and a variety of other textArea methods(viewable online) but nothing I can find helps. What am I missing ?
How does one clear the clipboard ? Any ideas anyone? Please?
Strange Behavior with Shift-C
Submitted by Cheruvim on Tuesday, 15 May, 2012 - 15:00
Not sure how this happened or how to reproduce it, however, in Jedit and only in Jedit, when I push shift-C It doesn't type a 'C' (which I just typed here on the same machine, a macbook pro OS 10.6). The strange thing is if I type shit-C in succession or if I type shift-C and then another key, I get a system beep.

What the heck is going on? Where on earth did Jedit get that mapped?
Data Collection problem for concept location research on Jedit
Submitted by komail on Thursday, 17 May, 2012 - 07:47
Hi there,
I'm doing my research on concept location area and I want to chose Jedit as
my case study. I need the complete data of the source code repository with
the log commit messages, bug and features.
The problems are:
1. The source code repository is in three different type of source control
repository(CVS, SVN, Git)
2. I want to find/recommend the accurate location for the features and bugs
in the source code and regarding to the conversation in
I don't know what should I do with this code distribution problem.
3. There isn't any link in the bugs and features web page to download them.
4. I need the whole list of the Jedit developers. After a long search, I
found a list of developer in
"" but I don't
know is this correct and also there isn't any link to download the list.

thanks for your help, with the best regards
Autoindent in jEdit help
Submitted by groland on Saturday, 19 May, 2012 - 16:51
I am brand new to jEdit, and I am using it to write code in java. I thought it auto-indented when typing, so that code blocks would be correctly indented. I cannot get it set up properly to do this.

How is this accomplished?



MacBook Pro, Mas OS X 10.6.8
PHP Getters / Setters (PHP_Get_and_Set_Methods.bsh v1.0 by Thomas Van Steenwinkel)
Submitted by jvgamers on Monday, 21 May, 2012 - 14:01
This macro allow you to generate Getters / Setters and Constructor for PHP File. It is based on official Get and Set Methods for Java, improved for PHP use.
jEdit syntax highligthing
Submitted by Paula17 on Wednesday, 23 May, 2012 - 16:34

I'm using textArea of jEdit in my application but I'm only interested in using assembly and c language. I've seen there are several types of assembly language. I'm interested in assembly language for ARM7TDMI. Which one of these languages would be the correct or the best to this kind of ARM? Could anyone help me?

Thanks in advance!

How can I capitalize first letter of a line and lowercase the rest?
Submitted by speedracer on Thursday, 24 May, 2012 - 05:32
I want to select a line of text and convert all of it to lower case except for the first letter, which I want to be converted to upper case, if it isn't already. Is there a macro to do this? All I've been able to find is the macro that capitalizes the first letter of every word, which is no good for my needs. Any help will be appreciated.
GdbPlugin for jEdit 4.5+ (GdbPlugin.jar v0.5 by Shlomy Reinstein)
Submitted by shlomy on Thursday, 24 May, 2012 - 11:40
GdbPlugin for jEdit 4.5+
User login
Browse archives
« April 2012 »
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51172
Context Free Art (*.cfdg)   0.31   41265
JBuilder scheme   .001   17059
BBEdit scheme   1.0   16663
ColdFusion scheme   1.0   16640
R Edit Mode - extensive version   0.1   14942
Advanced HTML edit mode   1.0   14097
Matlab Edit Mode   1.0   14043
jEdit XP icons   1.0   13469
XP icons for jEdit   1.1   12492