jEdit Community - Resources for users of the jEdit Text Editor
Hypersearch results analysis ( v1.0 by Thiemo Kellner)
Submitted by Robert Schwenn on Thursday, 13 April, 2017 - 21:04
Two neat macros to analyse hypersearch results:

- hypersearch_results_distinct_hits.bsh: extracts the distinct lines in the results
- hypersearch_results_files.bsh: extracts all the files results were found in

! Note that these macros depend on:
- other macro "Misc/HyperSearch_Results_to_Buffer.bsh"
- TextTools Plugin

Also, see original post:
jEdit Server on OSX
Submitted by RobertX on Friday, 21 April, 2017 - 00:26
When I run jEdit on Windows, I create a shortcut and put it in the Startup folder that runs the jEdit server in the background. I have zero idea on how to do this on MacOS. Any help?
jEdit hangs when using multiple screens
Submitted by rursus on Friday, 21 April, 2017 - 12:17
Hi! Jedit version tested: 5.4.0 (compiled from source) Java version: java-1.8.0-openjdk-amd64 (Debian) I have tried to find any relevant info by googling, but I couldn't find any: * Whenever I run jedit on a single screen, there are no problems, and life is happy and the sun shining. * Whenever I run jedit on a computer using multiple screens, jedit cannot be started, or if it is already started before, and the second screen is attached afterwards, jedit refuses to open any new windows. When refusing to open any window, jedit says: 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: Exception in thread "AWT-EventQueue-1" 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.image.ReplicateScaleFilter.( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at sun.awt.X11.XToolkit.createCustomCursor( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.textarea.TextAreaPainter.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Container.addNotify( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at javax.swing.JComponent.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.textarea.TextArea.addNotify( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Container.addNotify( ... 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at java.awt.Window.pack( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.jEdit.newView( 13:55:29 [AWT-EventQueue-1] [error] AWT-EventQueue-1: at org.gjt.sp.jedit.PerspectiveManager$PerspectiveHandler.endElement( Which obviously means that when jEdit makes a newView, it obviously triggers a TextArea.addNotify which triggers a TextAreaPainter.addNotify, which somehow delivers a window with a size of 0,0. I'm inclined to hack this in my personal copy of jEdit, if possible. Anyone have an idea why this occurs?
Write current date/time to a file as it is saved
Submitted by jhaefner on Sunday, 23 April, 2017 - 01:00
I am writing html and would like to write "Updated: ...the date of last modification.." on to the html file in a particular place. So, after testing that the file has been modified, I would like to write the current day and time to the file immediately after I tell Jedit to save the file, but before it is actually saved. Possibly, the solution would be to point my usual "save file" shortcut to a macro that writes the date/time info where I want it and then does the jedit save file command. Has anyone done this? If not, can any one point me in a direction to get me started? I have done simple ".bsh" macros, but nothing more complex. I am aware of Robert Schwenn's 2008 "insert_simple_date.bsh".

Thanks in advance. Jim
ReadOnlyBuffer (Macro) not working with jEdit 5.4
Submitted by Hans_Bauer on Friday, 19 May, 2017 - 11:30
Using the MacroManager i downloaded the "ReadOnly Buffer"-Macro and associated a Toolbar-Icon with it.

The Macro does not seem to do anything in jEdit 5.4.

Possibly there is a code change in jEdit, because my own-written macro "ToggleReadOnlyBuffer" also stopped working after the update from jEdit 5.3 to 5.4.

Any idea to update the macro "ReadOnly Buffer"?

Thanks Hans
(Windows) unable to release Ctrl+Alt+J hotkey for usage
Submitted by 1234ru on Wednesday, 24 May, 2017 - 19:21
Ctrl+Alt+J is bound to start jEdit when it is installed (which was pretty surprise by itself and was discovered accidentally). I need this combination for another program, so I went to "Start jEdit" shortcut's properties and reset the "Shortcut key" property to a blank value.
However, the hotkey still remains bound to starting jEdit (which happens when I press the keys), although the property of a shortcut is displayed as a blank value.

How can I get rid of it?
User login
Browse archives
« April 2017 »
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   50256
Context Free Art (*.cfdg)   0.31   40399
JBuilder scheme   .001   16579
ColdFusion scheme   1.0   16140
BBEdit scheme   1.0   16138
R Edit Mode - extensive version   0.1   14307
Advanced HTML edit mode   1.0   13657
Matlab Edit Mode   1.0   13534
jEdit XP icons   1.0   13018
XP icons for jEdit   1.1   12044