jEdit Community - Resources for users of the jEdit Text Editor
jedit locked up and won't restart
Submitted by akovia on Tuesday, 24 September, 2013 - 21:25
jedit 4.4.2
xubuntu 12.04-LTS 64bit

I'm at a loss. jedit locked up on me and now won't restart, even after a reboot.

Launching from command line: (launches script to execute java -jar "/home/akovia/jedit/4.4.2/jedit.jar" "$@")
$ jedit

(java:21298): Gtk-WARNING **: Unable to locate theme engine in module_path: "equinox",
4:19:16 PM [main] [error] main: Error parsing gtk-icon-sizes string: ''
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: php: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: html: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: php: EXCLUDE_MATCH is deprecated
4:19:17 PM [AWT-EventQueue-0] [warning] XModeHandler$TagDecl: lircrc: EXCLUDE_MATCH is deprecated

Then nothing happens. No splash or anything, and I have to kill it.
Tried installing newest .deb version from site and it won't launch either.
(removed old ver from path and checked which jedit to confirm running newest installed)

Here is my java:
$ update-alternatives --config java
There are 3 choices for the alternative java (providing /usr/bin/java).

Selection Path Priority Status
0 /usr/lib/jvm/java-7-oracle/jre/bin/java 1063 auto mode
1 /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java 1061 manual mode
2 /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java 1051 manual mode
* 3 /usr/lib/jvm/java-7-oracle/jre/bin/java 1063 manual mode

I've been using jedit on a project for a week straight with only one other lockup, but a kill and restart fixed it then. I am dead in the water now and the console errors aren't getting me anywhere.

Here is the launch script that I use:
# Runs jEdit - Programmer's Text Editor.

# Set jvm heap initial and maximum sizes (in megabytes).

if [ -z "$JAVA_HOME" ]; then

# Launch application.

#exec "$JAVA_HOME/bin/java" -Dnimrodlf.themeFile="/home/akovia/jedit/4.4.2/jeznet.theme" -Xmx${JAVA_HEAP_MAX_SIZE}M -jar "/home/akovia/jedit/4.4.2/jedit.jar" "$@"
# -Dnimrodlf.themeFile="/home/akovia/jedit/4.4.2/NimRODThemeFile2.theme"
exec java -jar "/home/akovia/jedit/4.4.2/jedit.jar" "$@"

The java path doesn't match but like I said it's been working great. I did try to change the path to
but had the same result.

Here are my latest system updates just in case. jedit hasn't been closed since the last lockup so I suppose it coulda been fine till the lockup and then an update played a part when trying to restart??

$ tail -n45 /var/log/apt/history.log

Start-Date: 2013-09-19 10:02:18
Commandline: aptdaemon role='role-commit-packages' sender=':1.156'
Upgrade: libpolkit-backend-1-0:amd64 (0.104-1ubuntu1, 0.104-1ubuntu1.1), libsane-hpaio:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), thunderbird-locale-en-us:amd64 (17.0.8+build1-0ubuntu0.12.04.1, 24.0+build1-0ubuntu0.12.04.1), language-selector-gnome:amd64 (0.79.3, 0.79.4), thunderbird:amd64 (17.0.8+build1-0ubuntu0.12.04.1, 24.0+build1-0ubuntu0.12.04.1), audacity:amd64 (2.0.3+svn20130918+r7817-0~r21~ubuntu12.04.1, 2.0.3+svn20130919+r7822-0~r21~ubuntu12.04.1), python-software-properties:amd64 (,, printer-driver-postscript-hp:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), libpolkit-gobject-1-0:amd64 (0.104-1ubuntu1, 0.104-1ubuntu1.1), hplip:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), language-selector-common:amd64 (0.79.3, 0.79.4), software-properties-common:amd64 (,, usb-creator-gtk:amd64 (0.2.38,, policykit-1:amd64 (0.104-1ubuntu1, 0.104-1ubuntu1.1), rtkit:amd64 (0.10-2, 0.10-2ubuntu0.12.04.1), libhpmud0:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), apt-xapian-index:amd64 (0.44ubuntu5, 0.44ubuntu5.1), software-properties-gtk:amd64 (,, audacity-data:amd64 (2.0.3+svn20130918+r7817-0~r21~ubuntu12.04.1, 2.0.3+svn20130919+r7822-0~r21~ubuntu12.04.1), google-chrome-stable:amd64 (29.0.1547.65-r220622, 29.0.1547.76-r223446), printer-driver-hpcups:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), jockey-common:amd64 (0.9.7-0ubuntu7.10, 0.9.7-0ubuntu7.11), usb-creator-common:amd64 (0.2.38,, thunderbird-globalmenu:amd64 (17.0.8+build1-0ubuntu0.12.04.1, 24.0+build1-0ubuntu0.12.04.1), jockey-gtk:amd64 (0.9.7-0ubuntu7.10, 0.9.7-0ubuntu7.11), libpolkit-agent-1-0:amd64 (0.104-1ubuntu1, 0.104-1ubuntu1.1), thunderbird-locale-en:amd64 (17.0.8+build1-0ubuntu0.12.04.1, 24.0+build1-0ubuntu0.12.04.1), printer-driver-hpijs:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2), hplip-data:amd64 (3.12.2-1ubuntu3.1, 3.12.2-1ubuntu3.2)
End-Date: 2013-09-19 10:03:34

Start-Date: 2013-09-19 17:48:32
Commandline: apt-get install agave
Install: agave:amd64 (0.4.7-2ubuntu1)
End-Date: 2013-09-19 17:48:43

Start-Date: 2013-09-20 08:14:48
Commandline: aptdaemon role='role-commit-packages' sender=':1.171'
Upgrade: libsmbclient:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), libpam-winbind:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), smbclient:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), audacity:amd64 (2.0.3+svn20130919+r7822-0~r21~ubuntu12.04.1, 2.0.3+svn20130920+r7824-0~r21~ubuntu12.04.1), libwbclient0:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), samba-common:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), audacity-data:amd64 (2.0.3+svn20130919+r7822-0~r21~ubuntu12.04.1, 2.0.3+svn20130920+r7824-0~r21~ubuntu12.04.1), samba-common-bin:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7), winbind:amd64 (3.6.3-2ubuntu2.6, 3.6.3-2ubuntu2.7)
End-Date: 2013-09-20 08:15:15

Start-Date: 2013-09-21 07:45:29
Commandline: aptdaemon role='role-install-file' sender=':1.181'
Install: liblua5.2-0:amd64 (5.2.0-2, automatic)
End-Date: 2013-09-21 07:45:33

Start-Date: 2013-09-21 14:14:40
Commandline: aptdaemon role='role-commit-packages' sender=':1.191'
Upgrade: gparted:amd64 (0.16.1-1~getdeb1, 0.16.2-1~getdeb1)
End-Date: 2013-09-21 14:14:48

Start-Date: 2013-09-22 14:27:28
Commandline: aptdaemon role='role-commit-packages' sender=':1.198'
Upgrade: audacity:amd64 (2.0.3+svn20130920+r7824-0~r21~ubuntu12.04.1, 2.0.3+svn20130922+r7831-0~r21~ubuntu12.04.1), audacity-data:amd64 (2.0.3+svn20130920+r7824-0~r21~ubuntu12.04.1, 2.0.3+svn20130922+r7831-0~r21~ubuntu12.04.1)
End-Date: 2013-09-22 14:28:06

Start-Date: 2013-09-23 09:27:16
Commandline: aptdaemon role='role-commit-packages' sender=':1.208'
Upgrade: audacity:amd64 (2.0.3+svn20130922+r7831-0~r21~ubuntu12.04.1, 2.0.3+svn20130923+r7834-0~r21~ubuntu12.04.1), audacity-data:amd64 (2.0.3+svn20130922+r7831-0~r21~ubuntu12.04.1, 2.0.3+svn20130923+r7834-0~r21~ubuntu12.04.1)
End-Date: 2013-09-23 09:27:26

Start-Date: 2013-09-24 12:09:23
Commandline: aptdaemon role='role-commit-packages' sender=':1.220'
Upgrade: libraw5:amd64 (0.14.4-0ubuntu2.1, 0.14.4-0ubuntu2.2), python-openssl:amd64 (0.12-1ubuntu2, 0.12-1ubuntu2.1), audacity:amd64 (2.0.3+svn20130923+r7834-0~r21~ubuntu12.04.1, 2.0.3+svn20130924+r7838-0~r21~ubuntu12.04.1), audacity-data:amd64 (2.0.3+svn20130923+r7834-0~r21~ubuntu12.04.1, 2.0.3+svn20130924+r7838-0~r21~ubuntu12.04.1)
End-Date: 2013-09-24 12:09:35

Start-Date: 2013-09-24 16:15:29
Commandline: apt-get remove jedit
Remove: jedit:amd64 (
End-Date: 2013-09-24 16:15:32

The last entry I removed the jedit .deb i had just tried.

I'm not sure what other info to post, but will be happy to post anything else needed.
Any help is greatly appreciated.
Comment viewing options
Select your preferred way to display the comments and click 'Save settings' to activate your changes.
Well I finally got it to work
by akovia on Wed, 25/09/2013 - 15:55
Well I finally got it to work. I changed the update alternatives to use
and it opened displaying the autosave windows for the files that were not saved during the crash.

I'm guessing that java 7 is having trouble displaying these windows and just gets stuck. Now that I have successfully open jedit and closed it normally, I was able to go back to java 7 and it opens fine now.

Not a very friendly bug, but just glad I have it working again.
Did a little more searching a
by akovia on Wed, 25/09/2013 - 15:30
Did a little more searching and ran java in verbose mode.

Here are the last couple lines before it hangs.

[Loaded java.text.AttributedCharacterIterator from /usr/lib/jvm/java-7-oracle/jre/lib/rt.jar]
[Loaded java.text.AttributedString$AttributedStringIterator from /usr/lib/jvm/java-7-oracle/jre/lib/rt.jar]
[Loaded sun.awt.TimedWindowEvent from /usr/lib/jvm/java-7-oracle/jre/lib/rt.jar]
[Loaded javax.swing.Timer$1 from /usr/lib/jvm/java-7-oracle/jre/lib/rt.jar]

Thought it might help.
I really need to get this working again. I'm happy to try any suggestions.
User login
Browse archives
« February 2018  
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51081
Context Free Art (*.cfdg)   0.31   41260
JBuilder scheme   .001   17053
BBEdit scheme   1.0   16658
ColdFusion scheme   1.0   16636
R Edit Mode - extensive version   0.1   14919
Advanced HTML edit mode   1.0   14092
Matlab Edit Mode   1.0   14038
jEdit XP icons   1.0   13463
XP icons for jEdit   1.1   12487