jEdit Community - Resources for users of the jEdit Text Editor
Jedit doesn't start - no error messages
Submitted by DocDJ on Wednesday, 9 September, 2015 - 13:27
My system is Windows 10 Pro X64. Yesterday, I did a Java update and now Jedit won't start. I downloaded a new version (so now I have 2: 1 in Program Files and 1 in program files (x86)). Neither one works (jedit.exe). I also tried javaw -jar jedit.jar from a command prompt inside the jedit directory. Same results: no error messages. Program does not show up in Task Manager although when I installed the newest version using the Windows installer it said it would try to stop a running copy (which I couldn't find). The version in progfiles (x86) was installed using the java installer. But if I have a wrong version of java, shouldn't I get an error message of "some" kind?
Comment viewing options
Select your preferred way to display the comments and click 'Save settings' to activate your changes.
Hi, there are a few things
by Robert Schwenn on Wed, 09/09/2015 - 18:03
Hi,

there are a few things to clarify:

0. Sound like jEdit has been running successfully on Windoews 10 already, hasn't it?
1. What kind of java update have You done (old and new version, x32/x64)?
2. Which jEdit version have You installed?
3. You said "also tried javaw -jar jedit.jar". What else did You try?
4. Invoke "java -version" at a command prompt: What version does java display (also x32/x64)?
5. You will never ever find a program or process called "jEdit". Look for "Java ..." in task manager - the subitem tells You if it runs jEdit.
6. Try the java command line version in order to get output at the command window: java -jar jedit.jar
(Note: java without trailing "w")
7. Even on failed start jEdit should write something into the activity.log file. Check it's file time and content. You find the file inside Your jEdit settings directory (for me it's: C:\Users\sc\AppData\Roaming\jEdit\activity.log)
8. For me, sometimes helps to remove the "perspective.xml" or "server" file inside the settings directory. You also could rename the settings directory to ensure jEdit is starting whithout any user settings.

Enough for now, I think Eye-wink

Robert
 
Sorry I took so long to appen
by DocDJ on Wed, 30/09/2015 - 16:10
Sorry I took so long to append. "java -version" and "java -jar jedit.jar" BOTH give this error message:

C:\Program Files\jEdit>java -jar jedit.jar
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object


I'm not a Java programmer, so I don't understand what is wrong.

Live long & Prosper,
DocDJ
 
I did a search on the entire
by DocDJ on Wed, 30/09/2015 - 16:33
I did a search on the entire message string and found that I had to uninstall & re-install Java, especially noting that I had to
1. install java 32-bit
2. install java 64-bit
IN THAT ORDER.
And that did it!

What's really weird is that prior to the recent Java update Jedit was working. I just let java do its own auto-updates.

PS. It would be really nice if the installer checked do see what kind of system I had and then install both as needed. Even a message just asking the user at installation time would be helpful. Maybe Jedit could do a check too??

Live long & Prosper,
DocDJ
User login
Browse archives
« March 2017  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
12
13
14
15
16
17
19
20
22
23
24
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   50012
Context Free Art (*.cfdg)   0.31   40156
JBuilder scheme   .001   16445
ColdFusion scheme   1.0   16003
BBEdit scheme   1.0   16002
R Edit Mode - extensive version   0.1   14150
Advanced HTML edit mode   1.0   13519
Matlab Edit Mode   1.0   13392
jEdit XP icons   1.0   12860
XP icons for jEdit   1.1   11907