jEdit Community - Resources for users of the jEdit Text Editor
on font aliasing (again) under Linux
Submitted by xenthar on Sunday, 29 May, 2016 - 09:54
There is *not* a lot of activity here.

When I search for font aliasing support under Linux, I find very diverse topics and messages everywhere and most of them are really old.

I will just say now that on my Ubuntu (Kubuntu) 16.04 system, in KDE, the actual configuration dialog looks good. But the actual text, as well as the interface.... even when using identical files (fonts) as other (KDE) programs, looks readily different and very ugly.

In general such things happen more in Linux (KDE) particularly when using some old GTK app (I think). Moreoever, some Linux distributions appear to have no good fonts at all; it seems and is sometimes said that only Ubuntu has good font support; my latest adventure into OpenSUSE was abysmal in that regard and full of problems.

For me a very complicated topic and I cannot see the forest for the trees.

Fonts that look AMAZING in e.g. "Kate" look abysmal in jEdit, and have very different font width, font spacing, etc.

I will post a screenshot later when I get down to it.

The difference is just outstanding and the minute anti-aliasing that I can detect in jEdit screenshots just doesn't cut it.

It is so bad that I even refuse to use jEdit even though it has been my favourite java editor since like forever. I now edit in console-mode Vim and only use jEdit for copy & paste operations, in general.

It is just horrid. This has been going on for such a long time in Linux, and when I see the instructions for jEdit of the past, I get sick in the stomach to begin with.

So I wonder if anyone can tell me in advance, before going through all that, if any of those instructions are still current?


I have attempted "http://jedit.9.x6.nabble.com/jEdit-fonts-on-Ubuntu-Linux-td1823304.html" but none of it did anything.

Meaning, this line:

exec java -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -jar /usr/share/jedit/jedit.jar org.gjt.sp.jedit.jEdit -reuseview "$@"

doesn't change anything.

So I don't know what to do. I haven't tested anything else like NetBeans.
Comment viewing options
Select your preferred way to display the comments and click 'Save settings' to activate your changes.
Here is a screenshot. As you
by xenthar on Sun, 29/05/2016 - 10:01
Here is a screenshot. As you can see, the interface looks reasonably well. But the actual edit text does not:

jedit-screenshot-kde-5-1.png

Oh, java version is now open-jdk-8:

/usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java
 
trials
by Robert Schwenn on Sun, 29/05/2016 - 13:16
Are You sure this is a jEdit issue rather than a Java issue? What's about other Java applications or othe jre/jdk?

Maybe another font does the trick, I'm using Courier New (on Windows).

Propably this article could help (though not intended for end users):
https://docs.oracle.com/javase/tutorial/2d/text/fonts.html

Robert
User login
Browse archives
« September 2017  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   50661
Context Free Art (*.cfdg)   0.31   40793
JBuilder scheme   .001   16802
ColdFusion scheme   1.0   16368
BBEdit scheme   1.0   16354
R Edit Mode - extensive version   0.1   14598
Advanced HTML edit mode   1.0   13861
Matlab Edit Mode   1.0   13774
jEdit XP icons   1.0   13243
XP icons for jEdit   1.1   12260