jEdit Community - Resources for users of the jEdit Text Editor
Visible Tabs?
Submitted by rovf on Tuesday, 23 March, 2010 - 17:29
I have set my global options like this:

Tab Width: 4
Soft Tabs: checked

When I press the Tab character, the text is intended to the next multiple of 4 characters, and the intending is done by inserting spaces. This is OK.

When I however open a file which already containins tabs, these settings cause jedit to display the text alsoe tabulated to a multiple of 4, but there is no visual clue that we have a tab character (it looks not different from spaces).

What I would like, however, is the following behaviour:

- If the text contains "hard tabs", they should be displayed either using some special (rarely used) character - as most text editors do - or by using a different background colour - which I would prefer.

- In addition, I would like to set up a different tab width for hard tabs (for instance, 8 characters).

Is this possible with jEdit?
Comment viewing options
Select your preferred way to display the comments and click 'Save settings' to activate your changes.
Or use syntax highlighting
by mgates17 on Tue, 18/10/2011 - 20:55
You can also modify the syntax highlighting rules to highlight tabs. In particular, this gives the ability to change the background color of tabs, which the WhiteSpace plugin does not do.

For instance, add the line below to the c.xml file (somewhere in your jedit application or settings directory), inside its <RULES> tag:

<SEQ TYPE="LITERAL4">&#9;</SEQ>

Then adjust the background of Literal4 in jEdit's syntax highlighting preferences. The &#9; is a tab character (ASCII 9).

-mark
Whitespace Plugin
by Robert Schwenn on Tue, 23/03/2010 - 19:20
You need the Whitespace Plugin and have to enable "Show Tabs".

That's the way, most of the WhiteSpace plugin's features are applied:
- You can toggle them immediately for the active buffer via plugin menu
- You can set a default for newly opened buffers via plugin options pane

So, changing an option in plugin options pane has no effect for already opened buffers! You have to re-load the buffer after checking this option. Or You can toggle an option by invoking the corresponding action via menu "Plugins -> WhiteSpace.

Regarding Tab width:
Since this is a per buffer setting (Utilities -> Buffer Options), You can have a different tab width in every buffer. But in one buffer You can have only one witdth - same for hard and soft.

Robert
 
Whitespace
by dalexander on Tue, 30/03/2010 - 18:06
just tried this, but I am unable to see hard tabs either. Installed Whitespace and set it to show tabs in a shade of blue not used in my color scheme. Nothing. I'm running 4.3.1 under Windows 7

Dave
 
?
by Robert Schwenn on Tue, 30/03/2010 - 18:33
1. What means "Nothing"?
2. Did You pay attention to my handling notes (resp. the plugin help)?
3. Try also to show spaces.

Whitespace plugin works well. If You enable to show all kind of whitespace You must see something!

Robert
User login
Browse archives
« February 2018  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   51052
Context Free Art (*.cfdg)   0.31   41260
JBuilder scheme   .001   17052
BBEdit scheme   1.0   16657
ColdFusion scheme   1.0   16635
R Edit Mode - extensive version   0.1   14918
Advanced HTML edit mode   1.0   14092
Matlab Edit Mode   1.0   14037
jEdit XP icons   1.0   13462
XP icons for jEdit   1.1   12486