jEdit Community - Resources for users of the jEdit Text Editor
--AutoIt v3-- support request
Submitted by Haloloooya on Tuesday, 23 May, 2006 - 02:31
Is anyone interested in providing AutoIt support for editing files with JEdit? http://www.hiddensoft.com/autoit3/

Thanks.
Dockable window problem.
Submitted by inami on Monday, 22 May, 2006 - 17:23
How to create a new dockable window and make it docked into the view(at any of the 4 positions TOP,BOTTOM,LEFT,RIGHT except FLOATING) defaultly?
Is there a new version of the JCompiler in development?
Submitted by iNetRunner on Friday, 19 May, 2006 - 08:40
Hi,

Is there perchance a new version of the JCompiler in development? 1.7 can't seem to work with 4.2.xx versions of the Console. (Gives the java.lang.NoSuchMethodError: console.Console.setShell(Lconsole/Shell;... error. Also seems to work with only some success in Console 4.1.2.)
notification when dockable is displayed?
Submitted by achim on Friday, 12 May, 2006 - 09:27
Hallo,

I'd like to build a plugin, which is _only_ displayed as a dockable when
in the editor are special kinds of files open. For example files with
the extension '.xml'.

For the first call of my plugin I managed the discribed behavior by the
following code in my 'dockables.xml':

if (buffer.isUntitled() || (! (buffer.getName().endsWith("xml")))) {
Macros.message(view, "JaserReports-Plugin is only supporting files
with the extension '.xml'");
return;
}
else {
return new de.infokomGT.jjr.JasperReportsView(view, position);
}

But for all following calls to open the plugin, this code has no effect.

So I tried to be informed by the MessageBus, but it seams there is no
message send, when the DockableWindowManager opens or closes a window.

Any help is welcome.

Achim
Plugin to work with uneditable and editable regions in the code
Submitted by canelita on Sunday, 7 May, 2006 - 21:14
Do we have a plugin that allows me to have uneditable and editable regions in the code?
I need to lock some region in the code, so users cannot touch some code I have already generated.
Cheers
Bug in JARClassLoader when loading directories as Resources
Submitted by ssaBrec on Wednesday, 3 May, 2006 - 18:46
Trying to retrieve a directory using:

URL url = class.getResource("org/foo/bar/definitions");
JarURLConnection connection = url.openConnection();

causes an IOException thrown by PluginResURLConnection.connect()

Perhaps the openConnection call shouldn't try to get getResourceAsStream ? Just let the caller validate the Connection's contents. Basically, right now, it seems that retrieving a directory and then iterating through its entries is impossible?
DotComplete cannot parse Java 5.0 source
Submitted by TTAnimal on Tuesday, 2 May, 2006 - 12:19
Title says it all really. I get no DotComplete popups when editing code with @nnotations, or generics.

Will this be fixed????
How can I use a single buffer to load file content from several files(more than one)
Submitted by zhang_tx on Friday, 28 April, 2006 - 02:17
I'm trying to write a plug in for file content analyse, and I need to show contents of several files(more than one) in a single buffer, I tried a lot, but I can not do this job successfully, because the file to open is very big, so I want to use jEdit's Buffer object to do job, can some one give me any advice?
I tried to do in this way:
1. open each file I want to use by:
Buffer buffer = jEdit.getBuffer(aPath);
if (buffer == null) {
Hashtable props = new Hashtable();
buffer = jEdit.openFile(null, null, aPath, false, props);
} else {
// close if this buffer is currently
// visible in the view.
//if (buffer != null){
EditPane[] editPanes = panel.getEditPanes();
for (int j = 0; j < editPanes.length; j++) {
if (editPanes[j].getBuffer() == buffer) {
LogPump.textArea.append("Comming close buffer \n");
jEdit.closeBuffer(panel, buffer);
LogPump.textArea.append("Buffer closed for 1 time \n");
break;
}
}
}
2. than use Buffer newBuffer = jEdit.newFile(view) to get a untitled buffer,
3. than use Buffer temp = jEdit.getBuffer(path) to get every file's buffer I need
4. than use String test = temp.getText(0, temp.getLength()) to get the file content
5. than use newBuffer.insert(0, test) to insert the file content to the untitled buffer

But in the 4th step, I found that I can not get the Text because the Buffer temp is not load, so my question is how can I load a buffer for disk mannually, I've tried the buffer.load() method, but it doesn't work, how can I do ?
How can I load a Buffer
Submitted by zhang_tx on Thursday, 27 April, 2006 - 13:40
I'm writing a plugin for jEdit. In the plugin, I need to get File content by path, My code like this:

Buffer _buffer = jEdit.getBuffer(path);
String content = _buffer.getText(0, _buffer.getLength());

but this code caught NullPointException.
Then I found that the _buffer is unload:

_buffer.isLoad() = false;

so my question is how can I get a Buffer by path and load it,
or how can I get File content with the file path.

I'm the beginner in JEdit plugin develop, I hope if some kind man can help me with this problem, SOS, whoever you are, thank you very much!Smiling
Developing New Project Management Plug-in
Submitted by philmaker on Monday, 24 April, 2006 - 05:28
This week I am creating a plug-in which will be a fresh approach to managing a projects files. It will have some of the functionality of ProjectViewer but with a radically different GUI. Most of these new GUI elements I had created in a past personal project. I have used ProjectViewer for at least three years and I find it extremely useful but I am now finding its limits because I have so many small related projects. I will also integrate some aspects of AntFarm somehow but without making the new plug-in relevant for Java projects only. I hope to have something demoable by the end of this week. I'll be looking for developers to help me enhance and complete the plug-in and I'll likely need some testers as well. I'll have more details online once I post the demo and commit to CVS. Please contact me if you're interested in helping.

Thanks,
Philip Weaver
sftp plugin and defunct sftp-server processes
Submitted by edoceo on Tuesday, 18 April, 2006 - 23:38
I use and love the sftp plugin but I notice that on some of my servers (gentoo) I get many defunct sshd/sftp-server processes. Anyone else seeing this issue?

My SSH servers are:
# ssh -V
OpenSSH_4.2p1, OpenSSL 0.9.7i 14 Oct 2005

In the sshd_config file I had these values:
# grep Client /etc/ssh/sshd_config
ClientAliveInterval 0
ClientAliveCountMax 3

Meaning no keep alive is sent on the SSH channel (different from TCP keep alive).
I'm tweaking/studying those affects as I type, any other hints?
LookAndFeel 1.1 with jEdit 4.2final -- "Cannot start...Unsupported major.minor" -- "Try updating..."
Submitted by Phrawm48 on Wednesday, 29 March, 2006 - 22:18
jEdit 4.2final, LookAndFeel plugin version 1.1, JRE 1.5.0_06.

Both the jEdit Plugin Manager and the the LookAndFeel plugin page (http://plugins.jedit.org/plugins/?LookAndFeel) tell me:

- Version 1.1 of LookAndFeel is the latest, greatest version

- Version 1.1 is intended for use with jEdit 4.2final

Despite this, if I install LookAndFeel 1.1 I receive the following "Plugin Error" message box when I start jEdit 4.2:

C:\Program Files\jEdit\jars\LookAndFeel.jar:
"Cannot start: java.lang.UnsupportedClassVersionError: lookandfeel/LookAndFeelPlugin (Unsupported major.minor version 49.0)
Try updating to a newer version of the plugin.

But as best I can tell there is no newer version of the plugin.

Any ideas?

Cheers & thanks,
Ric
SFO
Console : where are the error patterns ?
Submitted by Baldurien on Friday, 24 March, 2006 - 18:19
Hi,

I just installed the last version of the Console plugin, and *pouf* : no more pattern for the error list! So when I run my make command, I don't have the error in the error list (which is practic when with C++ ...)

I don't want to rewrite them all, so I decided to desinstall Console, and reinstall it, but since it seems that the pattern are not even in the release :/

What could I do?
perlsidekick - especially for the author
Submitted by cvicari on Wednesday, 22 March, 2006 - 12:04
Hi everybody,
I installed the latest version of PerlSideKick in jedit 4.2final, using the plugin manager.
But, after installation, it claims that SideKick >= 0.5 is needed, while SideKick 0.5 claims that it needs at least jedit4.3pre3.
I guess that we need either to change dependencies handling, or simply the requirements for PerlSideKick.
problems rebuilding clipper jar
Submitted by jesseainskeep on Saturday, 18 March, 2006 - 21:36
Ok, I followed the directions, made a new clip library, added it to the jar file and all that stuff.

Now, I think my problem is that I just need to rebuild the jar file.

Can someone tell me how to do this. I tried with NetBeans, and the visual basic suite, neither will do it for me.

What am I doing wrong?

Thanks in advance.
Magically matching caret on new SideKick Plugin with SideKickTree nodes
Submitted by mabushadi on Friday, 17 March, 2006 - 21:52
Hello,

I've been working on a SideKick extension parser (for FOCUS code) and was successful in adding Assets to the SideKick tree using SideKickParsedData. Clicking on the SideKickTree will make the caret jump fine to the right place in the textarea. But I can't get the reverse to happen. I can't click on the code buffer and have the SideKickTree adjust to the right node. Just how do you achieve that magic?

Your guidance is greatly appreciated.
Thanks and regards
Choose and insert file path and name to hyperlinks
Submitted by philaweb on Tuesday, 14 March, 2006 - 12:51
Hi,

I am new to this forum and to JEdit plugin's as well.

Is there a plugin avialable for download with the functionality of choosing and inserting a file path and file name to hyperlinks?

Well, it is the only tedious thing about the plain JEdit version, that I have to type all file paths and names manually.

TIA
XML Plugin: Updated Ant Completion
Submitted by Stillglade on Tuesday, 21 February, 2006 - 16:20
The Ant code completion when editing a build.xml file is currently outdated (based on Ant 1.5). This functionality is driven by the ant-complete.xml file found in the XML Plugin (a sort of DTD for Ant). I created an Ant task that when run will generate an updated ant-complete.xml based on the version of Ant used when running the task (it uses the Introspection Helper to see all available task/types and their attributes/sub-elements). I created a patch for the build.xml of the XML Plugin so that when built, it will also update the ant-complete.xml file as part of the build. This will keep this file from getting out of date in future releases of the XML Plugin (assuming that new versions of Ant are used when building for a release). Also, this is useful for those who wish to build the plugin themselves as it will allow them to use Ant code copletion with their specific types and tasks which may be added to their local Ant installations.

I recently created a bug report which has these changes attached - http://sourceforge.net/tracker/index.php?func=detail&aid=1432414&group_id=588&atid=565475
TextMate snippets importing
Submitted by delackner on Monday, 13 February, 2006 - 07:36
SuperAbbrevs is a plugin that has functionality similar to Textmate's and Eclipse's to paste a template with placeholders that you can tab through. Textmate supplies a lot of nice defaults.

Textmate is OS X only, so I wrote a command line Cocoa tool to convert binary plists to xml plists, which I then batch run against the snippet files I want.

Then I modified SuperAbbrevs to have an import option, which takes a directory and imports all .xml or .plist files it finds there, converting $0 endings to $end endings.

If anyone would like to polish this into something more end-user usable, I'd be happy to email the code. For my purposes it has already consumed far more time than I wanted.
How to change plugins properties during the installation?
Submitted by Siver on Thursday, 26 January, 2006 - 15:27
Hi,

I'm working on installation CD with jedit and I would like to install all the plugins with jedit properly. This requires to set some plugins configuration.
Is there a regular way how to do it?
As I understand it's not easy to change plugin *.prop property in *.jar archive during the installation (for exampe, a path for ctags for Code Browser plugin) (perhaps to patch java sources of the plugin looks better...).

Thanks in advance,

Andrey
User login
Browse archives
« November 2014  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   47251
Context Free Art (*.cfdg)   0.31   37213
JBuilder scheme   .001   11585
R Edit Mode - extensive version   0.1   11403
BBEdit scheme   1.0   11150
ColdFusion scheme   1.0   11139
Advanced HTML edit mode   1.0   10855
Matlab Edit Mode   1.0   10720
jEdit XP icons   1.0   10180
XP icons for jEdit   1.1   9971