jEdit Community - Resources for users of the jEdit Text Editor
Console plugin: default for the -classpath option
Submitted by w0073r on Monday, 15 November, 2004 - 16:46
I looked around, but couldn't find a solution. I'm on Windoze, in a computer lab, so I don't have the ability to change my classpath. How can I get the Console plugin to default the -classpath option when I compile/run Java classes to a specific string, rather than just $CLASSPATH;? So I want it to default to $CLASSPATH;;"H:\compsci\MBS\Code\mbsgui.jar";"H:\compsci\MBS\Code\mbsbb.jar". The JCompiler plugin does that, but that doesn't help for running the file. Thanks.
Console plugin: default for the -classpath option
Submitted by w0073r on Monday, 15 November, 2004 - 16:46
I looked around, but couldn't find a solution. I'm on Windoze, in a computer lab, so I don't have the ability to change my classpath. How can I get the Console plugin to default the -classpath option when I compile/run Java classes to a specific string, rather than just $CLASSPATH;? So I want it to default to $CLASSPATH;;"H:\compsci\MBS\Code\mbsgui.jar";"H:\compsci\MBS\Code\mbsbb.jar". The JCompiler plugin does that, but that doesn't help for running the file. Thanks.
Using Eclipse to develop plugins
Submitted by Anonymous on Sunday, 14 November, 2004 - 09:27
I want to use Eclipse to develop a plugin. No problem setting up an Eclipse(3.01) project running JEdit 4.2 with breakpoints etc. But now I would like to be able to debug a plugin (setting breakpoints in the plugin source), and it seems to me that is not easily possible without modifying JEdit considerably (which I would prefer no to do). JEdit appears to be designed to only run plugins from jars. Any ideas?
Default encoding setting for each Sessions (in sessions plugin)
Submitted by Anonymous on Monday, 8 November, 2004 - 13:10
This would be great feature for people working with different encodings. They could set default encoding for each session (project) to load files with.
Anytime I reload session, it loads with default "Global" encoding instead of last used encoding Sad
Thanks for any help.
plugin startup
Submitted by Anonymous on Monday, 8 November, 2004 - 12:14
Hi,
Can a plugin be an extension of swing.JFrame or it must be an axtension of JPanel?

Thanks,
young developer
Loading the plugin
Submitted by Anonymous on Saturday, 6 November, 2004 - 14:13
Hi,
I'm doing a plugin extending class JFrame. I have compiled and archived my files. Later I have put the archive inside directory jEdit/jars. From the jedit Plugin Manager I see that my plugin has been loaded but it's not visible in the application menu!

What could be the problem?
How can I debug other problems?

Thanx in advance,
Mik
Extending EditPlugin
Submitted by Anonymous on Friday, 5 November, 2004 - 17:17
Hi. How can I import the class "org.gjt.sp.jedit.EditPlugin" for the plugin core class?
javac doesn't seem to find it.

Using ANT is compulsory or I can do everything manually?

Thanx in advance,
Mik
Parse Error on plugin menu action
Submitted by AndreJRenard on Monday, 1 November, 2004 - 14:30
I am in the final development phase of a new plugin, trying to add an action to a plugin item.

The actions.xml file contain a call to an internal function: kmeditor.KMEditor.buildKMFile().

I got the following error message when I click on the menu item:

Parse error at line 6, column 1. Encountered: }
at bsh.Parser.generateParseException(Parser.java:5807)
at bsh.Parser.jj_consume_token(Parser.java:5759)
at bsh.Parser.Statement(Parser.java:2605)
at bsh.Parser.BlockStatement(Parser.java:2711)
at bsh.Parser.Block(Parser.java:2675)
at bsh.Parser.MethodDeclaration(Parser.java:355)
at bsh.Parser.BlockStatement(Parser.java:2706)
at bsh.Parser.Line(Parser.java:146)
at bsh.Interpreter.Line(Interpreter.java:991)
at bsh.Interpreter.eval(Interpreter.java:631)
at bsh.Interpreter.eval(Interpreter.java:731)
at bsh.Interpreter.eval(Interpreter.java:720)
at org.gjt.sp.jedit.BeanShell._eval(BeanShell.java:446)
at org.gjt.sp.jedit.BeanShell.cacheBlock(BeanShell.java:486)
at org.gjt.sp.jedit.BeanShellAction.invoke(BeanShellAction.java:73)
at org.gjt.sp.jedit.gui.InputHandler.invokeAction(InputHandler.java:229)
at org.gjt.sp.jedit.jEdit$3.invokeAction(jEdit.java:2910)
at org.gjt.sp.jedit.EditAction$Wrapper.actionPerformed(EditAction.java:216)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Any hint to what I should do or where I should look?
Thanks
Andre
vi, Vimulator resurrected
Submitted by Anonymous on Thursday, 28 October, 2004 - 20:08
I've just switched from vim to jEdit, but have been a hard-core vi/vim user for almost 10 years. That said, I'm definitely a keyboard user, and am quite happy with vi's keystoke combinations. To that end, I've resurrected the Vimulator to work with the current version of jEdit, in addition to adding a bunch of additional keystokes, fixing a couple of bugs, and introducing a couple of new ones... I'm thinking about throwing all my changes together and posting them, but don't want to waste anyones time if there isn't any interest..... any interest?

Jason ( jklap @ v_i_s_i.com --- try without the '_' )
How to Multiple Instances of jEdit?
Submitted by Anonymous on Wednesday, 27 October, 2004 - 21:36
Hi,
I am working on a plugin for jEdit, and I'm using jEdit for the coding. My problem is this: If I want to test my plugin I have to restart jEdit.

Is there a way to:
a) use multiple instances? (I downloaded the src, and compiled it to a different directory, with a different .jar, but when I run the .jar, it just brings up a copy of the jEdit instance that I already have open.
b) reload plugins?
c) do something else that I'm missing?

Sorry, I haven't RTFM, so feel free to scold me if it's in there.

Thanks,
Mike
IncludesParser up for adoption
Submitted by Sawdusty on Wednesday, 27 October, 2004 - 17:24
I am the original developer of the IncludesParser plugin for JEdit. I don't think its been overly popular, but I am no longer interested in maintaining it and would like to give it up for adoption to a caring (or even just interested) developer.

The current version available with JEdit is 0.4. I've rewritten it from scratch in a version 0.5 that never made it into the plugin manager, as it does not support the JEdit 4.2 plugin API. This new version fixes a bug that causes 0.4 to break under Windows, and contains much cleaner code. It is available from http://www.buchuki.com/software.html; I suggest it as a base for anybody wanting to adopt IncludesParser.

If anybody is interested in maintaining this plugin, feel free to contact me (dgp@buchuki.com).

Dusty
Timeline for updating plugins for Java 5: Tiger?
Submitted by Sawdusty on Wednesday, 27 October, 2004 - 17:17
I've started developing in Tiger and am having troubles with a lot of my favourite JEdit plugins. JavaStyle crashes on generics, enums, and static imports. SideKick (using Jane) is not able to parse the structure of files containing Tiger structures. Dot Complete also seems to be confused on occasion, but not so often that it hinders my work.

I know that these and other Java-Centric plugins are going to require a major overhaul to include the new Tiger features. I was just wondering if there's any timeframe in mind for when they will be supported or partially supported.

Thanks,
Dusty
Jane Plugin
Submitted by mbirth on Monday, 18 October, 2004 - 22:16
After fixing/changing two lines of the Jane-Plugin, its parser now complains about a <String,String> inside the Runtime-Sourcecode.

 

Fixes:
jane\lang\CommentProxySupport.java, line 76
OLD: if ((mInfo.getComment()==null) || (mInfo.getComment().trim().equals("")))
NEW: if (mInfo==null || (mInfo.getComment()==null) || (mInfo.getComment().trim().equals("")))
(Caused NullPointerException.)

 

jane\lang\MemberInfoBase.java, line 132
OLD: StringTokenizer st = new StringTokenizer(aComment, "\r\n");
NEW: StringTokenizer st = new StringTokenizer(aComment, "\n");
(Because \n is used in SUN's JavaDocs and Sources for the Runtime. Also you can split on \n because afaik the \r get's automagically removed by the trim() procedure a few lines further down.)

 

My Jane-settings:
CLASS: C:\Progra~1\Java\jre1.5.0\lib\rt.jar
SOURCE: C:\Progra~1\Java\jdk1.5.0\src\
JDOC: C:\Progra~1\Java\jdk1.5.0\docs\api\

 

Now, when typing "System." in jEdit, Jane parses the sourcecode and breaks with

 

[error] SideKick #1: 80 [SideKick #1] ERROR ccparser.JavaParser  - file:/C:/Progra~1/Java/jdk1.5.0/src/java/lang/System.java
[error] SideKick #1: jane.parser.ccparser.ParseException: Encountered "<" at line 840, column 32.
[error] SideKick #1: Was expecting one of:
[error] SideKick #1:     <IDENTIFIER> ...
[error] SideKick #1:     "[" ...
[error] SideKick #1:     
[error] SideKick #1:  at jane.parser.ccparser.JavaParser.generateParseException(JavaParser.java:4007)

 

The line in the System.java is:
public static java.util.Map getenv() {

 

Is there anybody out there who knows the ccparser used in Jane? It looks somewhat complex to me and I don't want to spend the next few weeks' evenings analyzing it just to fix this little bug...

 

btw: I didn't find any code for handling the Runtime-JavaDocs. But perhaps I didn't look deep enough into the code. For me, it looks as if only comments from Runtime-sourcecode are taken ...

 

Best regards,
-mARKUS

VFS and HTTP based protocols
Submitted by Anonymous on Wednesday, 29 September, 2004 - 06:13
Hi,

I have recently done some work on the DAV plugin.

One of the issues that came up was the use of VFS for http based protocols.
If I register my protocol as http, then jEdit tries to use my plugin to access
any files with a http URL. Of course http urls could be stored on a standard
Web server or on a webdav server or on a soap server etc etc etc.

To get around this, I registered my protocol as webdav. The plugin converts this to http
when it acceses the server. (In jEdit, I specify webdav://myhost/mycollection).

However, this causes its own problems. If I download an XML file from the Weddav server
and this file references a style sheet or schema with a http url, jEdit cannot download
these referenced files. If I modify the references to webdav URLs that stuffs up other
software.

It appears to me the the VFS interface is not flexible enough to handle http based protocols.

Is there any way around this?
Java Console Plugin please support stdin.
Submitted by Anonymous on Wednesday, 22 September, 2004 - 03:32
thanks!
Function parameters suggestion plugin (usual box with current param. bold)
Submitted by Anonymous on Tuesday, 21 September, 2004 - 19:16
Hello,

I'd like to know if there is someone developing (or planning to develop) such a plugin. If there is, i'd be glad to help. Otherwise, i could start developing the plugin myself, but it would be the first for me and i'm not a frequent java programmer, so i prefer the first case Eye-wink
In case i would begin developing it, what are the suggestions of you jEdit experts? What other plugins should i depend on?
From what other plugin should i get my ideas for the development?

Thank you
CharacterMap plug-in problem
Submitted by bibiko on Wednesday, 1 September, 2004 - 10:20
dear all,

I have a big problem with the characterMap plug-in.

I tried to insert unicode characters of block CJK (Chinese,etc) but I cannot choose this block because the the combo-box is visible but not active.

I tried it with version 1.1 and 1.2, on a PC (WinXP prof) jre 1.4.2_03, on a Mac (OSX 4.3) jre 1.4.2-38 with jEdit 4.2pre14 and final. Always the same.

My global coding is UTF8 and I tried some unicode fonts.

I can remember me that with an earlier version of jEdit the CharacterMap worked very fine.

Have anybody a solution?

Thanks in advance

bibiko
FTP plugin problem
Submitted by sss4r on Monday, 30 August, 2004 - 18:31
Hello,

I've been attempting to get support on this problem for months, so I am respectfully requesting that anyone who knows anything about this issue to please respond.

I have been unable to get the FTP plugin to work properly (I've tried on 3 different machines) since 4.2pre9. As the plugin is critical to my workflow, I have stayed with 4.1final; however, now that 4.2final is out, I would really like to start using it (in fact, I need to because there are newer plugins I need to start using that require it).

Having said all that, here's my dilemma:

I start with a fresh installation of 4.2final. I install the FTP plugin, version 0.7.2. When I attempt to open from a secure server, I click "yes" or "always" to the remote host authentication dialogue. Immediately I get the following I/O error:

Cannot list directory: com.sshtools.j2ssh.transport.MessageStoreEOFException: The message store has reached EOF

I have tried reinstalling dozens of times. Like I said, I've tried on three different machines. I've also tried with two different servers. Never had a problem until 4.2 hit pre9 or so. Opening a non-secure connection works fine.

Is anyone else having this problem? Does the author know about it? Can you duplicate it? Is there a fix in the pipeline? I'm desperate to get an answer (and a fix!) as I would really like to continue using jEdit.

Thank you very much in advance for taking the time to read this and for your help.

Thanks,
Shannon
Cant find server
Submitted by Anonymous on Saturday, 28 August, 2004 - 12:26
I am trying to connect to mysql. I have downloaded the plugin for sql and have provided the mysql Jconnector path but I cannot add the server. I am using jedit version 4.1
crypto?
Submitted by Anonymous on Thursday, 12 August, 2004 - 13:05
Wondering if I would release a crypto plugin for jEdit, what are the issues concerning the restriction inside the Us?Could such a plugin also be distributed everywhere?Is it possible to integrate in the plugin C or assembler code to speed up some routines or it must be pure java?
Salme
User login
Browse archives
« July 2014  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
11
12
13
14
15
16
17
18
19
20
21
22
23
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   46174
Context Free Art (*.cfdg)   0.31   36731
R Edit Mode - extensive version   0.1   10962
JBuilder scheme   .001   10711
Advanced HTML edit mode   1.0   10415
Matlab Edit Mode   1.0   10283
BBEdit scheme   1.0   10275
ColdFusion scheme   1.0   10263
jEdit XP icons   1.0   9738
XP icons for jEdit   1.1   9679