jEdit Community - Resources for users of the jEdit Text Editor
How to use the services of project viewer from within myplugin
Submitted by Anonymous on Saturday, 10 July, 2004 - 23:42
Hi,
How do i listen to events such as: what project is selected or what java file is selected using the services of project viewer from with my plugin. i have set the properties file already (plugin.jplant2.jplant2Plugin.depend.1=plugin projectviewer.ProjectPlugin 2.0.2). What else do i need to do?

Thanks.

Drake
How to write up a plugin that is dynamically loaded.
Submitted by Anonymous on Saturday, 10 July, 2004 - 11:08
hi,
How do i write up a plugin that can be loaded or unloaded without restarting jedit?

myPlugin.java has the following code
public class myPlugin extends
{
public void createMenuItems(Vector menuItems)
{
menuItems.addElement(GUIUtilities.loadMenuItem("myPlugin"));
}
}

Thanks,

salgavkar
Using Gruntspud to retrieve jedit from sourceforge
Submitted by Anonymous on Friday, 25 June, 2004 - 21:08
I'm trying to use Gruntspud to get the jedit cvs files on sourceforge.

USing gruntspud 0.4.6-beta on Windows XP.
When I issue an update command I get the following:

Changing home directory to c:\mycvs
Command update -d -P jEdit
[:pserver:anonymous@cvs.sourceforge.net:/cvsroot/jedit]
Opening connection
Connection opened
Local path is c:\mycvs
unrecognized request `Case '
Closing connection


Has any successfully used gruntspud to retrive jedit or jedit-plugin files from sourceforge?

Is there a workaround to the "unrecognized request" problem?
Where is AntHelper 0.8.4?
Submitted by Anonymous on Monday, 14 June, 2004 - 19:01
Beta plugins for AntHelper for JavaCore have been posted, but it contains a dependency to AntHelper Plugin 0.8.4. The latest I could find on this site or CVS is 0.8.3.

Is there a 0.8.4 or is the dependency in error?
trying to develop a test plugin
Submitted by gdhokamp on Friday, 4 June, 2004 - 13:35
Hello all,

I'm trying to develop a small test plugin. I studied the plugin tutorial and started then to write a very simple plugin. I only wanted the plugin to be loaded. I created a Cide.props, a CidePlugin.class and an actions.xml file. Put it all in a jar file, copied it to the jars directory and started jedit.
Unfortunately the activity.log says:

[debug] EditPlugin$JAR: Opening F:\jedit\jars\Cide.jar
[warning] EditPlugin$JAR: Ignoring: CidePlugin
[debug] ActionSet: Loading actions from jeditresource:/Cide.jar!/actions.xml
[warning] EditPlugin$JAR: F:\jedit\jars\Cide.jar has an actions.xml but no plugin core class
[debug] PluginJAR: Writing F:\jedit\jars-cache\Cide.jar.summary

What am I doing wrong? Or have I missed something?

Thanks in advance

Gerald
Look and Feel Isn't Working... what am I doing wrong?
Submitted by Anonymous on Tuesday, 25 May, 2004 - 00:37
I followed the directions and d/l a new theme pack (aqua), but it's not changing a thing when I choose it and the path in the plugin options. Is it not compatible with the pre13 version? I'm running XP and have the latest Java runtime as recommended by the documentation.
Plugins & Toolbar
Submitted by BeanProvider on Thursday, 6 May, 2004 - 10:07
Hello,

I am currently working on a plugin for a stx-debugger (stx is similar to xslt).
So I use a nice toolbar. Is there a possibility to hide the toolbar until
the dockable of my plugin was loaded.

Greetings,
Tolja
Next plugin batch: when
Submitted by svu on Wednesday, 28 April, 2004 - 09:22
It's more than month since the last release. Anyone knows when the next one is going to happen? People keep asking me for SQL Plugin version which would work with 4.2pre series...
XMLPlugin and Schema Validation
Submitted by webengr on Monday, 19 April, 2004 - 00:38

This could well be user error, which is why I am not using the "Report a Bug" link.

I am editing an XML schema in jEdit 4.2pre11, using XMLPlugin 0.13 (plus its required companions), running on JDK 1.4.2_04/Win2K. No matter what I do, I get this error in the Error List:

   cvc-elt.1: Cannot find the declaration of element 'xs:schema'.

The XML Insert pane shows the proper tags available, so jEdit did find a schema somewhere. Also, the target file does validate against my schema. Using "Edit tag at caret" to edit the <xs:schema> tag brings up the expected dialog box, BUT it also deletes the namespace binding for the "xs:" prefix.

I could be doing something wrong, but I didn't find any clues in the plugin documentation. Here is what my schema looks like at the moment:

<?xml version="1.0" encoding="utf-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:element ...>
    etc...
</xs:schema>

I have tried several permutations with various attributes for <xs:schema>, but I don't think that is the root cause. Any hints?

PCS

Is this kind of plug-in feasible?
Submitted by Anonymous on Friday, 16 April, 2004 - 19:28
I am thinking (dreaming?) of a plug-in that is somewhat like an outliner. Initially it might look a bit like this:

- keeps its own tree-like representation in memory
- tree-like view on left
- fast keyboard navigation (up, down, etc.) of tree
- fast keyboard manipulation of tree (move sub-trees around)
- based on which tree node is in focus
- corresponding set of nodes displayed on right side
e.g. like sticky notes
- xml format for nodes and their contents
- styled text for nodes and their contents (via some 'styling')
- some node sub-content will be code, using code-formatting
- some subtrees/nodes can be viewed as visual graphs
- option to invoke graphviz to generate graphs
- graphs presented on right hand pane

I don't know much about the plug-in architecture. Is this doable? Already done? What other things should I be looking at?

Thanks!
ErrorList
Submitted by Anonymous on Friday, 16 April, 2004 - 13:53
Hi All!
I'm currently developing a plugin and i've reached a point where I've to display error messages.
I've done a bit of reasearch and I guess that the ErrorList plugin does the job.
Unfortunately I did not find any documentation on how to use this plugin.

Does anybody know the meanings of the parameters of the constructor:
errorlist.DefaultErrorSource.DefaultError(ErrorSource arg0, int arg1, String arg2, int arg3, int arg4, int arg5, String arg6)?

PS: I'm currently developing my plugin under jEdit 4.1 and plan to migrate to 4.2 later on, so I'm using version 1.2.3 of ErrorList.

Regards,
Xserty
JEdit 4.2 pre11 and Background plugin
Submitted by rharlos on Sunday, 11 April, 2004 - 19:55
When I try to enable or disable the Background plugin via JEdit's Plugins menu, the following BeanShell error message appears:

~~~ begin error text:
java.lang.NoSuchMethodError: org.gjt.sp.jedit.textarea.JEditTextArea.getFoldVisibilityManager()Lorg/gjt/sp/jedit/textarea/FoldVisibilityManager;
at background.BackgroundHighlight.updateTextArea(Unknown Source)
at background.BackgroundHighlight.toggleHighlightEnabledFor(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at bsh.Reflect.invokeOnMethod(Reflect.java:149)
at bsh.Reflect.invokeStaticMethod(Reflect.java:100)
at bsh.Name.invokeMethod(Name.java:872)
at bsh.BSHMethodInvocation.eval(BSHMethodInvocation.java:72)
at bsh.BSHPrimaryExpression.eval(BSHPrimaryExpression.java:102)
at bsh.BSHPrimaryExpression.eval(BSHPrimaryExpression.java:47)
at bsh.BSHBlock.evalBlock(BSHBlock.java:130)
at bsh.BSHBlock.eval(BSHBlock.java:80)
at bsh.BshMethod.invokeImpl(BshMethod.java:349)
at bsh.BshMethod.invoke(BshMethod.java:246)
at bsh.BshMethod.invoke(BshMethod.java:171)
at org.gjt.sp.jedit.BeanShell.runCachedBlock(BeanShell.java:523)
at org.gjt.sp.jedit.BeanShellAction.invoke(BeanShellAction.java:76)
at org.gjt.sp.jedit.gui.InputHandler.invokeAction(InputHandler.java:229)
at org.gjt.sp.jedit.jEdit$3.invokeAction(jEdit.java:2882)
at org.gjt.sp.jedit.EditAction$Wrapper.actionPerformed(EditAction.java:216)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$ForwardActionEvents.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$MouseInputHandler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
~~~ end error text.

When I press the error dialog's "ok" button, only the area of the JEdit window that was covered by the error dialog has been cleared of the background image. If I first drag the error dialog box all over the JEdit window, I can effectively remove any trace of the image so that when I press the error dialog's "ok" button, the desired state of no background image results.

Anyone else experience this? Find a workaround or fix?

Richard
JavaScript dot
Submitted by Anonymous on Thursday, 8 April, 2004 - 12:55
Hi, how can I write JavaScript code with JEdit, so when I write 'window.' for example, a list of properties of 'window' appear?
tools.jar & JCompiler
Submitted by rharlos on Wednesday, 7 April, 2004 - 21:50
I'm a relatively new JEdit user and I enjoy it very much. One point I'm struggling with is the visibility of tools.jar for the JCompiler plug-in.

I know I can just copy it into the jedit/jars folder (because I did this on a friends laptop just to get it working) but i really, REALLY want to solve this problem using JAVA_HOME and/or CLASSPATH.

When I installed the SDK (1.4.02), I opted to allow it to install the public JRE as well (was this my bad?). Without having set any environment variables (did I mention I'm using Windows XP Pro?), the plug-in reports that it can't find tools.jar ... that my java.home is the public install (c:\program files\java\j2re1.4.2_04\bin) ... the the tools.jar file is usually found (relative to java.home) in ..\lib, so...

I've tried creating a CLASSPATH env var that points specifically to the tools.jar in the SDK/lib directory... I've tried adding a JAVA_HOME env var that points to the SDK's \bin directory, and to the actual root/home directory... none of these things seems to work.

I feel as if I'm going to HAVE to copy tools.jar into jedit/jar in order to get this to work but I can't help but wonder if I'm just overlooking some simple step/idea that would allow me to get this working WITHOUT having to do the copy.

Any help much appreciated!

Richard
java *.java
Submitted by Anonymous on Thursday, 1 April, 2004 - 11:38
Hi,
does any one know if its possible to use the console/system plugin with command javac *.java ? i get

error: cannot read: *.java
1 error
Process javac exited with code 1
jEdit and gdb integration
Submitted by Anonymous on Wednesday, 31 March, 2004 - 18:03
jEdit and gdb integration - breakpoints, watch etc..
GUIUtilities.loadToolBar() change in JEdit 4.2 pre?
Submitted by beffy on Tuesday, 30 March, 2004 - 12:35
Hi there,
I tried to update a little plugin I wrote to JEdit 4.2. pre 11, but I am stuck updating my plugin toolbar...
in JEdit 4.1. final I am using
JToolBar toolbar = GUIUtilities.loadToolBar("tidedebug.toolbar");
Then I am iterating over the components to get my buttons and that's basically it...

start = (JButton) toolbar.getComponentAtIndex(0);
pause = (JButton) toolbar.getComponentAtIndex(1);
stop = (JButton) toolbar.getComponentAtIndex(2);
stepInto = (JButton) toolbar.getComponentAtIndex(4);
stepOver = (JButton) toolbar.getComponentAtIndex(5);
runToCursor = (JButton) toolbar.getComponentAtIndex(6);
stepOut = (JButton) toolbar.getComponentAtIndex(7);

But, in 4.2., this doesnt work anymore since now I get a Box back from this method:

Box toolbar = GUIUtilities.loadToolBar("tidedebug.toolbar");

I've tried to simply create new Buttons like this:

if(toolbar != null)
{
try
{
start = new JButton();
pause = new JButton();

etc., then setting Icons, ToolTipsTexts, adding ActionHandlers for every button, etc. but while the buttons are being rendered now, I'm still getting weird NullPointerExceptions all over the place and I'm not sure why... is there any other way doing this?
Or what is the recommended way now to add a Toolbar with usable buttons? And why was this changed?

Thanks for any advice!
best regards,
beffy
VIMOutliner like solution
Submitted by Gary Furash on Friday, 26 March, 2004 - 14:25
Has anyone built outliner functionality into jEdit - something like VimOutliner is for VI? It's pretty nifty.
Mac OS Plugin missing
Submitted by Anonymous on Tuesday, 23 March, 2004 - 20:22
Hi!
I am new to jEdit and XML, and when launching the editor, I keep getting the following message: "Mac OS Plugin requires a newer version of Java (MRJ 99.0)."
I've been searching for some time now but without any success.
Can anyone help?
Thanx
Eric
Proof of Concept SwitchPane Plugin
Submitted by adraken on Tuesday, 16 March, 2004 - 04:59
Hi,

I've wanted jEdit to have an Alt-Tab window switcher
(like on Windows and Mac) for edit panes for a while
now. That is, you'd cycle through windows, but the
order changes based on which windows receive focus, so
you can quickly switch between 2-3 windows.

This weekend, I hacked together this proof of concept
plugin to demonstrate the idea. After bumping my head
on the various KeyEvent workarounds and AWT warts, I
finally got it to work.

http://www.stanford.edu/~adraken/SwitchPane.jar

Just drop it in your jars/ directory and restart
jEdit. Use CTRL-BACKQUOTE (Ctrl-`) to switch between
edit panes.

The keyboard shortcut is hardcoded in and there are no
actions or options. But, if you like it and would like
to spend some time polishing it, the source is in the
JAR. Go for it.

Have fun.
Dave

P.S. I had to bypass the keyboard shortcut framework
because there was no other way for the plugin to know
when you let go of the modifier key. If you're still
confused, play with the real thing (Alt-Tab) and
notice how it behaves. But because I did that, we
can't use TAB as the action key (no Ctrl-Tab) because
View.processKeyEvent consumes any KEY_PRESSED event
for TAB.

P.P.S. Lee Turner's SwitchBuffer served as a basic
template for building this plugin. Thanks.
User login
Browse archives
« July 2014  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
11
12
13
14
15
16
17
18
19
20
21
22
23
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   46188
Context Free Art (*.cfdg)   0.31   36748
R Edit Mode - extensive version   0.1   10972
JBuilder scheme   .001   10730
Advanced HTML edit mode   1.0   10425
BBEdit scheme   1.0   10294
Matlab Edit Mode   1.0   10293
ColdFusion scheme   1.0   10282
jEdit XP icons   1.0   9748
XP icons for jEdit   1.1   9690