jEdit Community - Resources for users of the jEdit Text Editor
When will jEdit be cleared to use Java 9?
Submitted by jrs40 on Thursday, 18 January, 2018 - 15:06
I cannot use jEdit with Java 9. I am running a Windows 10 x64-x86 box. When I click on any shortcuts that start the jEdit.exe program I get a message stating that i need a Java 1.8.x JRE and then am sent to a java Website to download the appropriate JRE. How do I inform the jEdit.exe program tjat java 9 is a valid java installation? Failing that, when can I expect to see a version of jEdit compatible with Java 9? Remember, Java 8 is officially unsupported as of October 2018. I do not look forward to creating form my own use some sort of script to run on a Windows 10 box to emulate the jEdit.exe program.
ReadOnlyBuffer (Macro) not working with jEdit 5.4
Submitted by Hans_Bauer on Friday, 19 May, 2017 - 11:30
Using the MacroManager i downloaded the "ReadOnly Buffer"-Macro and associated a Toolbar-Icon with it.

The Macro does not seem to do anything in jEdit 5.4.

Possibly there is a code change in jEdit, because my own-written macro "ToggleReadOnlyBuffer" also stopped working after the update from jEdit 5.3 to 5.4.

Any idea to update the macro "ReadOnly Buffer"?

Thanks Hans
Where/How to submit bug reports?
Submitted by dsmith on Friday, 15 May, 2015 - 15:07
OK, so the subtitle comment on the forum says that bug reports don't belong here, but the SourceForge bug tracker won't let me submit a bug report without being authorised by the project admin. So, how do I submit a bug report?
Highlight issue when CSS + HTML in the same file
Submitted by margenn on Tuesday, 5 August, 2014 - 13:06
Incorrect highlight on code below. The problem is the character ":" on "li:first-child". The code is presented correctly when it is removed

The "Submit a bug" link, is not working, so, posting it here was the only way ive found to communicate this issue, sorry

<!DOCTYPE html>
<html lang="en">
<title>Template · Bootstrap</title>

<!-- Le styles -->
<link href="css/bootstrap.min.css" rel="stylesheet">
<style type="text/css">
body { padding-top: 20px; padding-bottom: 60px; }

.navbar .nav li:first-child a { border-left:0; border-radius: 3px 0 0 3px; }
<link href="css/bootstrap-responsive.min.css" rel="stylesheet">



<div class="container">


<div class="footer">
<p>© Company 2013</p>

</div> <!-- /container -->

<!-- Le javascript
================================================== -->
<!-- Placed at the end of the document so the pages load faster -->
<script src="js/jquery-1.7.1.min.js"></script>
<script src="js/bootstrap.min.js"></script>
jEdit 5.1.0 w/ JRE 1.8.0_05 + W7 64-bit = slow exit from jEdit?
Submitted by Phrawm48 on Thursday, 24 July, 2014 - 00:25

· jEdit 5.1.0
· Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)
· java version "1.8.0_05" (JRE Cool
· Windows 7 64-bit

On my W7 64-bit computer, jEdit 5.1.0 runs fine, but when I exit jEdit it takes 20+ seconds to finally close. This behavior is new after my recent update to my JRE8 / Java SDK on this computer.

On my Windows Vista 32-bit computer, jEdit runs fine AND exits / closes straight away. This is true even though I updated the JRE to the same version as the one on my 64-bit computer.

Has anyone seen this? I've tried re-installing jEdit but otherwise have no ideas. At this point I simply close jEdit then minimize its window so that it's out of the way until it finally closes.

Cheers & thanks,
ColumnRuler for jEdit: Misplaced indicator
Submitted by Hans_Bauer on Friday, 27 June, 2014 - 13:33
Sorry for using this forum for a plugin-bug, but the e-mail of the developer of the ColumnRuler did not work. Could you please submit this report to Brad Mace, if you have a valid e-mail adress?


Hello Brad Mace,

using your ColumnRuler for jEdit since several years i really have to thank you a lot for this tool.

Updating to jEdit5.2pre1 and ColumnRuler 1.0.3 the indicator is misplaced to the Cursor as shown in the png-file, given with the link below.

Is there a possibility to correct this or did i make a mistake?

Thank you a lot for your efforts.

Best wishes
Hans Bauer
Keyboard shortcuts broken in 5.0 ?
Submitted by weberjn on Wednesday, 19 December, 2012 - 12:12

I changed the find-next shortcut to C+g, the shortcut options dialog shows the change, but pressing C+g still results in the Go-To-Line dialog.
Anybody can confirm this?

phpparser and interface as member variable
Submitted by fenor on Tuesday, 11 December, 2012 - 14:22

If I have the following code, the phpparser marks the ->interface-> part as error and it is not parsed in the sidekick.

class CClass
public $interface;

function func1()
phpparser and interface as member variable
Submitted by fenor on Tuesday, 11 December, 2012 - 11:34

If I have the following code, the phpparser marks the ->interface-> part as error and it is not parsed in the sidekick.

class CClass
public $interface;

function func1()
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 15:08
If multiple files with different files format is opened then an error message appears that does not fit to screen.

Expected Results: The list of error message should be able to fit on screen so that user can click on OK button.

Test Enviroment: OS: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:32
When a file is printed, the filename also appears at the top of the page.

Expected Result: Application should be able to send the print command which should print only the contents of a file

Test Enviroment: Windows 7, 64-bit
Submitted by sanjeevpc on Tuesday, 8 May, 2012 - 14:19
When large input data are entered in a new file, the heap gets out space and displays an beanshellerror message which is not user friendly message. Also in the the beanshellerror message the text is typable.

Expected Results:
Appropriate user friendly error message should be appeared and in the error message text should not be typable.

Test Enviroment: OS: Windows 7, 64-bit
Submitting a bug report does not work
Submitted by rovf on Thursday, 1 March, 2012 - 14:05
I tried to submit a bug report today. I went to the bug tracker (, logged in, created the new Artifact, and submitted it. After this, I was redirected to the overview page (where I can see a list of the most recent bugs). My bug report was NOT there, and I was logged out!!

What is then the correct way to report a bug? I can't do it here in the Bug Reports forum, because I need to include a screenshot.
Search and replace in all buffers
Submitted by Hans_Bauer on Friday, 10 June, 2011 - 07:50
When having several *.prn-files/buffers (containing text only) open within one instance of jEdit and trying to search and replace e.g. "," by "." in all buffers i get the error

"The specified search file set contains no files. Please ensure that the file name filter and directory to search (if applicable) are set correctly"

The error occurs with jEdit 4.4pre1 under Win7x64
Session plugin - saving problem ftp user
Submitted by ottar on Wednesday, 6 April, 2011 - 09:52
There's an error when saving a session with files that are opened from a ftp-server and where you need to use domain name and user name to log on to the ftp-server.
An example:
I open file ftp://domainname\
Session saves this: ftp://domainname/
jEdit tryes to open: ftp://domainname:21/

If session had saved ftp://domainname\, it wouldn't be a problem.
Has anyone gotten Clearcase plugin to work with Jedit 4.3.2?
Submitted by stantonio on Tuesday, 8 February, 2011 - 20:37
Has anyone gotten Clearcase plugin to work with Jedit 4.3.2?
I was using this plugin fine with 4.2 and now it doesn't seem to work and get error at startup.
The error is :
Cannot start: java.lang.NoSuchMethodError: console.Shell.registerShell(Lconsole/Shell;)V
9:12:23 AM [main] [error] ErrorListDialog$ErrorEntry: Try updating to a newer version of the plugin.
Marker Drift
Submitted by Kineas on Thursday, 6 January, 2011 - 13:58

in the new (4.3.2) version of Jedit the markers no longer stick to their line "anchor". When you place a marker and save the file, the position is saved into the .marks file. If you press ENTER above the marked line it scrolls down, after a save the bookmark positions are updated in the .marks file.

But after restarting jedit the .marks file is no longer maintained, and the markers slowly drift away. Is this a known issue?

Duplicate Buffers after jumping to search result
Submitted by imgod2u on Sunday, 14 November, 2010 - 00:22
I've noticed this happen a few times now both on Solaris and on Windows. When searching a relatively large file (3000 lines or so), if I jump to a result (especially through Hypersearch), there would be duplicated buffers in BufferTabs. Now, I originally thought this was just a bug in the plugin but I noticed that when I edit one, the other buffer would not update. It would also pop up the notification that the file had been changed on disk.

This leads me to believe jEdit opened duplicate buffers of the same file after jumping to the search result line. I'm running 4.3 final using java 1.4.2 but on Windows, I've noticed it happen with the latest JRE and 4.3 final.

Has anyone else run into this problem? Any possible solutions?
PHPParser doesn't parse preg_replace
Submitted by premislaus on Wednesday, 7 April, 2010 - 11:01
code like this:

$addr2 = preg_replace("/(\d+.*$)/is", "", $addr2);

and parser says: Unexpected token: '$'

Problem with ProjectViewer 2.9.1 with old project file path
Submitted by Jabberwock on Wednesday, 13 January, 2010 - 06:18

I have a problem with the new version of ProjectViewer and jEdit 4.3.

All my project have been moved to a new location, that is OK.

But when a launch jEdit all my project files path are weird like ftp://\\totot//toto/toto, and i can ope properly the files.
I look the xml project files with the old version of project viewer and i see that the path is like ftp://toto/toto... and with the new id ftp:\\toto\toto

There is a solution to convert old format XML to new ?

Thanks a lot.
User login
Browse archives
« February 2018  
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51055
Context Free Art (*.cfdg)   0.31   41260
JBuilder scheme   .001   17053
BBEdit scheme   1.0   16658
ColdFusion scheme   1.0   16636
R Edit Mode - extensive version   0.1   14919
Advanced HTML edit mode   1.0   14092
Matlab Edit Mode   1.0   14038
jEdit XP icons   1.0   13463
XP icons for jEdit   1.1   12487