jEdit Community - Resources for users of the jEdit Text Editor
Write current date/time to a file as it is saved
Submitted by jhaefner on Sunday, 23 April, 2017 - 01:00
I am writing html and would like to write "Updated: ...the date of last modification.." on to the html file in a particular place. So, after testing that the file has been modified, I would like to write the current day and time to the file immediately after I tell Jedit to save the file, but before it is actually saved. Possibly, the solution would be to point my usual "save file" shortcut to a macro that writes the date/time info where I want it and then does the jedit save file command. Has anyone done this? If not, can any one point me in a direction to get me started? I have done simple ".bsh" macros, but nothing more complex. I am aware of Robert Schwenn's 2008 "insert_simple_date.bsh".

Thanks in advance. Jim
jEdit Server on OSX
Submitted by RobertX on Friday, 21 April, 2017 - 00:26
When I run jEdit on Windows, I create a shortcut and put it in the Startup folder that runs the jEdit server in the background. I have zero idea on how to do this on MacOS. Any help?
jEdit Server under OSX
Submitted by RobertX on Friday, 31 March, 2017 - 15:00
At work, on Windows, I create a startup shortcut that starts the jEdit server in the background and keeps it running. Is there a similar process to get that to work on OS X?
Lucene Wildcard Searches
Submitted by weberjn on Tuesday, 21 March, 2017 - 12:16
Hi,

for me the killer feature of jEdit is LucenePlugin. Lucene searches some 15 years of project notes for me, each year a simple 1MB .txt file.
You could well advertise more for LucenePlugin...

Anyway, looks like you cannot search wildcards or regular expressions (Standard Analyzer).

Of the Term Modifiers from the Lucene docs, only some terms work for me, Wildcard, Regular Expressions and Fuzzy Searches do not get accepted, the plugin simply does nothing.
Actually, I use mostly Proximity Searches, which still help a lot.

What did I do wrong?

And could you list some working search expression examples in the Plugin Help, please?

http://lucene.apache.org/core/6_4_2/queryparser/org/apache/lucene/queryparser/classic/package-summary.html#Term_Modifiers
TextAutocomplete
Submitted by CJreige on Saturday, 11 March, 2017 - 14:45
Has anybody had any luck installing the TextAutocomplete plug-in lately? I cannot get the Plug-in Manager to download it (it gives a download error). When I download it manually and try to install it, it doesn't really work within jEdit. I just wanted to see if anybody has had any luck with this plug-in.

Thank you,
CJ
Right to left supprt
Submitted by wkevils on Saturday, 21 January, 2017 - 10:26
Does jEdit support Right to left typing ? I could not find any support for it, and no plugin for this.

Kevin
Elixir edit mode
Submitted by Llelan D. on Saturday, 24 December, 2016 - 07:03
Is there an Elixir edit mode? I see there is an Erlang mode, which is similar but not this same and is very primitive.
Default encoding for a mode
Submitted by Llelan D. on Saturday, 24 December, 2016 - 07:01
How do I set the default encoding for an edit mode?

For example: I want to create a new document in the current edit mode (CS-n) Erlang. The encoding for Erlang documents should automatically be UTF-8. This should be separate from any global default encoding.

However, I can find no way to set a default encoding for an edit mode separate from the global default encoding. This is so fundamentally obvious that I'm still looking for something I've missed.
FTP plugin opened files
Submitted by mca on Saturday, 19 November, 2016 - 19:07
I've been using this plug-in for remotely editing files and it works fine. The only trouble I have is that after I closed jEdit, I have to reopen each file I was working with.
Does anyone know a way to remember the opened files remotely as it happens with local files? Tks.
Is it possible to remove/hide scroll bars?
Submitted by maurelioc on Friday, 5 August, 2016 - 01:01
Hi folks,
I want to know if it is possible to remove or hide the scroll bars as it is possible with gutter bars.
I could not find any command for this.
on font aliasing (again) under Linux
Submitted by xenthar on Sunday, 29 May, 2016 - 09:54
There is *not* a lot of activity here.

When I search for font aliasing support under Linux, I find very diverse topics and messages everywhere and most of them are really old.

I will just say now that on my Ubuntu (Kubuntu) 16.04 system, in KDE, the actual configuration dialog looks good. But the actual text, as well as the interface.... even when using identical files (fonts) as other (KDE) programs, looks readily different and very ugly.

In general such things happen more in Linux (KDE) particularly when using some old GTK app (I think). Moreoever, some Linux distributions appear to have no good fonts at all; it seems and is sometimes said that only Ubuntu has good font support; my latest adventure into OpenSUSE was abysmal in that regard and full of problems.

For me a very complicated topic and I cannot see the forest for the trees.

Fonts that look AMAZING in e.g. "Kate" look abysmal in jEdit, and have very different font width, font spacing, etc.

I will post a screenshot later when I get down to it.

The difference is just outstanding and the minute anti-aliasing that I can detect in jEdit screenshots just doesn't cut it.

It is so bad that I even refuse to use jEdit even though it has been my favourite java editor since like forever. I now edit in console-mode Vim and only use jEdit for copy & paste operations, in general.

It is just horrid. This has been going on for such a long time in Linux, and when I see the instructions for jEdit of the past, I get sick in the stomach to begin with.

So I wonder if anyone can tell me in advance, before going through all that, if any of those instructions are still current?


I have attempted "http://jedit.9.x6.nabble.com/jEdit-fonts-on-Ubuntu-Linux-td1823304.html" but none of it did anything.

Meaning, this line:

exec java -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -jar /usr/share/jedit/jedit.jar org.gjt.sp.jedit.jEdit -reuseview "$@"

doesn't change anything.

So I don't know what to do. I haven't tested anything else like NetBeans.
Validating XHTML5: how do I add the custom datatypes from the Nu Html Checker (v.Nu)?
Submitted by Graham Hannington on Monday, 22 February, 2016 - 05:10
I would like to use the jEdit XML plugin to validate XHTML5 using the RELAX NG schema from the Nu Html Checker (v.Nu):

https://github.com/validator/validator

I have downloaded the RELAX NG schema files from the v.Nu GitHub repo, and set the schema (Plugins > XML > Set Schema) for a sample XHTML5 document to refer to the XHTML5 RELAX NG schema.

As I expected, jEdit reports the following error:

> datatype library "http://whattf.org/datatype-draft" not recognized

due to the following line in the schema files:

datatypes w = "http://whattf.org/datatype-draft"

I know that I need to make available to jEdit - in its class path - a .jar that contains the datatype library, as described in:

http://www.thaiopensource.com/relaxng/pluggable-datatypes.html

but so far, I've been unsuccessful. I'm a newbie Java developer, so I am very likely missing something obvious, but I thought this would be relatively straightforward, because both jEdit and v.Nu use Jing, so I thought it would simply be a matter of copying the relevant files from v.Nu to jEdit.

I've taken the latest-release vnu.jar and stripped everything out of it except:

\META-INF\services\
org.relaxng.datatype.DatatypeLibraryFactory

that contains the lines:

com.thaiopensource.datatype.xsd.DatatypeLibraryFactoryImpl
nu.validator.datatype.Html5DatatypeLibraryFactory

and

\nu\validator\datatype\
Html5DatatypeException.class
Html5DatatypeLibrary.class
Html5DatatypeLibraryFactory.class

but I don't know how to add that .jar to the jEdit class path (I'm using jEdit 5.2.0 with XML plugin 2.8.7 - I know, not quite the latest - on Windows 7). I don't know how to tell jedit.exe to add the location of this .jar to its class path. Whatever I try - adding a classpath option to the jEdit.l4j.ini file, or defining a CLASSPATH environment variable - the jEdit activity.log reports:

Log: java.class.path=C:\Program Files\jEdit\jedit.jar

I even tried copying the contents of my "cut down" vnu.jar into jedit.jar, to no effect.

I'm stumped. How do I add the custom datatypes from v.Nu to jEdit?
Two problems with non-alphanumerics
Submitted by jhaefner on Friday, 25 September, 2015 - 22:08
Hi,
I'm using ver 5.1 on Ubuntu 14.10 using MATE ver 1.8.2 on a Dell Latitude 3450 laptop. I've noticed two problems that were not in Jedit 4.* but may be due to my setup.

1. A short-cut defined for CTRL+. (ie, control plus period) does not work. Other shortcuts with alphanumeric works. (Just noticed that "ALT+." works, so it must be me...???
2. An abbreviation with containing a non-alphanumeric does not work. The match algorithm stops at the non-alphanumeric. So, an abbreviation like "\bf" (w/o the quotes) does not work, but "bf" does get expanded.

If this is an issue with Jedit, I'd like to know how/if the above can be fixed. Obviously a work around is possible. If it is a problem with my laptop, any help from a guru would be appreciated.

Jim
Vertical indent lines
Submitted by Bannakaffalatta on Saturday, 22 August, 2015 - 14:43
Hi. How do I get rid of the vertical lines a that appear to mark a block of indented code? Thanks.

KP>
Console hangs, OS X 10.10.4
Submitted by SpiceWare on Monday, 10 August, 2015 - 14:22
Haven't used jEdit in a couple months. This weekend I went to work on a project and whenever I'd try to use the console plugin, jEdit would hang.

I suspect it's due to something that changed with OS X 10.10.4. Any ideas?
Caret move to first/last visible line bug?
Submitted by jhaefner on Wednesday, 17 June, 2015 - 05:26
Hi,
I use ubuntu 14.04 lts, jEdit version 5.1
$ java -version
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
OpenJDK Server VM (build 24.79-b02, mixed mode)

I have strange behavior of caret moves near the top and bottom of visible lines. Specifically, "go to first visible line" goes to the fourth from the top, and "go to last visible line" goes to the 4th from bottom. Further, "go to next line down", when within the top 4 visible lines jumps to the 4th line. It works correctly when the caret is positioned w/in the middleof the text.

Any one else see this?
copy and paste
Submitted by jhuang22 on Sunday, 14 June, 2015 - 09:25
I have used jEdit to create web code file in HTML for several years. I met this problem recently and do not know why. When I copy a paragraph and try to paste in jEdit, the whole paragraph become one long line. I paste the same thing to other text editor like Microsoft word or open office writer, it do not have this problem. I do not have this problem in jEdit before, I even can not remember when this problem started.


Please help.
partially case-sensitive mode file?
Submitted by SpiceWare on Saturday, 4 October, 2014 - 18:22

When writing code for the Atari 2600 I use the compiler dasm.

With dasm, the opcodes are case-insensitive so LDA can be written as LDA, lda, Lda, etc. As such, I've set the mode file to use <RULES IGNORE_CASE="TRUE">.

I've configured the mode file so the 2600's registers such as GRP0, which holds sprite0's shape for the current scanline*, get syntax highlighted. However, dasm is case-sensitive when it comes to variable names. As such, if I type grp0 into my source code the compile will fail.

As such, I'd like to be able to make some of the keywords case-sensitive even though most of them are not. Can this be done with jEdit? My current mode file, assembly-6502, can be found here. I'm planning to do an update soon and will be renaming it Atari 2600 Assembly as the mode file's not really for generic 6502 assembly language.

* Yep, just the current scanline. When the Atari 2600 was developed memory was extremely expensive, so much so that the 2600 only contains 128 bytes of RAM. So TIA, the video chip, was designed to be scanline based. This means the registers in TIA only contain enough information to draw a single scanline, so your code must update TIA's registers on each and every scanline in order to draw the screen the player sees.

Console plugin environment variable issue
Submitted by SpiceWare on Friday, 3 October, 2014 - 17:09
I've been using jEdit for Atari 2600 homebrew development since 2006. Spurred on by a fellow homebrewer, I recent delved into the plugins to figure out how to compile and run code from jEdit. I got it mostly working, though I ran into a problem with the environment variables. To figure out what was going on, I replaced my Custom Command for the Interpteter with an echo command and did some tests:

echo $f
/Users/darrellspice/Projects/Atari/Draconian/draconian.asm

echo $d
/Users/darrellspice/Projects/Atari/Draconian

echo $n
draconian.asm

echo $c
draconian

I know I can use multiple environment variables per command because my custom compile command works. The following compiles my source code (draconian.asm) and creates three output files(draconian.sym, draconian.lst and draconian.bin):
dasm $n -f3 -v0 -s$c.sym -l$c.lst -o$c.bin

For the interpreter step I needed to use the full path to the bin file, which is the source file with the extension .asm replaced with .bin. I thought that could be accomplished by $d/$c.bin but it fails to work.

echo $d/$c.bin
/Users/darrellspice/Projects/Atari/Draconian/.bin

The results I was expecting were:
/Users/darrellspice/Projects/Atari/Draconian/draconian.bin

So for some reason the second environment variable is being ignored. Any ideas? About jEdit shows:
jEdit 5.2pre1 server-background mode, using Oracle Corporation Java 1.7.0_67

In case you're wondering, Draconian is a port of Bosconian for the 2600. You can read about it, and even download a WIP ROM to run in Stella, over at AtariAge:
http://atariage.com/forums/topic/225044-draconian-2600/
http://stella.sourceforge.net

Thanks!
Change the prompt in the system console plugin?
Submitted by kmogli on Thursday, 10 July, 2014 - 23:05
The default prompt (current working directory) is sometimes long and leaves no room on the command line. I would prefer to change the prompt to something minimal (like '$' on Linux or '>' on my Windows system). Seems there would be an easy way to do this, but I can't find it. Can anyone help?
User login
Browse archives
« October 2017  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   50716
Context Free Art (*.cfdg)   0.31   40859
JBuilder scheme   .001   16847
ColdFusion scheme   1.0   16414
BBEdit scheme   1.0   16394
R Edit Mode - extensive version   0.1   14665
Advanced HTML edit mode   1.0   13902
Matlab Edit Mode   1.0   13815
jEdit XP icons   1.0   13284
XP icons for jEdit   1.1   12307