jEdit Community - Resources for users of the jEdit Text Editor
JEdit , Windows and 56.xx nvidia display drivers
Submitted by Lup on Wednesday, 17 March, 2004 - 01:45
I was using Jedit since a while with Windows, no major issue so far, but since i've installed 56.xx nvidia display drivers, when launching jEdit i have some display corruption.
Then i can use jEdit normally, but when i quit the program system becomes slow (menus are slow, windows draw slowly...)
I was using j2 beta 1.5, rolled back to 1.4.2_03, i still have the same problem, anyone else ? any workaround ?
the drivers seem to work perfectly well with other applications i use.
XSLT still gets transformation error
Submitted by Anonymous on Wednesday, 17 March, 2004 - 00:42
I've followed the instructions on moving the xalan, xercesImpl and xmlParserAPIs jar files, and adding the -D flag to the startup for my JEdit installation on Java 1.4.1_02 on RedHat Linux 8. I still get the transformation error about running with the old version of Xalan-Java. Is there something else that needs to be done? This worked fine when I ran JEdit with Java 1.3.1.
Can't get plug-ins to work
Submitted by Anonymous on Tuesday, 16 March, 2004 - 04:45
I have downloaded and installed a couple of plug-ins but have not been able to get even one of them to work. For example I have installed the JCompiler, the Debugger, the CodeAid plug-ins but cannot get any of these to work. eg cannot run the debugger. What I am doing wrong ?. I am running jEdit Version 4.2pre9. OS is Win NT 4. Immediate help will be appreciated.
+line option in command-line from windows?
Submitted by bjorn on Monday, 15 March, 2004 - 21:23
Has anyone gotten the +line option working on the command line under windows? For example, if I send a command:

C:/jEdit42/jedit.exe MyFile.java +line:4

It always treats the '+line:4' as though I am trying to open a file of that name. Other variants (e.g., -- MyFile.java...) have the same result.

Is there no way to pass in a line number on Windows if you are using the launcher?

Thanks for any help...
FTP-plugin kills internet connection depending on used network interface
Submitted by Anonymous on Saturday, 13 March, 2004 - 02:46
Hello,

I encountered strange Problems, when trying to save files on a remote server via FTP.

The envrioment:
- Centrino Notebook with 100MBit and WLAN network interfaces
- Win XP Prof.
- Java 1.4.2_02
- Jedit 4.1 / 4.2pre9 (problem occurs with both versions)

Everything works fine as long as I only use the WLAN to connect to the network. Saving files via FTP is no problem.

But if the notebook is connected via cable saving is not possible. Jedit shows the "1 I/O Operation in progress" message in the status bar and seems to grab up lots of memory (up to 200 MB). The whole Editor hangs for a while and does not respond to any user actions, it doesn't even display properly. Its just gray. In the same moment the internet connection dies.

After 1-2 Minutes jEdit comes back to life, the "I/O operations in progress" message disappears but the file remains marked as changed and not saved. No changes to the data on the server was made.

It is not possible to close jEdit afterwards (i have to kill it using the task manager). The worst thing is that the network connection is dead until I restart the computer. I even can't ping my internert router.

Shutting down Windows also does not work anymore after jEdit killed the connection. It just freezes during shutdown. Only way to restart is a hard reset of the machine.

I'm wondering how someting like that can happen. It just makes no sense at all.

Greetings

Jan Harder
Mac OS X Notes w/ jedit 4.2pre9
Submitted by Anonymous on Friday, 12 March, 2004 - 07:51
Hey Folks,
I just got the copy of pre9 again tonight, I ditched it a while ago because the first thing I noticed when I started using it was that the scrolling speed was REALLY slow, so I figured I'd have to stay w/ jedit4.1 ... anyway, i just re d/led it .. the scroll speed was still sluggish, but for some reason I decided to change the look/feel in the appearence pref from Mac OS X over to Metal, and the scrolling speed problems were fixed!

I noticed that this was mentioned once or twice on the forums, but never came accross a solution, so I figured I'd let y'all know.

Also, the mac plugin now seems to be working as expected so far ..

Sorry if this was all covered before, but I'm pretty psyched about the whole deal, really ...


thanks!

-steve

ps - I'm using the latest version of Panther w/ all the updates (including the java 1.4.2 updated that caused many-a-woe...)
cannot quit jedit using MacOS 10.3
Submitted by Anonymous on Monday, 8 March, 2004 - 21:59
Hi,

I'm running MacOS Panther with newest updates.
Jedit 4.2 pre9 won't quit/exit.
Display_shortcuts.bsh - no output to document
Submitted by Anonymous on Sunday, 7 March, 2004 - 19:53
I have new JEDIT 4.2pre9. Display_shortcuts.bsh can show table, but buttons and key letters are not working. I can only close the window using upper right cross ....
Display_abbreviations.bsh is working well. Problem with my hands?
Mike
Alt-Tab problem
Submitted by Anonymous on Wednesday, 3 March, 2004 - 16:07
When I Alt-Tab in Windows XP from another application to jEdit, jEdit thinks that I've hit the Alt key and the top menu gets the focus. I have to hit escape (or Alt) to go back to editing. Does anyone else have this problem?
Tilde won't work in Linux
Submitted by Anonymous on Sunday, 29 February, 2004 - 15:34
I had this issue in Linux, with 4.2 pre 8 and in pre 9 as well.

jEdit does not accept the tilde as a single character. For instance, I tried to type a web address as www.ic.unicamp.br/~ra, but the tilde does not show up.

Latin characters, such as ã, ñ, etc. show fine.

If I use another editor to type the tilde alone, and copy-paste it into jEdit, it works fine.

In Windows it works fine.
CLASSPATH Windows XP vs JEdit classpath
Submitted by Anonymous on Saturday, 28 February, 2004 - 16:45
Hi, Im having a hard time setting my CLASSPATH in the Environment Varaiabels. I want to add somw package, jar-files to it but it wont simple work. BUT it works like a charm when I add the value to JEdits JCompiler Plugin's classpath. So my question is dose JEdit's classpath override Windows's CLASSPATH?
Can't type quote characters
Submitted by Anonymous on Thursday, 26 February, 2004 - 16:32
Problem: When typing the ' or the " character, nothing appears on the jEdit input window.

Environment:
Linux 2.4.21 - basically RedHat 7.2 with updated kernel and libraries
Java2 1.4.0_01-b03

The ' character is a dead-key. Typing it twice gets the character. This works in all other applications I use.

Attempts to fix:
I've tried this in jEdit 4.1, jEdit 4.2pre6, and jEdit 4.2pre9 with the same results.
I've read all the documentation and have read through the message archives. No one else seems to have reported this problem. Thus I suspect it's unique to this machine's configuration.

Using the jEdit->Utilities->Troubleshooting->Keyboard Tester I get the following results:

In jEdit 4.1, pressing the ' key results in

Event java.awt.event.KeyEvent[KEY_RELEASED,keyCode=129,keyChar=' ',keyLocation=KEY_LOCATION_STANDARD] on org.gjt.sp.jedit.gui.GrabKeyDialog$InputPane[,0,0,204x25,layout=javax.swing.plaf.basic.BasicTextUI$UpdateHandler,alignmentX=null,alignmentY=null,border=javax.swing.plaf.BorderUIResource$CompoundBorderUIResource@613b53,flags=296,maximumSize=,minimumSize=,preferredSize=,caretColor=javax.swing.plaf.ColorUIResource[r=0,g=0,b=0],disabledTextColor=javax.swing.plaf.ColorUIResource[r=153,g=153,b=153],editable=true,margin=javax.swing.plaf.InsetsUIResource[top=0,left=0,bottom=0,right=0],selectedTextColor=javax.swing.plaf.ColorUIResource[r=0,g=0,b=0],selectionColor=javax.swing.plaf.ColorUIResource[r=204,g=204,b=255],columns=0,columnWidth=0,command=,horizontalAlignment=LEADING] passed

Note: in the above, the character between the ' ' was not a space. I replaced it with a space because that's what appeared on the screen. What was there was a 0x3f byte - a question mark. I did a hexdump on the file after I saved the buffer this diagnostic appeared within. Note that the key code is a decimal 129.

In jEdit 4.2pre9 pressing the ' key results in

Event KEY_RELEASED,keyCode=0x81,keyChar=0xffff,modifiers=0x0 passed

I'm not sure what's going on here. Any help?

Roy Kimbrell
FTP doesn't work with TANDEM/Guardian ftp server
Submitted by michael_zee on Tuesday, 24 February, 2004 - 15:53
I try to connect my TANDEM host "myhost" as account "my.account" from my PC running JEdit, and I get an error message :

ftp://my.account@myhost:21/~/:
Cannot list directory : ft.FtpException : 550 XCWD valid $volume.subvolume format required

I searched for a while but didn't find which ftp servers are correctly handled by ftp plugin. I'm afraid TANDEM/Guardian ftp server is not.

Can someone help ?

Thank you
Whacked permissions on a shared drive under Win2K
Submitted by setmajer on Sunday, 22 February, 2004 - 20:33
This is as likely due to my own pathetic admin skills as anything, but here goes:

I'm running jEdit from a 'power user' account on a Win2K laptop. I'm editing a file that resides on a Mac OS X.2.8 desktop. 'Windows File Sharing' is enabled on the Mac, and that's how I'm connecting to it with the PC (I used an theusername/p'word from an admin account on the Mac I connected to it, if that makes a difference).

I mapped the folder containing the file using 'Map Network Drive...' on the Win2K machine, then opened it in jEdit, made a trivial change and saved it. Thereafter, the permissions were set to 740 (they had been 755). I can't set the permissions back via the Windows Explorer, either, so I have to get up and walk over to the Mac to fix the permissions.

Any ideas what I've screwed up?



Some additional observations:

-- When viewed from the Mac, the permissions of the directory are 755. When viewed from the PC, there's no access allowed for anyone other than my own account (the file's owner). I've tried changing the permissions on the directory from Windows to allow everyone to read & execute the folder but it never sticks; the PC just churns for 5 min. or so, then closes the Properties dialog; when I reopen it, the permissions are unchanged.

-- jEdit changes the permissions on the files if I access it directly from the network location (//hostname/directory/file.ext) as well.

-- HomeSite doesn't ever change the permissions on the file, but HTML-Kit misbehaves just as jEdit does.

-- jEdit behaves itself if I open the file via FTP, but I'd rather not type a URL + username + password every time I want to open a file.
word wrap woes
Submitted by jeidsness on Thursday, 19 February, 2004 - 01:39
hello, all. I have upgraded from 4.1 to 4.2pre9 and cannot figure out how to get word wrap working properly.

I'd like it to do a softwrap to whatever size the text pane happens to be. if i set it to soft wrap, with a margin of 0, it doensn't wrap at all. i can put in a specific margin size (50 or whatever) and it wraps, but sometimes i have 2 files open side by side, sometimes only one (not to mention sometimes i make the jedit window smaller/bigger). i'd like it all to wrap automagically.

am i looking in the wrong place?

thanks in advance
Plugin download stalls
Submitted by Anonymous on Wednesday, 18 February, 2004 - 22:13
I'm trying to install a plugin...

My jEdit Plugin Manager opens, and downloads the latest list of plugins OK, but when I select one or more to install, the Installing Plugins progress bar appears, but does not download anything.

My modem monitor shows that no data is being downloaded. It doesn't matter which pluing I try or where I try to save it.

Please help. Thanks, Tom

System info:
J2SE SDJ 1.4.1 on Win98
dial-up modem
jEdit 4.1final
DotComplete
Submitted by baloo on Wednesday, 11 February, 2004 - 15:20
Hi, i had installed the DotComplete plugin, and now when i save and/or compile my java code jEdit that 99% of my cpu for a long time... is it something i could do?
thx
Long text lines under linux
Submitted by Anonymous on Tuesday, 10 February, 2004 - 14:38
It appears that JEdit has problems when opening a file containing long lines - for example a file containing 5 lines each of 100000-500000 characters in length. Under
Windows this seems to work OK (if slowly) under Linux it seems to consume a large percentage of CPU then stop responding to user input (even after some time [>10 mins] has elapsed).

Any thoughts as to what could be causing this? I don't think this is really a bug (as it works OK under windows) but I would like help in narrowing down what could be causing this.
FTP plugin requires reinstallation every session
Submitted by blalock on Tuesday, 10 February, 2004 - 01:50
Hi -- I'm using the FTP plugin to access files on a remote server using SFTP.
If I start Jedit and then install the plugin, it works fine. However, if I quit and then
restart Jedit, the plugin stops working. When I try to browse by SFTP, I get the "loading...."
messages with the arrows in a circle. Nothing ever happens. If I then use the plugin manager
to remove the FTP plugin and reinstall it, it will start working again for that session.

Any ideas on what's going wrong are appreciated.

I have Mac OS 10.3 with JVE 1.4.2. The problem occurs with all recent versions of
Jedit 4.2.7pre to 4.2.9pre.

Thanks,
-garrick-
Jane usage?
Submitted by aabbaabb on Monday, 9 February, 2004 - 07:29
This might be a bug but I will first try to use this forum.

I have tried everything but I can't get Jane working. I have set Jane to generate both errors.

I have added my project as Jane library (project's build folder).
But it can't see everything I want from my project files. Still I can see some classes from my project.

I have private variable clled myVariable. I use this variable e.g. in constructor but Jane gives me a warning: Cannot resolve symbol: myVariable

I have class where is static methods (MyClass). I am using those methods from my class and Janse warns: Cannot resolve symbol: MyClass

I have private method (method()) what I am using (at least in constructor) and Jane warns: Cannot resolve symbol: method

I am using newest Jane, newest jEdit devel (pre9) and J2SE build 1.4.2_01-b06

Can someone help me to get Jane working
User login
Browse archives
« October 2014  
MoTuWeThFrSaSu
 
1
2
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
24
25
26
27
28
29
30
31
 
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   47010
Context Free Art (*.cfdg)   0.31   37106
JBuilder scheme   .001   11381
R Edit Mode - extensive version   0.1   11301
BBEdit scheme   1.0   10947
ColdFusion scheme   1.0   10936
Advanced HTML edit mode   1.0   10752
Matlab Edit Mode   1.0   10618
jEdit XP icons   1.0   10076
XP icons for jEdit   1.1   9916