jEdit Community - Resources for users of the jEdit Text Editor
Missing plugins
Submitted by BewareofDoug on Sunday, 16 January, 2011 - 15:50
The Plugin Manager doesn't list some important plugins like Beauty and XML. I just downloaded jEdit for Mac today and installed; the editor proper seems to be functional. I wanted to install mwjed, so I begain installing the prereq plugins and I installed several other plugins (e.g. JakartaCommons) without difficulty. I've downloaded the .bin.tgz for each as well and unpacked them but can't find documentation on how to install them that way.

Danke,
Doug
New fonts not showing up
Submitted by MMDeveloper on Thursday, 6 January, 2011 - 15:50
I'm running Windows 7, jEdit 4.3.2, Java 1.6.0_22.

I installed a couple of monospace fonts to try out in jEdit but when I go to Global Options and Text Area, the new fonts don't appear in the list when I try to change the text area font. The new fonts show up fine in other programs (office, photoshop, etc) but they just wont show in jEdit. One of the fonts is a bitmap font and the other is an Open Type Font.

Any ideas?
dead keys
Submitted by silvain on Tuesday, 28 December, 2010 - 15:33
Dead keys of my national keyboard (Swiss French) do not work - neither under Windows nor under linux Ubuntu.
It seems that these keys are not captured at all by jEdit. They do not produce any character – neither by pressing them twice, nor by pressing space afterwards, nor by pressing any other character in order to produce some accentuated character.
Is there any way to solve this problem?
Beautif corrupts doctype
Submitted by jelups on Monday, 27 December, 2010 - 19:49
When beautyfing a html document, the brackets framing the doc type declaration are deleted.
Example:

DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd"

The document name has the suffix .php since it contains some php-code ("include" function). The editing mode in global and buffer settings is set to "html". The plugin options for php and html modes are set to "html.beauty".
How can I prevent this?
(Suse 11.1, jedit 4.3.2)
Kurt
too many apps opening at startup
Submitted by koszta5 on Wednesday, 15 December, 2010 - 21:21
Hey,
I am running jEdit on Mac OS and it got kinda broken on the mac for me. I have like 60 files opening at startup (there was some error at first bu a ignored it and let it run and it caused a one more new empty file to load at startup. Now if I run it with -nosettings I am fine but otherwise it opens and crashes out of memory (obviously).. I couldnt find the file with jEdit preferences on MacOS... no xml saying what files to load on startup... Where is it located on Mac OS? (I know where it is on windows...)
thank you very much
jEdit has a weird look
Submitted by MrPedantic on Sunday, 5 December, 2010 - 18:59
I don't know why, but when I open jEdit now the interface becomes all screwed up on mouse-over, or when I type at the caret. The interface I configured normally has 4 panes: left for console, right for preview of output (I use jEdit with LilypondTool), in the middle for input, and below that I have a pane for midi playback. Except when I mouse over the right pane, or type in the middle pane, I get something that looks like this:

http://img207.imageshack.us/img207/6325/jediterror1.jpg
http://img696.imageshack.us/img696/967/jediterror2.jpg

Sometimes closing and restarting jEdit works; sometimes it doesn't. Last time I had to completely uninstall and reinstall jEdit for the problem to go away, but after I closed jEdit yesterday, opening it up again seems to just bring the problem back.
Indent folding mode error - blank lines
Submitted by patrickb on Wednesday, 1 December, 2010 - 14:14
The behaviour of a line at indent folding should only depend on the number of initial tabs in the line, not on the content of the line.

However, when using indent mode, blank lines are not folded correctly. E.g.
A.
___B.
.
C.

(dots denote end of lines, third line is a blank line, ___ represents a tab) after folding looks like:
A.
C.

However, the blank line is on the same "tab hierarchy" as A and C. Therefore

A.
.
C.

would be correct. Why is this a problem? I use jEdit to edit plain text. Blank lines should serve to separate topics A and C, but after folding, the blank line is folded as well and readability is impaired a lot!

Only a line with tabs should disappear by folding:
A.
___B.
___.
C.

should fold to:
A.
C.

By the way, as a workaround I tried to introduce a space into the blank line to get the folding correct, but this doesn't work. Only lines with real text fold correctly.

Thanks

Patrick
SVNPlugin: Authentication failed
Submitted by Zelos on Tuesday, 16 November, 2010 - 10:10
Hello,

I just installed SVNPlugin version 1.6.0 with dependencies as mentioned in the plugin page. My jedit version is 4.3.2 using java 1.6.0_20.

When I try to access my repository via svn+ssh the SVN console shows "error while listing entries: svn: Authentication required".
However, I tried to provide the username as part of the URL as well as input into the username field. Password is not required since I use a public key file.

It seems that ssh is not called correctly from jedit, restricting authentication to password only (which is not provided) instead of using ssh's default mechanisms.

How can I get this working?

Thanks!
David
Parse error when trying to replace blanks
Submitted by gold-mary on Tuesday, 16 November, 2010 - 08:30
Hi,

I apologize in case this is a duplicate. I searched the forum, but did not find anything which seems to be similar to this issue.

I use jEdit 4.3.2 (Java 1.6.0_22).
Since a few days it is not possible any more to replace blanks. When I select "Text" within the Find dialog, nothing happens. In case I select "Return value of a BeanShell snippet" I get an error:

Parse error at line 3, column 9. Encountered...

Is there anything broken? Or is it just a setting I have to change.


Thanks a lot for your help,

gold-mary
OS X 10.6.5 updates causes jEdit to load in 'Java-ish' look rather than native OS X look
Submitted by altonator on Monday, 15 November, 2010 - 10:40
I've just updated OS X to 10.6.5 and now jEdit doesn't look OSX-ified. In other words, the File, Edit, etc menus are within the jEdit window rather than in the OS X mneu bar.

Other than that it seems to work OK.

Anyone got an ideas as to what's caused this? (I'm guessing it's a Java update that was packaged with the OS X update). And more importantly, can anyone manage to fix it?

Cheers
Altonator
jEdit opens an additional window for additional files
Submitted by Nick Payne on Saturday, 30 October, 2010 - 22:05
Whenever I open an additional file once jEdit is already running, jEdit opens a additional window into which it loads the file. The new window is also slightly displaced on the screen from the previous window. However, both the new window and the previous window allow access to both the new file and any previous files I had open from the drop-down selection menu at the top of the text area. I normally close this new window, as it's not located where I want, and then use the drop-down selection at the top of the text area to bring the new file to the front, which is two extra annoying steps in the process.

How can I stop jEdit from creating a new window. Any additional files I open once jEdit is running, I want them to open in the already existing window. I've had a browse around in the various menus and global options without seeing where this can be set. I'm running jEdit 4.3.2 on Ubuntu 10.10.
jEdit + .ctp files
Submitted by grandioso on Friday, 29 October, 2010 - 23:00
I can't seem to make jEdit highlight any .ctp file syntax as php. (ctp files are used by cakePHP)

I did the following : "Options" -> "editing", chose php, unchecked "use default", changed "file name glob" to "*.{php3,php4,php,phtml,inc,ctp}", saved, restarted app... but still nothing.

Any ideas ? I use Ubuntu 10.04
java update broke jedit 4.3.2 for me
Submitted by jeditcdnguy on Tuesday, 26 October, 2010 - 16:34
I'm running ubuntu jaunty when I got an update today re:java

After the update jedit 4.3.2 stopped working

Here's what happens when I run it in the terminal

terry@beauty:/usr/lib/jvm/java-6-sun-1.6.0.22/jre/bin$ java jedit
Exception in thread "main" java.lang.NoClassDefFoundError: jedit
Caused by: java.lang.ClassNotFoundException: jedit
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: jedit. Program will exit.
sideKick stopped parsing python scripts
Submitted by pixeldroid on Saturday, 23 October, 2010 - 02:31
For some reason, the jEdit Sidekick plugin has stopped parsing my python scripts (no functions, vars, etc.).
For my Python Path in the Jython plugin, I have been using the python executable that is installed with Maya:
C:\Program Files\Autodesk\Composite 2011\program
which has been working fine until yesterday.
I've also tried:
C:\Program Files\Autodesk\Composite 2011 Subscription Advantage Pack\program
Any suggestions for fixing will be appreciated.
Thx
jEdit 4.2 no longer starts - what next?
Submitted by LongtimeUser on Wednesday, 20 October, 2010 - 13:46
Hello all,

I've been using 4.2 for several years because of the plugins for it, and installed it right away on this laptop when I got it 6 months ago. I have it running all the time. Then Monday I installed Plants vs Zombies and after a few hours it froze my computer. After rebooting jEdit will no longer start. As the FAQ suggests I tried moving all the files from .jedit/ (since Win 7 won't let me rename the directory), but that was no help. Java is fine, I can do >java -jar jedit.jar and the CLI gives me another prompt but nothing happens. Then I tried installing 4.3 (in a different location) as a last resort and it seems to have deleted my 4.2 directory - and still won't start up.

Oddly enough I went back to a previous laptop and found that 4.2 won't start up on that one either.

A) Anyone else had this happen?
B) Anything else I can try to get 4.2 working again?
C) What's the procedure for a clean install?
D) Or a side-by-side install with multiple jEdit versions?

Thanks!
save function in jedit after installing ssd very slow
Submitted by oe7 on Sunday, 3 October, 2010 - 12:55
Hi,
I'am new to this forum. Using jedit for some jears, recently on a macbook pro with Mac OS 10.6.4. Now I've changed my internal harddrive into a ssd- everything works faster- except jedit which works slower- when I hit the save shortcut it takes 5 seconds until the file is saved (and also the lilypondtool plugin does react very delayed).
Any idea whats going on?

thanks,

ole
jEdit opens formerly not opened files at startup
Submitted by gtecsoy on Sunday, 3 October, 2010 - 00:00
Dear Developers and Forum Members!

I am a newbie in jEdit. It seems to me very good. Thank you for your efforts and excellent work.

I have a small problem with it. At startup the system loads that kind of files which were never opened.

It loads those files, which are in my user profile directory (C:\Documents and Settings\xxxxx\).

I am using:
1:32:35 AM [main] [message] Log: When reporting bugs, please include the following information:
1:32:35 AM [main] [message] Log: java.version=1.6.0_21
1:32:35 AM [main] [message] Log: java.vm.version=17.0-b17
1:32:35 AM [main] [message] Log: java.runtime.version=1.6.0_21-b07
1:32:35 AM [main] [message] Log: java.vendor=Sun Microsystems Inc.
1:32:35 AM [main] [message] Log: java.compiler=null
1:32:35 AM [main] [message] Log: os.name=Windows XP
1:32:35 AM [main] [message] Log: os.version=5.1
1:32:35 AM [main] [message] Log: os.arch=x86
1:32:35 AM [main] [message] Log: user.home=C:\Documents and Settings\xxxxx
1:32:35 AM [main] [message] Log: java.home=C:\Program Files\Java\jre6
1:32:35 AM [main] [message] Log: java.class.path=E:\My Installations\jEdit\jedit.jar
1:32:35 AM [main] [notice] jEdit: jEdit version 4.3.2
1:32:35 AM [main] [message] jEdit: Settings directory is C:\Documents and Settings\xxxxx\.jedit
1:32:35 AM [main] [message] jEdit: jEdit home directory is E:\My Installations\jEdit

When I check the settings directory (C:\Documents and Settings\xxxxx\.jedit) I have to realize, that the system writes never opened files to perspective.xml and recent.xml files all time.
I have deleted those files from the mentioned xml files and the files from settings-backup but it did not solve the problem.

The "Restore previously open files on startup" option is set up.

Thank you for your kindest help.
Can't save long files with FTP Plugin
Submitted by glukgluk on Monday, 6 September, 2010 - 17:56
Hey guys,

I have worked with jEdit and the FTP plugin now for a while and never have had any problems.
But since I have installed a 64 Bit version, the saving on my remote server doesnt work anymore.
Strangely, it works with small files (less than 200 characters or so) but not with larger.
The error I get seems as following: "Cannot save: java.io.IOException: Rename failed: [path]#[filename]#save#.
Where the heck do these # come from?
I also have tried with disabled "two-stage save" but the result was the same as before, in addition to the fact that I havent received any error message.

I really despair of this problem because whats more, I have lost some important files irrevocable.
Please help me! Otherwise I'll have to look for another program.
jEdit 4.3.2 delays Windows XP startup
Submitted by tomasio on Saturday, 28 August, 2010 - 09:05
I am using jEdit on a PC with Windows XP SP3 installed. Since I have upgraded to jEdit 4.3.2 after booting a jEdit Splash Screen appears which seems to delay the startup process of Win XP. My girlfriend has the same Splash Screen when she logs in with her user account - would it be possible to deactivate this unwanted pre-loading at least on her user account?

Thank you for your advice.

kind regards,
--
tomasio
Plugin CScopeFinder error : cscope.out: File not found
Submitted by chrdou on Tuesday, 24 August, 2010 - 16:13
I am using jEdit 4.3.2 + CScopeFinder 0.3 and I have exactly the same problem as described in page http://old.nabble.com/CScopeFinder-Plugin-td16526207.html where the problem remained unsolved apparently.

It means that the plugin doesn't find the file though the path is correct and the file present.


I didn't found any related infos neither on internet nor on jEdit Community site.

Is it a known problem ?

Thanks for your help.
User login
Browse archives
« November 2014  
MoTuWeThFrSaSu
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Poll
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
26%
Yes, I'd like to have translations
33%
Indifferent
35%
No, that'd be bad (please comment)
7%
Total votes: 1092
Syndication
file   ver   dls
German Localization light   4.4.2.1   47175
Context Free Art (*.cfdg)   0.31   37188
JBuilder scheme   .001   11536
R Edit Mode - extensive version   0.1   11379
BBEdit scheme   1.0   11101
ColdFusion scheme   1.0   11090
Advanced HTML edit mode   1.0   10831
Matlab Edit Mode   1.0   10696
jEdit XP icons   1.0   10156
XP icons for jEdit   1.1   9956