jEdit Community - Resources for users of the jEdit Text Editor
jEdit stopped working after intall of Internet Explorer 9
Submitted by oscillator on Wednesday, 16 March, 2011 - 15:36
Dear forum,

yesterday I installed IE9 on my Win7Pro computer. Since then jEdit has stopped working.

I have reinstalled JRE and jEdit but no luch. I have also switched IE9 off.

If I paste the content of the jedit.bat file:

start "jEdit startup" "C:\Windows\SysWOW64\javaw.exe" -Xmx192M -jar "C:\Program Files\jEdit\jedit.jar" -reuseview %*

into a command window I don't get any error messages, only a new prompt. No jEdit window.

A "javaw.exe*32" process I started though.

Any ideas?

new guy having problems with java.awt.point
Submitted by stefandanielsen on Tuesday, 1 March, 2011 - 08:26
hey hey guyes... im verry new with jedit and is working my way forward in the programing... i hit a problem... im writing a small program and when im compile it there is no problem but when i try to run it the terminal says this :

stefan-danielsens-macbook-pro:java stefandanielsen$ java Setpoints
Exception in thread "main" java.lang.NoClassDefFoundError: Setpoints (wrong name: setPoints)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
stefan-danielsens-macbook-pro:java stefandanielsen$ java Setpoints
Exception in thread "main" java.lang.NoClassDefFoundError: Setpoints (wrong name: setPoints)
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(

pleas help me .... what am i doing wrong???
Marks are not saved properly
Submitted by fstephens on Monday, 28 February, 2011 - 17:45
I have a constant problem with the marks for a buffer being wrong.
They seem to be shifted to random lines. This does not seem to be related to adding/removing lines in the text area.
Is there a solution to this, or at least a way to easily re-mark all functions?
Missing Docking Menus on Plugin Windows?
Submitted by andrewleer on Friday, 18 February, 2011 - 04:20

Thank you,
Andrew J. Leer
External Browser Command for MAC
Submitted by mj3dvfx on Tuesday, 1 February, 2011 - 05:17
Hello everyone.

I'm brand new to using jEdit and have been slowly but surely setting things up. I recently ran into an issue trying to setup my InfoViewer plugin
to call an external browser (firefox) for my Maya Editor Display Docs menu item. I'm on a mac and have looked for examples both here and randomly
on the internet, but haven't seen anything that can help.

I open up jEdit, go to Plugins, choose Plugin Options, switch my browser options to External Browser and for the External Browser Command I type in the
path to where the firefox application lives - Macintosh HD/Applications/ When I go to Plugins >> Maya Editor >> Display Docs I keep getting
this following error or some variation thereof.


An Exception occured while starting the browser: Cannot run program "Macintosh": error=2, No such file or directory

The command was:

file:/Macintosh HD/Applications/Autodesk/maya2011/docs/Maya2011/en_US/Commands/null.html


Maybe I'm not putting in the proper path naming convention for mac or something, but If anyone can point me in the right direction on how to fix this issue I would greatly appreciate it.

Thanks in advance.
Console passes wrong file name to Error List
Submitted by Clavius on Tuesday, 25 January, 2011 - 22:32
I'm using the Console plug-in to parse my compiler messages and display errors in Error List plug-in. This works fine except the Error List incorrectly displays the file name and path.

In the Console error patterns menu, I specify the following:
Name: VHDL
Regexp: (.+):..+\\([^\\]+)\.vhd\ *\((\d+)\)Sad.+)
Warning regexp: leave empty
Extra lines regexp: leave empty
Filename: $f
Line number: $3
Error message: $4

Here's a sample of the compiler output displayed in the Console:

-- Compiling architecture behavior of tb_system_monitor
** Error: C:\Projects\tb_system_monitor.vhd (171): (vcom-1272) Length of expected is 8.

The Error List shows the correct error, but gets the file path wrong and forgets to include the file extension (.vhd).

C:\Program Files\jEdit\tb_system_monitor (1 error, 0 warnings)
171: ** Error: C (vcom-1272) Length of expected is 8.

I tried changing the Console Filename parameter from "$f", but nothing I did had any effect on the file name reported in the Error List. Is the Filename parameter passed to the Error List?

Jedit Problems on Ubuntu 10.10
Submitted by gdonwallace on Monday, 17 January, 2011 - 23:18
This started about 2 weeks ago. When I try to start Jedit I get the following errors: Exception in thread "main" java.awt.HeadlessException at sun.awt.HeadlessToolkit.getScreenSize( at org.gjt.sp.jedit.gui.SplashScreen.( at org.gjt.sp.jedit.GUIUtilities.showSplashScreen( at org.gjt.sp.jedit.jEdit.main( I am not able to launch Jedit from the menu entry, as I think it is doing the same thing. When I try to launch from command line, this is what I get. I am just typing "jedit" and pressing enter. Also, I can open Nautilus, navigate to jedit, right click and choose "Open with sun java 6 runtime" and it works fine. Should I be using any command line switches? thanks for any help or suggestions.
Missing plugins
Submitted by BewareofDoug on Sunday, 16 January, 2011 - 15:50
The Plugin Manager doesn't list some important plugins like Beauty and XML. I just downloaded jEdit for Mac today and installed; the editor proper seems to be functional. I wanted to install mwjed, so I begain installing the prereq plugins and I installed several other plugins (e.g. JakartaCommons) without difficulty. I've downloaded the .bin.tgz for each as well and unpacked them but can't find documentation on how to install them that way.

New fonts not showing up
Submitted by MMDeveloper on Thursday, 6 January, 2011 - 15:50
I'm running Windows 7, jEdit 4.3.2, Java 1.6.0_22.

I installed a couple of monospace fonts to try out in jEdit but when I go to Global Options and Text Area, the new fonts don't appear in the list when I try to change the text area font. The new fonts show up fine in other programs (office, photoshop, etc) but they just wont show in jEdit. One of the fonts is a bitmap font and the other is an Open Type Font.

Any ideas?
dead keys
Submitted by silvain on Tuesday, 28 December, 2010 - 15:33
Dead keys of my national keyboard (Swiss French) do not work - neither under Windows nor under linux Ubuntu.
It seems that these keys are not captured at all by jEdit. They do not produce any character – neither by pressing them twice, nor by pressing space afterwards, nor by pressing any other character in order to produce some accentuated character.
Is there any way to solve this problem?
Beautif corrupts doctype
Submitted by jelups on Monday, 27 December, 2010 - 19:49
When beautyfing a html document, the brackets framing the doc type declaration are deleted.


The document name has the suffix .php since it contains some php-code ("include" function). The editing mode in global and buffer settings is set to "html". The plugin options for php and html modes are set to "".
How can I prevent this?
(Suse 11.1, jedit 4.3.2)
too many apps opening at startup
Submitted by koszta5 on Wednesday, 15 December, 2010 - 21:21
I am running jEdit on Mac OS and it got kinda broken on the mac for me. I have like 60 files opening at startup (there was some error at first bu a ignored it and let it run and it caused a one more new empty file to load at startup. Now if I run it with -nosettings I am fine but otherwise it opens and crashes out of memory (obviously).. I couldnt find the file with jEdit preferences on MacOS... no xml saying what files to load on startup... Where is it located on Mac OS? (I know where it is on windows...)
thank you very much
jEdit has a weird look
Submitted by MrPedantic on Sunday, 5 December, 2010 - 18:59
I don't know why, but when I open jEdit now the interface becomes all screwed up on mouse-over, or when I type at the caret. The interface I configured normally has 4 panes: left for console, right for preview of output (I use jEdit with LilypondTool), in the middle for input, and below that I have a pane for midi playback. Except when I mouse over the right pane, or type in the middle pane, I get something that looks like this:

Sometimes closing and restarting jEdit works; sometimes it doesn't. Last time I had to completely uninstall and reinstall jEdit for the problem to go away, but after I closed jEdit yesterday, opening it up again seems to just bring the problem back.
Indent folding mode error - blank lines
Submitted by patrickb on Wednesday, 1 December, 2010 - 14:14
The behaviour of a line at indent folding should only depend on the number of initial tabs in the line, not on the content of the line.

However, when using indent mode, blank lines are not folded correctly. E.g.

(dots denote end of lines, third line is a blank line, ___ represents a tab) after folding looks like:

However, the blank line is on the same "tab hierarchy" as A and C. Therefore


would be correct. Why is this a problem? I use jEdit to edit plain text. Blank lines should serve to separate topics A and C, but after folding, the blank line is folded as well and readability is impaired a lot!

Only a line with tabs should disappear by folding:

should fold to:

By the way, as a workaround I tried to introduce a space into the blank line to get the folding correct, but this doesn't work. Only lines with real text fold correctly.


SVNPlugin: Authentication failed
Submitted by Zelos on Tuesday, 16 November, 2010 - 10:10

I just installed SVNPlugin version 1.6.0 with dependencies as mentioned in the plugin page. My jedit version is 4.3.2 using java 1.6.0_20.

When I try to access my repository via svn+ssh the SVN console shows "error while listing entries: svn: Authentication required".
However, I tried to provide the username as part of the URL as well as input into the username field. Password is not required since I use a public key file.

It seems that ssh is not called correctly from jedit, restricting authentication to password only (which is not provided) instead of using ssh's default mechanisms.

How can I get this working?

Parse error when trying to replace blanks
Submitted by gold-mary on Tuesday, 16 November, 2010 - 08:30

I apologize in case this is a duplicate. I searched the forum, but did not find anything which seems to be similar to this issue.

I use jEdit 4.3.2 (Java 1.6.0_22).
Since a few days it is not possible any more to replace blanks. When I select "Text" within the Find dialog, nothing happens. In case I select "Return value of a BeanShell snippet" I get an error:

Parse error at line 3, column 9. Encountered...

Is there anything broken? Or is it just a setting I have to change.

Thanks a lot for your help,

OS X 10.6.5 updates causes jEdit to load in 'Java-ish' look rather than native OS X look
Submitted by altonator on Monday, 15 November, 2010 - 10:40
I've just updated OS X to 10.6.5 and now jEdit doesn't look OSX-ified. In other words, the File, Edit, etc menus are within the jEdit window rather than in the OS X mneu bar.

Other than that it seems to work OK.

Anyone got an ideas as to what's caused this? (I'm guessing it's a Java update that was packaged with the OS X update). And more importantly, can anyone manage to fix it?

jEdit opens an additional window for additional files
Submitted by Nick Payne on Saturday, 30 October, 2010 - 22:05
Whenever I open an additional file once jEdit is already running, jEdit opens a additional window into which it loads the file. The new window is also slightly displaced on the screen from the previous window. However, both the new window and the previous window allow access to both the new file and any previous files I had open from the drop-down selection menu at the top of the text area. I normally close this new window, as it's not located where I want, and then use the drop-down selection at the top of the text area to bring the new file to the front, which is two extra annoying steps in the process.

How can I stop jEdit from creating a new window. Any additional files I open once jEdit is running, I want them to open in the already existing window. I've had a browse around in the various menus and global options without seeing where this can be set. I'm running jEdit 4.3.2 on Ubuntu 10.10.
jEdit + .ctp files
Submitted by grandioso on Friday, 29 October, 2010 - 23:00
I can't seem to make jEdit highlight any .ctp file syntax as php. (ctp files are used by cakePHP)

I did the following : "Options" -> "editing", chose php, unchecked "use default", changed "file name glob" to "*.{php3,php4,php,phtml,inc,ctp}", saved, restarted app... but still nothing.

Any ideas ? I use Ubuntu 10.04
java update broke jedit 4.3.2 for me
Submitted by jeditcdnguy on Tuesday, 26 October, 2010 - 16:34
I'm running ubuntu jaunty when I got an update today re:java

After the update jedit 4.3.2 stopped working

Here's what happens when I run it in the terminal

terry@beauty:/usr/lib/jvm/java-6-sun-$ java jedit
Exception in thread "main" java.lang.NoClassDefFoundError: jedit
Caused by: java.lang.ClassNotFoundException: jedit
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
Could not find the main class: jedit. Program will exit.
User login
Browse archives
« February 2018  
Are you interested in language packs for jEdit?
Yes, and I could help maintain translations
Yes, I'd like to have translations
No, that'd be bad (please comment)
Total votes: 1092
file   ver   dls
German Localization light   51053
Context Free Art (*.cfdg)   0.31   41260
JBuilder scheme   .001   17053
BBEdit scheme   1.0   16658
ColdFusion scheme   1.0   16636
R Edit Mode - extensive version   0.1   14919
Advanced HTML edit mode   1.0   14092
Matlab Edit Mode   1.0   14038
jEdit XP icons   1.0   13463
XP icons for jEdit   1.1   12487